aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2024-06-30 09:47:23 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2024-06-30 09:47:23 +0000
commitebcf92ebfe8276f3af04945355b5f8984b5be33e (patch)
tree54a58320839c16e086be887fb07fd1c4fae06593
parente89748e0ca32e838e041b47d011d21e8bed7e95c (diff)
net/netatalk3: Update to 3.2.1
See https://github.com/Netatalk/netatalk/releases/tag/netatalk-3-2-1 for a list of changes in this release. Security: CVE-2024-38439 CVE-2024-38440 CVE-2024-38441
-rw-r--r--net/netatalk3/Makefile46
-rw-r--r--net/netatalk3/distinfo6
-rw-r--r--net/netatalk3/files/patch-config_meson.build6
-rw-r--r--net/netatalk3/files/patch-contrib_shell__utils_meson.build14
-rw-r--r--net/netatalk3/files/patch-meson.build43
5 files changed, 57 insertions, 58 deletions
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index d35069e8afda..8e551124b8ff 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -1,6 +1,5 @@
PORTNAME= netatalk
-PORTVERSION= 3.2.0
-PORTREVISION= 1
+PORTVERSION= 3.2.1
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/netatalk-${PORTVERSION:S/./-/g}/
@@ -21,15 +20,14 @@ USE_RC_SUBR= netatalk
#INSTALL_TARGET=install-strip
CPE_VENDOR= netatalk_project
-MESON_ARGS= -Dwith-libgcrypt-dir=${LOCALBASE} \
- -Dwith-bdb=${LOCALBASE} \
- -Dwith-libiconv=${LOCALBASE} \
- -Dwith-ssl-dir=${OPENSSLBASE} \
+MESON_ARGS= -Dwith-libgcrypt-path=${LOCALBASE} \
+ -Dwith-bdb-path=${LOCALBASE} \
+ -Dwith-libiconv-path=${LOCALBASE} \
-Dwith-dtrace=false \
- -Ddisable-init-hooks=true \
+ -Dwith-init-hooks=false \
-Dpkg_config_path=${LOCALBASE}/libdata/pkgconfig \
- -Dwith-shadow=disabled \
- -Denable-pgp-uam=disabled \
+ -Dwith-shadow=false \
+ -Dwith-pgp-uam=false \
--localstatedir=/var \
--infodir=${PREFIX}/share/info
@@ -43,38 +41,38 @@ SENDFILE_DESC= Enable Sendfile support
ACL_DESC= Enable ACL support
SPOTLIGHT_DESC= Enable Spotlight search support
OPTIONS_SUB= yes
-KERBEROS5_MESON_ON= -Denable-krbV-uam=enabled \
- -Dwith-kerberos=enabled
-KERBEROS5_MESON_OFF= -Denable-krbV-uam=disabled \
- -Dwith-kerberos=disabled
+KERBEROS5_MESON_ON= -Dwith-krbV-uam=true \
+ -Dwith-kerberos=true
+KERBEROS5_MESON_OFF= -Dwith-krbV-uam=false \
+ -Dwith-kerberos=false
KERBEROS_LIB_DEPENDS=libgpg-error.so:security/libgpg-error
-PAM_MESON_ON= -Dwith-pam=${LOCALBASE}
-PAM_MESON_OFF= -Dwithout-pam=true
+PAM_MESON_ON= -Dwith-pam-path=${LOCALBASE}
+PAM_MESON_OFF= -Dwith-pam=false
AVAHI_CFLAGS= -I${LOCALBASE}/include -L${LOCALBASE}/lib
AVAHI_LIB_DEPENDS= libavahi-client.so:net/avahi-app
AVAHI_SUB_LIST= ZEROCONF="avahi_daemon"
MDNSRESPONDER_CFLAGS= -I${LOCALBASE}/include -L${LOCALBASE}/lib
MDNSRESPONDER_LIB_DEPENDS= libdns_sd.so:net/mDNSResponder
MDNSRESPONDER_SUB_LIST= ZEROCONF="mdnsd"
-LDAP_MESON_ON= -Dwith-ldap=${LOCALBASE}
+LDAP_MESON_ON= -Dwith-ldap-path=${LOCALBASE}
LDAP_CFLAGS= -I${LOCALBASE}/include -L${LOCALBASE}/lib
LDAP_USES= ldap
-SENDFILE_MESON_OFF=-Ddisable-sendfile=true
+SENDFILE_MESON_OFF=-Dwith-sendfile=false
DBUS_USES= gnome python
DBUS_USE= GNOME=glib20
DBUS_LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libdbus-1.so:devel/dbus
DBUS_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/dbus/_dbus.py:devel/py-dbus@${PY_FLAVOR}
-DBUS_MESON_ON= -Dwith-dbus-daemon=${LOCALBASE}/bin/dbus-daemon \
- -Dwith-dbus-sysconf-dir=${LOCALBASE}/etc/dbus-1/system.d
-DBUS_MESON_OFF= -Dwith-afpstats=disabled
+DBUS_MESON_ON= -Dwith-dbus-daemon-path=${LOCALBASE}/bin/dbus-daemon \
+ -Dwith-dbus-sysconf-path=${LOCALBASE}/etc/dbus-1/system.d
+DBUS_MESON_OFF= -Dwith-afpstats=false
MYSQL_USES= mysql
MYSQL_MESON_OFF=-Dwith-mysql-config=/nonexistent
ACL_LIB_DEPENDS= libsunacl.so:sysutils/libsunacl
-ACL_MESON_ENABLED=with-acls
-LIBWRAP_MESON_OFF=-Ddisable-tcp-wrappers=true
+ACL_MESON_OFF=-Dwith-acls=false
+LIBWRAP_MESON_OFF=-Dwith-tcp-wrappers=false
SPOTLIGHT_LIB_DEPENDS= libtracker-sparql-3.0.so:sysutils/tracker3
-SPOTLIGHT_MESON_OFF= -Dwith-spotlight=disabled
+SPOTLIGHT_MESON_OFF= -Dwith-spotlight=false
SHEBANG_GLOB= afpstats
@@ -84,7 +82,7 @@ CONFLICTS= jday yudit # bin/dbd man/man1/uniconv.1.gz
.if ${PORT_OPTIONS:MAVAHI}=="" && ${PORT_OPTIONS:MMDNSRESPONDER}==""
SUB_LIST+= ZEROCONF=""
-MESON_ARGS+=-Denable-zeroconf=disabled
+MESON_ARGS+=-Dwith-zeroconf=false
.endif
post-patch:
diff --git a/net/netatalk3/distinfo b/net/netatalk3/distinfo
index 93e2d66a8051..887dc6cf4088 100644
--- a/net/netatalk3/distinfo
+++ b/net/netatalk3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1718627379
-SHA256 (netatalk-3.2.0.tar.xz) = 0c2b4b47450bc7ac95a268d1033471f572a3e06b64131fcef9b66e73663b6d08
-SIZE (netatalk-3.2.0.tar.xz) = 1927124
+TIMESTAMP = 1719739026
+SHA256 (netatalk-3.2.1.tar.xz) = 166efe3c282e385fdc6118b002d74a78c1b95561aa6f170ad0f210e5255b516c
+SIZE (netatalk-3.2.1.tar.xz) = 1919812
diff --git a/net/netatalk3/files/patch-config_meson.build b/net/netatalk3/files/patch-config_meson.build
index fa35b01c47cf..d5f5cd2d763d 100644
--- a/net/netatalk3/files/patch-config_meson.build
+++ b/net/netatalk3/files/patch-config_meson.build
@@ -1,4 +1,4 @@
---- config/meson.build.orig 2024-06-01 04:56:52 UTC
+--- config/meson.build.orig 2024-06-29 05:58:36 UTC
+++ config/meson.build
@@ -7,23 +7,16 @@ custom_target(
custom_target(
@@ -14,7 +14,7 @@
-if (
- not fs.exists(pkgconfdir / 'afp.conf')
-- or (get_option('enable-overwrite') and fs.exists(pkgconfdir / 'afp.conf'))
+- or (get_option('with-overwrite') and fs.exists(pkgconfdir / 'afp.conf'))
-)
- install_data(afp_conf, install_dir: pkgconfdir)
-else
@@ -25,5 +25,5 @@
-install_data('extmap.conf', install_dir: pkgconfdir)
+install_data('extmap.conf', rename: 'extmap.conf.sample', install_dir: pkgconfdir)
- install_data('netatalk-dbus.conf', install_dir: dbus_sysconf_dir)
+ install_data('netatalk-dbus.conf', install_dir: dbus_sysconf_path)
diff --git a/net/netatalk3/files/patch-contrib_shell__utils_meson.build b/net/netatalk3/files/patch-contrib_shell__utils_meson.build
deleted file mode 100644
index 966e3b61a6cc..000000000000
--- a/net/netatalk3/files/patch-contrib_shell__utils_meson.build
+++ /dev/null
@@ -1,14 +0,0 @@
---- contrib/shell_utils/meson.build.orig 2024-06-17 15:52:57 UTC
-+++ contrib/shell_utils/meson.build
-@@ -24,8 +24,8 @@ endif
- install_data(asipstatus_script, install_dir: bindir)
- endif
-
--install_data('fce_ev_script.sh', install_dir: bindir)
-+#install_data('fce_ev_script.sh', install_dir: bindir)
-
--install_data('make-casetable.pl', install_dir: bindir)
-+#install_data('make-casetable.pl', install_dir: bindir)
-
--install_data('make-precompose.h.pl', install_dir: bindir)
-+#install_data('make-precompose.h.pl', install_dir: bindir)
diff --git a/net/netatalk3/files/patch-meson.build b/net/netatalk3/files/patch-meson.build
index ce0550a44aab..b72a231638a8 100644
--- a/net/netatalk3/files/patch-meson.build
+++ b/net/netatalk3/files/patch-meson.build
@@ -1,4 +1,4 @@
---- meson.build.orig 2024-06-01 04:56:52 UTC
+--- meson.build.orig 2024-06-29 05:58:36 UTC
+++ meson.build
@@ -40,6 +40,7 @@ sbindir = prefix / get_option('sbindir')
mandir = prefix / get_option('mandir')
@@ -9,7 +9,7 @@
##################
# Compiler flags #
@@ -70,7 +71,7 @@ statedir = '-D_PATH_STATEDIR="' + localstatedir + '/ne
- dversion = '-DVERSION="' + version + '"'
+ dversion = '-DVERSION="' + netatalk_version + '"'
messagedir = '-DSERVERTEXT="' + localstatedir + '/netatalk/msg/"'
statedir = '-D_PATH_STATEDIR="' + localstatedir + '/netatalk/"'
-uamdir = '-D_PATH_AFPDUAMPATH="' + libdir + '/netatalk/"'
@@ -17,15 +17,15 @@
############
# Includes #
-@@ -367,6 +368,7 @@ bdb_subdirs = [
+@@ -385,6 +386,7 @@ bdb_subdirs = [
'/usr',
]
bdb_subdirs = [
-+ '%%DB_NAME%%',
++ 'db18',
'db4.6',
'db4.7',
'db4.8',
-@@ -487,6 +489,11 @@ if crypt.found()
+@@ -504,6 +506,11 @@ if crypt.found()
if crypt.found()
cdata.set('HAVE_CRYPT_H', 1)
cdata.set('HAVE_LIBCRYPT', 1)
@@ -37,7 +37,7 @@
endif
des = cc.find_library('des', required: false)
-@@ -763,19 +770,7 @@ else
+@@ -822,19 +829,7 @@ else
required: false,
)
@@ -58,27 +58,42 @@
cdata.set('HAVE_TRACKER3', 1)
cdata.set(
'TRACKER_MANAGING_COMMAND',
-@@ -816,15 +811,16 @@ else
+@@ -875,7 +870,6 @@ else
endif
endif
endif
-endif
--
--have_spotlight = (
-+ have_spotlight = (
+
+ have_spotlight = (
tracker_sparql.found()
- and tracker_ok
- and talloc.found()
+@@ -884,6 +878,8 @@ have_spotlight = (
and flex.found()
and bison.found()
)
+endif
+
-+
if have_spotlight
cdata.set('WITH_SPOTLIGHT', 1)
endif
-@@ -1833,6 +1829,8 @@ int deny_severity = 0;
+@@ -1370,7 +1366,7 @@ if iconv_path != ''
+ endif
+ iconv = declare_dependency(
+ link_args: libiconv_link_args,
+- include_directories: include_directories(with_libiconv / 'include'),
++ include_directories: include_directories(iconv_path / 'include'),
+ )
+ endif
+
+@@ -1683,7 +1679,7 @@ else
+ have_shadow = false
+ else
+ have_shadow = (cc.has_header('shadow.h'))
+- if with_shadow
++ if enable_shadow
+ cdata.set('SHADOWPW', 1)
+ uams_options += ' SHADOW'
+ else
+@@ -1926,6 +1922,8 @@ int deny_severity = 0;
tcpwrap_code = '''
int allow_severity = 0;
int deny_severity = 0;