aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMilan Obuch <bsd@dino.sk>2024-06-05 14:50:20 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2024-06-05 14:51:52 +0000
commitec694eb958eec07bcac25a19d37a6d6c15a65871 (patch)
tree22fd39de23fe3bd2dbf981f1d7387cddb02e55a6
parent5b84a5ddb7990eafe253deee046f1bf3bbe52c65 (diff)
downloadports-ec694eb958eec07bcac25a19d37a6d6c15a65871.tar.gz
ports-ec694eb958eec07bcac25a19d37a6d6c15a65871.zip
mail/claws-mail: Update to 3.20.0/4.2.0
- Resurrect fancy plugin for the GTK 3 version of Claws Mail. - Clean up dependencies. - Disable GDK deprecation warnings flooding the build log. - Enable i18n of the plugins. - Enable parallel build of plugins. PR: 275236 Approved by: Chris Hutchinson <portmaster@bsdforge.com> (maintainer)
-rw-r--r--mail/Makefile1
-rw-r--r--mail/claws-mail-fancy/Makefile20
-rw-r--r--mail/claws-mail-fancy/pkg-descr1
-rw-r--r--mail/claws-mail-gdata/Makefile2
-rw-r--r--mail/claws-mail-litehtml_viewer/Makefile8
-rw-r--r--mail/claws-mail-managesieve/Makefile2
-rw-r--r--mail/claws-mail-notification/Makefile8
-rw-r--r--mail/claws-mail-pdf_viewer/Makefile3
-rw-r--r--mail/claws-mail-perl/Makefile4
-rw-r--r--mail/claws-mail-pgp/Makefile3
-rw-r--r--mail/claws-mail-plugins/Makefile3
-rw-r--r--mail/claws-mail-rssyl/Makefile3
-rw-r--r--mail/claws-mail-vcalendar/Makefile10
-rw-r--r--mail/claws-mail/Makefile35
-rw-r--r--mail/claws-mail/Makefile.claws31
-rw-r--r--mail/claws-mail/Makefile.ver4
-rw-r--r--mail/claws-mail/distinfo11
-rw-r--r--mail/claws-mail/pkg-plist2
18 files changed, 86 insertions, 65 deletions
diff --git a/mail/Makefile b/mail/Makefile
index c33cfabb52fa..cc516fb3e555 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -48,6 +48,7 @@
SUBDIR += claws-mail-bsfilter
SUBDIR += claws-mail-clamd
SUBDIR += claws-mail-dillo
+ SUBDIR += claws-mail-fancy
SUBDIR += claws-mail-fetchinfo
SUBDIR += claws-mail-gdata
SUBDIR += claws-mail-keyword_warner
diff --git a/mail/claws-mail-fancy/Makefile b/mail/claws-mail-fancy/Makefile
new file mode 100644
index 000000000000..5dad108b71e1
--- /dev/null
+++ b/mail/claws-mail-fancy/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= fancy
+
+COMMENT= Webkit based HTML renderer plugin for Claws Mail
+WWW= https://www.claws-mail.org/plugins.php
+
+LIB_DEPENDS= libcurl.so:ftp/curl
+
+.include "../claws-mail/Makefile.ver"
+
+.if ${MASTER_OPTIONS:MGTK2}
+IGNORE= depends on www/webkit-gtk2, which has been removed
+.endif
+.if ${MASTER_OPTIONS:MGTK3}
+LIB_DEPENDS+= libwebkit2gtk-4.0.so:www/webkit2-gtk3
+.endif
+
+CLAWS_PLUGINS_BUILD= ${PORTNAME}
+
+.include "../claws-mail/Makefile.claws"
+.include <bsd.port.mk>
diff --git a/mail/claws-mail-fancy/pkg-descr b/mail/claws-mail-fancy/pkg-descr
new file mode 100644
index 000000000000..f30f50aeeae7
--- /dev/null
+++ b/mail/claws-mail-fancy/pkg-descr
@@ -0,0 +1 @@
+This plugin renders HTML e-mail using the WebKit library.
diff --git a/mail/claws-mail-gdata/Makefile b/mail/claws-mail-gdata/Makefile
index 231131418769..ef7d1f43ec5a 100644
--- a/mail/claws-mail-gdata/Makefile
+++ b/mail/claws-mail-gdata/Makefile
@@ -7,5 +7,7 @@ LIB_DEPENDS= libgdata.so:devel/libgdata
CLAWS_PLUGINS_BUILD= ${PORTNAME}
+IGNORE= temporarily removed from Claws Mail build
+
.include "../claws-mail/Makefile.claws"
.include <bsd.port.mk>
diff --git a/mail/claws-mail-litehtml_viewer/Makefile b/mail/claws-mail-litehtml_viewer/Makefile
index 428d80352bf5..b66c1561dff7 100644
--- a/mail/claws-mail-litehtml_viewer/Makefile
+++ b/mail/claws-mail-litehtml_viewer/Makefile
@@ -3,12 +3,16 @@ PORTNAME= litehtml_viewer
COMMENT= Viewer plugin for HTML emails, using the litehtml library
WWW= https://www.claws-mail.org/plugins.php
-USES+= compiler:c++11-lang gnome
-USE_GNOME= cairo glib20
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
libgumbo.so:devel/gumbo \
libcurl.so:ftp/curl
+USE_GNOME= cairo glib20
+
+# The configure script does not set REAL_CXX if CXX contains an absolute path.
+CONFIGURE_ENV= REAL_CXX="${CXX}"
+
CLAWS_PLUGINS_BUILD= ${PORTNAME}
post-configure:
diff --git a/mail/claws-mail-managesieve/Makefile b/mail/claws-mail-managesieve/Makefile
index 1d416e3f8713..977c32d7aa59 100644
--- a/mail/claws-mail-managesieve/Makefile
+++ b/mail/claws-mail-managesieve/Makefile
@@ -3,6 +3,8 @@ PORTNAME= managesieve
COMMENT= Sieve filters manager for Claws Mail
WWW= https://www.claws-mail.org/plugin.php?plugin=managesieve
+LIB_DEPENDS= libcurl.so:ftp/curl
+
CLAWS_PLUGINS_BUILD= ${PORTNAME}
.include "../claws-mail/Makefile.claws"
diff --git a/mail/claws-mail-notification/Makefile b/mail/claws-mail-notification/Makefile
index f565f1c082a8..0acd46e7bb1c 100644
--- a/mail/claws-mail-notification/Makefile
+++ b/mail/claws-mail-notification/Makefile
@@ -3,17 +3,17 @@ PORTNAME= notification
COMMENT= New mail notification plugin for Claws Mail
WWW= https://www.claws-mail.org/plugin.php?plugin=notification
+LIB_DEPENDS= libnotify.so:devel/libnotify
+
.include "../claws-mail/Makefile.ver"
.if ${MASTER_OPTIONS:MGTK2}
-LIB_DEPENDS= libcanberra-gtk.so:audio/libcanberra-gtk2
+LIB_DEPENDS+= libcanberra-gtk.so:audio/libcanberra-gtk2
.endif
.if ${MASTER_OPTIONS:MGTK3}
-LIB_DEPENDS= libcanberra-gtk3.so:audio/libcanberra-gtk3
+LIB_DEPENDS+= libcanberra-gtk3.so:audio/libcanberra-gtk3
.endif
-LIB_DEPENDS+= libnotify.so:devel/libnotify
-
CLAWS_PLUGINS_BUILD= ${PORTNAME}
.include "../claws-mail/Makefile.claws"
diff --git a/mail/claws-mail-pdf_viewer/Makefile b/mail/claws-mail-pdf_viewer/Makefile
index 4d313918b021..2ef43f8515ec 100644
--- a/mail/claws-mail-pdf_viewer/Makefile
+++ b/mail/claws-mail-pdf_viewer/Makefile
@@ -1,12 +1,11 @@
PORTNAME= pdf_viewer
-PORTREVISION= 3
COMMENT= PDF and PostScript viewer plugin for Claws Mail
WWW= https://www.claws-mail.org/plugin.php?plugin=pdf_viewer
LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib
-USES+= ghostscript
+USES= ghostscript
CLAWS_PLUGINS_BUILD= ${PORTNAME}
diff --git a/mail/claws-mail-perl/Makefile b/mail/claws-mail-perl/Makefile
index b14edb004698..35e4eeb721f2 100644
--- a/mail/claws-mail-perl/Makefile
+++ b/mail/claws-mail-perl/Makefile
@@ -3,10 +3,10 @@ PORTNAME= perl
COMMENT= Perl filtering plugin for Claws Mail
WWW= https://www.claws-mail.org/plugin.php?plugin=perl
-USES+= perl5 shebangfix
+USES= perl5 shebangfix
SHEBANG_FILES= src/plugins/perl/tools/matcherrc2perlfilter.pl
-PLIST_FILES+= share/claws-mail/matcherrc2perlfilter.pl
+PLIST_FILES= share/claws-mail/matcherrc2perlfilter.pl
CLAWS_PLUGINS_BUILD= ${PORTNAME}
diff --git a/mail/claws-mail-pgp/Makefile b/mail/claws-mail-pgp/Makefile
index 09ef46a50d06..0a4e18e3250f 100644
--- a/mail/claws-mail-pgp/Makefile
+++ b/mail/claws-mail-pgp/Makefile
@@ -3,7 +3,8 @@ PORTNAME= pgp
COMMENT= PGP plugins for Claws Mail
WWW= https://www.claws-mail.org/plugin.php?plugin=gpg
-LIB_DEPENDS= libgpgme.so:security/gpgme
+LIB_DEPENDS= libgpg-error.so:security/libgpg-error \
+ libgpgme.so:security/gpgme
CLAWS_PLUGINS_BUILD= pgpcore pgpinline pgpmime smime
diff --git a/mail/claws-mail-plugins/Makefile b/mail/claws-mail-plugins/Makefile
index c962fee3037d..83b091a315af 100644
--- a/mail/claws-mail-plugins/Makefile
+++ b/mail/claws-mail-plugins/Makefile
@@ -15,8 +15,11 @@ CLAWS_PLUGINS+= pgp
.for _addon in ${CLAWS_PLUGINS:O}
. if exists(../claws-mail-${_addon})
+_IGNORE!= ${MAKE} -C ../claws-mail-${_addon} -V IGNORE
+. if ${_IGNORE} == ""
OPTIONS_DEFINE+= ${_addon:tu}
${_addon:tu}_DESC!= ${MAKE} -C ../claws-mail-${_addon} -V COMMENT
+. endif
. endif
.endfor
diff --git a/mail/claws-mail-rssyl/Makefile b/mail/claws-mail-rssyl/Makefile
index c61a5a819ac4..f55cbf296bde 100644
--- a/mail/claws-mail-rssyl/Makefile
+++ b/mail/claws-mail-rssyl/Makefile
@@ -4,7 +4,8 @@ PORTEPOCH= 4
COMMENT= RSS/Atom feed reader plugin for Claws Mail
WWW= https://www.claws-mail.org/plugins.php
-LIB_DEPENDS= libcurl.so:ftp/curl
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libexpat.so:textproc/expat2
CLAWS_PLUGINS_BUILD= ${PORTNAME}
diff --git a/mail/claws-mail-vcalendar/Makefile b/mail/claws-mail-vcalendar/Makefile
index 413e8d2081ac..cdfb602ffd1a 100644
--- a/mail/claws-mail-vcalendar/Makefile
+++ b/mail/claws-mail-vcalendar/Makefile
@@ -3,13 +3,13 @@ PORTNAME= vcalendar
COMMENT= vCalendar plugin for Claws Mail
WWW= https://www.claws-mail.org/plugin.php?plugin=vcalendar
-LIB_DEPENDS= libical.so:devel/libical
-
-CLAWS_PLUGINS_BUILD= ${PORTNAME}
-
-USES+= cpe
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libical.so:devel/libical
+USES= cpe
CPE_VENDOR= claws-mail
+CLAWS_PLUGINS_BUILD= ${PORTNAME}
+
.include "../claws-mail/Makefile.claws"
.include <bsd.port.mk>
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 676ad615a967..7e855fb5bf92 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -1,5 +1,4 @@
PORTNAME= claws-mail
-PORTREVISION= 3
CATEGORIES= mail news
COMMENT= Lightweight and featureful GTK based e-mail and news client
@@ -8,26 +7,19 @@ WWW= https://www.claws-mail.org/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libcurl.so:ftp/curl \
- libetpan.so:mail/libetpan \
- libexpat.so:textproc/expat2 \
- libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2 \
- libgcrypt.so:security/libgcrypt \
+LIB_DEPENDS= libetpan.so:mail/libetpan \
libgnutls.so:security/gnutls \
- libharfbuzz.so:print/harfbuzz \
- libnettle.so:security/nettle \
- libsasl2.so:security/cyrus-sasl2
+ libnettle.so:security/nettle
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss \
mime-support>0:misc/mime-support
-USES= autoreconf compiler:c++11-lang cpe desktop-file-utils gettext \
- gettext-tools gnome pathfix pkgconfig python shebangfix \
- ssl xorg
-USE_GNOME= cairo librsvg2
+USES= cpe desktop-file-utils pathfix perl5 python shebangfix xorg
+USE_GNOME= librsvg2
USE_XORG= ice sm
SHEBANG_FILES= tools/*.pl tools/*.py tools/tb2claws-mail
+CPPFLAGS+= -DGDK_DISABLE_DEPRECATION_WARNINGS
+
OPTIONS_DEFINE= COMPFACE DEBUG DOCS ENCHANT IPV6 LDAP NLS STARTUP \
THEMES
OPTIONS_DEFAULT= COMPFACE ENCHANT GTK2 STARTUP THEMES
@@ -55,9 +47,6 @@ IPV6_CONFIGURE_ENABLE= ipv6
LDAP_USES= ldap
LDAP_CONFIGURE_ENABLE= ldap
-NLS_USES= gettext-tools
-NLS_CONFIGURE_OFF= --disable-nls
-
STARTUP_LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification
STARTUP_CONFIGURE_ENABLE= startup-notification
@@ -67,18 +56,6 @@ THEMES_RUN_DEPENDS= claws-mail-themes>0:x11-themes/claws-mail-themes
MASTER_OPTIONS= ${PORT_OPTIONS}
.include "Makefile.claws"
-.if ${PORT_OPTIONS:MGTK2}
-USE_GNOME+= gtk20
-
-PLIST_SUB+= GTK2=""
-.else
-PLIST_SUB+= GTK2="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MGTK3}
-USE_GNOME+= gtk30
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/src/common/ssl.c
diff --git a/mail/claws-mail/Makefile.claws b/mail/claws-mail/Makefile.claws
index c1c690cbff5f..9ad662ea94c0 100644
--- a/mail/claws-mail/Makefile.claws
+++ b/mail/claws-mail/Makefile.claws
@@ -5,16 +5,32 @@ MAINTAINER= portmaster@bsdforge.com
LICENSE= GPLv3
-USES+= autoreconf gettext-tools gmake iconv libtool pkgconfig tar:xz
+USES+= gmake gnome iconv libtool pkgconfig tar:xz
GNU_CONFIGURE= yes
-GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
CONFIGURE_ARGS+= ${ICONV_CONFIGURE_ARG} --disable-dbus --disable-static
.include "${.CURDIR}/../claws-mail/Makefile.ver"
+
+.if ${MASTER_OPTIONS:MNLS}
+USES+= gettext
+CONFIGURE_ARGS+=--enable-nls
+.else
+CONFIGURE_ARGS+=--disable-nls
+.endif
+
+.if ${MASTER_OPTIONS:MGTK2}
+USE_GNOME+= gtk20
+.endif
+.if ${MASTER_OPTIONS:MGTK3}
+USE_GNOME+= gtk30
+.endif
+
.include "${.CURDIR}/../claws-mail/Makefile.claws.plugins"
.for p in ${CLAWS_PLUGINS}
+. if empty(CLAWS_PLUGINS_BUILD:M${p})
CONFIGURE_ARGS+= --disable-${p}-plugin
+. endif
.endfor
.if defined(CLAWS_PLUGINS_BUILD)
@@ -24,22 +40,15 @@ PKGNAMEPREFIX= claws-mail-
BUILD_DEPENDS+= claws-mail>=${PORTVERSION}:mail/claws-mail
RUN_DEPENDS+= claws-mail>=${PORTVERSION}:mail/claws-mail
-MASTERDIR= ${.CURDIR}/../claws-mail
-DESCR= ${.CURDIR}/pkg-descr
-FILESDIR= ${.CURDIR}/files
-PLIST= ${NONEXISTENT}
-PKGMESSAGE= ${.CURDIR}/pkg-message
-
-CONFIGURE_ARGS+= --disable-nls
+DISTINFO_FILE= ${.CURDIR}/../claws-mail/distinfo
. for p in ${CLAWS_PLUGINS_BUILD}
-CONFIGURE_ARGS:= ${CONFIGURE_ARGS:S|--disable-${p}-plugin||}
PLIST_FILES+= lib/claws-mail/plugins/${p:S|spam_|spam|}.so
. endfor
do-build:
. for p in ${CLAWS_PLUGINS_BUILD}
- (cd ${WRKSRC}/src/plugins/${p} && ${MAKE_CMD})
+ (cd ${WRKSRC}/src/plugins/${p} && ${DO_MAKE_BUILD})
. endfor
do-install:
diff --git a/mail/claws-mail/Makefile.ver b/mail/claws-mail/Makefile.ver
index c4b79c88c63b..fd641b9f3a03 100644
--- a/mail/claws-mail/Makefile.ver
+++ b/mail/claws-mail/Makefile.ver
@@ -3,8 +3,8 @@ MASTER_OPTIONS!= ${MAKE} -C ${.CURDIR}/../claws-mail -V PORT_OPTIONS
.endif
.if ${MASTER_OPTIONS:MGTK2}
-PORTVERSION= 3.19.1
+PORTVERSION= 3.20.0
.endif
.if ${MASTER_OPTIONS:MGTK3}
-PORTVERSION= 4.1.1
+PORTVERSION= 4.2.0
.endif
diff --git a/mail/claws-mail/distinfo b/mail/claws-mail/distinfo
index 1c240e132d37..fc1e9579f580 100644
--- a/mail/claws-mail/distinfo
+++ b/mail/claws-mail/distinfo
@@ -1,5 +1,6 @@
-TIMESTAMP = 1691825727
-SHA256 (claws-mail-3.19.1.tar.xz) = ac57fa557cf15c62e5f8fad247585fc609f0a696f6da54ed42cc000b6c6d6813
-SIZE (claws-mail-3.19.1.tar.xz) = 6580844
-SHA256 (claws-mail-4.1.1.tar.xz) = b189e700c1896f5e0deb0b76d4bfa820eb7ac1935ee10aa9afbada3cf53a0344
-SIZE (claws-mail-4.1.1.tar.xz) = 6523688
+TIMESTAMP = 1700554558
+SHA256 (claws-mail-3.20.0.tar.xz) = 1f2f3d2b2ca39c0c860c7afc5490c790936afbb50cf31debdb2beda728c8d6e5
+SIZE (claws-mail-3.20.0.tar.xz) = 6687376
+TIMESTAMP = 1700554614
+SHA256 (claws-mail-4.2.0.tar.xz) = 7c8ab1732d74197df06d61a6b7ebc7c580ecf6e92eb1ef6ae5b0107533f1af07
+SIZE (claws-mail-4.2.0.tar.xz) = 6674872
diff --git a/mail/claws-mail/pkg-plist b/mail/claws-mail/pkg-plist
index 576a73e557d3..e9a6f26180d7 100644
--- a/mail/claws-mail/pkg-plist
+++ b/mail/claws-mail/pkg-plist
@@ -293,7 +293,7 @@ share/icons/hicolor/64x64/apps/claws-mail.png
%%NLS%%share/locale/nl/LC_MESSAGES/claws-mail.mo
%%NLS%%share/locale/pl/LC_MESSAGES/claws-mail.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/claws-mail.mo
-%%GTK2%%%%NLS%%share/locale/pt_PT/LC_MESSAGES/claws-mail.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/claws-mail.mo
%%NLS%%share/locale/ro/LC_MESSAGES/claws-mail.mo
%%NLS%%share/locale/ru/LC_MESSAGES/claws-mail.mo
%%NLS%%share/locale/sk/LC_MESSAGES/claws-mail.mo