aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2023-01-28 20:48:22 +0000
committerStefan Eßer <se@FreeBSD.org>2023-01-28 20:48:22 +0000
commitec98f1089a6a1f0dad313e788bc6a3d06d4b4383 (patch)
tree13867ab6933df83f9cc8468725babf386b6e9e08
parentf94e507062fa73e2460cb64d19e388e04ef798ee (diff)
downloadports-ec98f1089a6a1f0dad313e788bc6a3d06d4b4383.tar.gz
ports-ec98f1089a6a1f0dad313e788bc6a3d06d4b4383.zip
math/gh-bc: update to version 6.2.2
This update fixes a few issues and adds new features: - There was a discrepancy from the bc standard with regards to the behavior of the "quit" command. This bc used to quit whenever it encountered "quit" during parsing, even if it was parsing a full file. Now, bc only quits when encountering "quit" after it has executed all executable statements up to that point. This behavior is slightly different from GNU bc, but users will only notice the difference if they put "quit" on the same line as other statements. - A memory bug was caused by assigning a string to a non-local variable in a function, then redefining the function with use of the same non-local variable, which would still refer to a string in the previous version of the function. - Another memory bug was caused by passing an array argument to the asciify() built-in function. In certain cases, that was wrongly allowed, and the interpreter just assumed everything was correct and accessed memory. Now that arrays are allowed as arguments (see below), this is not an issue. - A missing local in the uint*() family of functions in the extended math library. - A failure to clear the tail call list in dc on error. - A crash when attempting to swap characters in command-line history when no characters exist. - SIGWINCH was activated even when history was not. - If an array element was used as a parameter, and then a later parameter had the same name as the array whose element was used, bc would grab the element from the new array parameter, not the actual element from before the function call. - A new built-in function is_number() ("u" in dc) returns 1 if the runtime argument is a number and 0 otherwise. - A new is_string() built-in function ("t" in dc) returns 1 if the runtime argument is a string and 0 otherwise. - The new asciify() built-in function in bc converts a full array of numbers into a string. This means that character-by-character printing will not be necessary, and more strings than just single-character ones will be able to be created. - Stack traces are now given for runtime errors. In debug mode, the C source file and line of errors are given as well.
-rw-r--r--math/gh-bc/Makefile4
-rw-r--r--math/gh-bc/distinfo6
2 files changed, 5 insertions, 5 deletions
diff --git a/math/gh-bc/Makefile b/math/gh-bc/Makefile
index 8912880727b2..06d05ca64cc3 100644
--- a/math/gh-bc/Makefile
+++ b/math/gh-bc/Makefile
@@ -1,12 +1,12 @@
PORTNAME= bc
-PORTVERSION= 6.0.2
+PORTVERSION= 6.2.2
CATEGORIES= math lang
MASTER_SITES= https://github.com/gavinhoward/bc/releases/download/${PORTVERSION}/
PKGNAMEPREFIX= gh-
MAINTAINER= se@FreeBSD.org
COMMENT= GNU compatible bc/dc calculator
-WWW= https://git.yzena.com/gavin/bc
+WWW= https://git.yzena.com/gavin/bc
LICENSE= BSD2CLAUSE MIT
LICENSE_COMB= multi
diff --git a/math/gh-bc/distinfo b/math/gh-bc/distinfo
index e6914393b9b9..cd420e9e8c32 100644
--- a/math/gh-bc/distinfo
+++ b/math/gh-bc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1661883902
-SHA256 (bc-6.0.2.tar.xz) = a4e51fda30515005f729422d184df7f04d9b4517614212aa65204db33c344046
-SIZE (bc-6.0.2.tar.xz) = 451876
+TIMESTAMP = 1674331624
+SHA256 (bc-6.2.2.tar.xz) = 5b6fe23b720ab898c9c9c9cbdc83e124791b0b575005ec91a63175d3b69b90f2
+SIZE (bc-6.2.2.tar.xz) = 456672