aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2021-12-25 20:28:18 +0000
committerDima Panov <fluffy@FreeBSD.org>2021-12-25 20:28:18 +0000
commited253c0553af2883c5d4d4d28d5cf9740f768459 (patch)
tree552ad0860b29fb09b66f008dc887c225b8f6987a
parent6ba80078eaafc974c2e210065d09e6538090720d (diff)
downloadports-ed253c0553af2883c5d4d4d28d5cf9740f768459.tar.gz
ports-ed253c0553af2883c5d4d4d28d5cf9740f768459.zip
mail/exim: unbreak after mail/opendmarc update (+)
Last update for mail/opendmarc to 1.4.2 changes required params for opendmarc_policy_store_dkim subroutine by introducing *dkim_selector as pair for *domain. Adjust exim' dmarc routines by pass NULL string as *dkim_selector to force opendmarc subroutine go thru autodetect required selector on the fly. This dirt'n'ugly hack will be dropped as soon as functionality will be adjusted upstream in proper way. Bump PORTREVISION to force rebuild. Reported by: ler, poudriere failure PR: 260678
-rw-r--r--mail/exim/Makefile2
-rw-r--r--mail/exim/files/patch-src-dmarc.c19
2 files changed, 20 insertions, 1 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 3c7030a0499b..874f352e5ae3 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -2,7 +2,7 @@
PORTNAME= exim
PORTVERSION?= ${EXIM_VERSION}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= mail
MASTER_SITES= EXIM:exim
MASTER_SITE_SUBDIR= /exim4/:exim \
diff --git a/mail/exim/files/patch-src-dmarc.c b/mail/exim/files/patch-src-dmarc.c
new file mode 100644
index 000000000000..c0054446458c
--- /dev/null
+++ b/mail/exim/files/patch-src-dmarc.c
@@ -0,0 +1,19 @@
+--- src/dmarc.c.orig 2021-04-30 12:08:21 UTC
++++ src/dmarc.c
+@@ -37,6 +37,7 @@ uschar *spf_human_readable = NULL;
+ u_char *header_from_sender = NULL;
+ int history_file_status = DMARC_HIST_OK;
+ uschar *dkim_history_buffer= NULL;
++uschar *dkim_selector = NULL;
+
+ typedef struct dmarc_exim_p {
+ uschar *name;
+@@ -446,7 +447,7 @@ if (!dmarc_abort && !sender_host_authenticated)
+ vs == PDKIM_VERIFY_INVALID ? DMARC_POLICY_DKIM_OUTCOME_TMPFAIL :
+ DMARC_POLICY_DKIM_OUTCOME_NONE;
+ libdm_status = opendmarc_policy_store_dkim(dmarc_pctx, US sig->domain,
+- dkim_result, US"");
++ dkim_selector, dkim_result, US"");
+ DEBUG(D_receive)
+ debug_printf("DMARC adding DKIM sender domain = %s\n", sig->domain);
+ if (libdm_status != DMARC_PARSE_OKAY)