aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-12 00:10:46 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-12 00:11:19 +0000
commited417e4d65fe4f7f1d857621c90b6125791ae622 (patch)
tree38f017d7f7d14cf42cb9202ebb618479aae84a6f
parent1e8c8b489a047d05abc47de4f0258feead08c302 (diff)
science/py-OpenFermion-PySCF: New port: Interface between OpenFermion and PySCF
-rw-r--r--science/Makefile1
-rw-r--r--science/py-OpenFermion-PySCF/Makefile25
-rw-r--r--science/py-OpenFermion-PySCF/distinfo3
-rw-r--r--science/py-OpenFermion-PySCF/pkg-descr4
4 files changed, 33 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 1c2f5aeb8a0c..6e3bc001aab0 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -256,6 +256,7 @@
SUBDIR += py-MDAnalysisTests
SUBDIR += py-OpenFermion
SUBDIR += py-OpenFermion-Dirac
+ SUBDIR += py-OpenFermion-PySCF
SUBDIR += py-OpenMC
SUBDIR += py-PubChemPy
SUBDIR += py-PyFR
diff --git a/science/py-OpenFermion-PySCF/Makefile b/science/py-OpenFermion-PySCF/Makefile
new file mode 100644
index 000000000000..d104c170835b
--- /dev/null
+++ b/science/py-OpenFermion-PySCF/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= py-OpenFermion-PySCF
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.5
+CATEGORIES= science python # chemistry, quantum-computing
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Interface between OpenFermion and PySCF
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}OpenFermion>0:science/py-OpenFermion@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyscf>0:science/py-pyscf@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist pytest # 2 tests are known to fail, see https://github.com/quantumlib/OpenFermion-PySCF/issues/65
+
+USE_GITHUB= yes
+GH_ACCOUNT= quantumlib
+GH_PROJECT= OpenFermion-PySCF
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-OpenFermion-PySCF/distinfo b/science/py-OpenFermion-PySCF/distinfo
new file mode 100644
index 000000000000..e9740728b859
--- /dev/null
+++ b/science/py-OpenFermion-PySCF/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1660258578
+SHA256 (quantumlib-OpenFermion-PySCF-v0.5_GH0.tar.gz) = 8548dd47bcd314ec489d31caa2a92455555d1b2a623bca9baeb6c3fb4c808220
+SIZE (quantumlib-OpenFermion-PySCF-v0.5_GH0.tar.gz) = 39924
diff --git a/science/py-OpenFermion-PySCF/pkg-descr b/science/py-OpenFermion-PySCF/pkg-descr
new file mode 100644
index 000000000000..29d2abf7f5c2
--- /dev/null
+++ b/science/py-OpenFermion-PySCF/pkg-descr
@@ -0,0 +1,4 @@
+OpenFermion-PySCF is an interface between OpenFermion and PySCF to perform
+relativistic quantum chemistry calculations simulated on a quantum computer.
+
+WWW: https://github.com/quantumlib/OpenFermion-PySCF