aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2023-02-20 07:50:33 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2023-02-20 07:55:04 +0000
commited6d1fa6601b9701b21f525336a96d26cb76db05 (patch)
tree10f6ebfd33b0f3f639b1341bbff27468530f0eed
parent7457e5faa47593492f7d78484ffe719c89c9dc2a (diff)
downloadports-ed6d1fa6601b9701b21f525336a96d26cb76db05.tar.gz
ports-ed6d1fa6601b9701b21f525336a96d26cb76db05.zip
audio/uade: Update to 3.02
-rw-r--r--audio/uade/Makefile52
-rw-r--r--audio/uade/distinfo5
-rw-r--r--audio/uade/files/patch-configure11
-rw-r--r--audio/uade/files/patch-src_Makefile.in4
-rw-r--r--audio/uade/files/patch-src_frontends_audacious_Makefile.in11
-rw-r--r--audio/uade/files/patch-src_frontends_uade123_Makefile.in10
-rw-r--r--audio/uade/files/patch-write__audio_Makefile.in19
-rw-r--r--audio/uade/files/patch-write__audio_write__audio.cc11
-rw-r--r--audio/uade/pkg-plist30
9 files changed, 99 insertions, 54 deletions
diff --git a/audio/uade/Makefile b/audio/uade/Makefile
index eac19582f7a8..4b0abaa8eba8 100644
--- a/audio/uade/Makefile
+++ b/audio/uade/Makefile
@@ -1,8 +1,7 @@
PORTNAME= uade
-PORTVERSION= 2.13
-PORTREVISION= 2
+PORTVERSION= 3.02
CATEGORIES= audio
-MASTER_SITES= http://zakalwe.fi/uade/uade2/ \
+MASTER_SITES= http://zakalwe.fi/uade/uade3/ \
LOCAL/ehaupt
MAINTAINER= ehaupt@FreeBSD.org
@@ -11,50 +10,45 @@ WWW= https://zakalwe.fi/uade/
LICENSE= GPLv2
-LIB_DEPENDS= libao.so:audio/libao
+BUILD_DEPENDS= bash:shells/bash \
+ vasmm68k_mot:devel/vasm
+LIB_DEPENDS= libao.so:audio/libao \
+ libbencodetools.so:devel/bencodetools
-USES= gmake pkgconfig tar:bzip2
-HAS_CONFIGURE= yes
+USES= gmake localbase:ldflags pathfix pkgconfig python:build \
+ shebangfix tar:bzip2
-DOCSDIR= ${PREFIX}/share/doc/uade2
-DATADIR= ${PREFIX}/share/uade2
+SHEBANG_FILES= configure write_audio/generate_amiga_oscilloscope_view
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- --mandir=${MANPREFIX}/man/man1 \
- --no-debug --without-audacious \
- --package-prefix=${STAGEDIR}
+HAS_CONFIGURE= yes
-CONFIGURE_ENV= SYSCFLAGS='${CFLAGS}'
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man/man1 \
+ --no-debug \
+ --prefix=${PREFIX} \
+ --without-write-audio
+CONFIGURE_ENV= PYTHON_INTERPRETER=${PYTHON_CMD} \
+ SYSCFLAGS='${CFLAGS}'
-PORTDOCS= BUGS PLANS REDUNDANT_REPLAYERS UAE-CREDITS UAE-README \
- VERSION_CONTROL_TAGGING audio_emulation.txt design.tex \
- download.html faq.html layers.eps layers.xfig \
- play_loop_state_diagram.dia play_loop_state_diagram.eps \
- play_loop_state_diagram.txt uade.html
+SHEBANG_FILES= configure write_audio/generate_amiga_oscilloscope_view
-OPTIONS_DEFINE= TEXTSCOPE FUSE DOCS
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= DOCS TEXTSCOPE
+OPTIONS_DEFAULT= TEXTSCOPE
+OPTIONS_SUB= yes
TEXTSCOPE_DESC= Audio register debug mode
TEXTSCOPE_CONFIGURE_WITH= text-scope
-FUSE_USES= fuse
-FUSE_CONFIGURE_WITH= uadefs
-
post-extract:
@${RM} -r ${WRKSRC}/players/S
-post-patch:
- @${REINPLACE_CMD} -e 's,lib/pkgconfig,libdata/pkgconfig,' \
- ${WRKSRC}/configure
-
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR}
.endfor
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/uade123 \
- ${STAGEDIR}${PREFIX}/lib/uade2/uadecore
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/uade123 \
+ ${STAGEDIR}${PREFIX}/lib/libuade.so \
+ ${STAGEDIR}${PREFIX}/lib/uade/uadecore
.include <bsd.port.mk>
diff --git a/audio/uade/distinfo b/audio/uade/distinfo
index ee076352894b..50f93d3be948 100644
--- a/audio/uade/distinfo
+++ b/audio/uade/distinfo
@@ -1,2 +1,3 @@
-SHA256 (uade-2.13.tar.bz2) = 3b194e5aebbfa99d3708d5a0b5e6bd7dc5d1caaecf4ae9b52f8ff87e222dd612
-SIZE (uade-2.13.tar.bz2) = 2897931
+TIMESTAMP = 1659213752
+SHA256 (uade-3.02.tar.bz2) = 2aa317525402e479ae8863222e3c341d135670fcb23a2853ac93075ac428f35b
+SIZE (uade-3.02.tar.bz2) = 3190260
diff --git a/audio/uade/files/patch-configure b/audio/uade/files/patch-configure
new file mode 100644
index 000000000000..05f3611fcaa3
--- /dev/null
+++ b/audio/uade/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2022-10-01 15:24:39 UTC
++++ configure
+@@ -389,7 +389,7 @@ if test "$?" != "0"; then
+ exit 1
+ fi
+
+-VASM=$(which vasm.vasmm68k-mot)
++VASM=$(which vasmm68k_mot)
+ if [[ -n ${VASM} ]] ; then
+ usescore="yes"
+ fi
diff --git a/audio/uade/files/patch-src_Makefile.in b/audio/uade/files/patch-src_Makefile.in
index ff9fa6c75345..ad568b210f26 100644
--- a/audio/uade/files/patch-src_Makefile.in
+++ b/audio/uade/files/patch-src_Makefile.in
@@ -1,6 +1,6 @@
---- src/Makefile.in.orig 2009-10-29 21:01:12 UTC
+--- src/Makefile.in.orig 2022-10-01 15:24:39 UTC
+++ src/Makefile.in
-@@ -8,7 +8,7 @@ ARCHFLAGS = {ARCHFLAGS}
+@@ -7,7 +7,7 @@ ARCHFLAGS = {ARCHFLAGS}
ARCHLIBS = {ARCHLIBS}
DEBUGFLAGS = {DEBUGFLAGS}
diff --git a/audio/uade/files/patch-src_frontends_audacious_Makefile.in b/audio/uade/files/patch-src_frontends_audacious_Makefile.in
deleted file mode 100644
index 282e78323b95..000000000000
--- a/audio/uade/files/patch-src_frontends_audacious_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/frontends/audacious/Makefile.in.orig 2009-10-29 21:01:12 UTC
-+++ src/frontends/audacious/Makefile.in
-@@ -7,7 +7,7 @@ DEBUGFLAGS={DEBUGFLAGS}
- AUDACIOUSFLAGS={AUDACIOUSFLAGS}
- AUDACIOUSLIBS={AUDACIOUSLIBS}
- SHAREDLIBRARYFLAGS={SHAREDLIBRARYFLAGS}
--CFLAGS = -Wall -O2 $(SHAREDLIBRARYFLAGS) $(AUDACIOUSFLAGS) $(ARCHFLAGS) $(DEBUGFLAGS) -I../common -I../../include
-+CFLAGS = $(SHAREDLIBRARYFLAGS) $(AUDACIOUSFLAGS) $(ARCHFLAGS) $(DEBUGFLAGS) -I../common -I../../include
- CLIBS = $(XMLIBS) -lm
-
- all: libuade2.so
diff --git a/audio/uade/files/patch-src_frontends_uade123_Makefile.in b/audio/uade/files/patch-src_frontends_uade123_Makefile.in
index dd9850d3bdc9..ccf1c8b09e80 100644
--- a/audio/uade/files/patch-src_frontends_uade123_Makefile.in
+++ b/audio/uade/files/patch-src_frontends_uade123_Makefile.in
@@ -1,11 +1,11 @@
---- src/frontends/uade123/Makefile.in.orig 2009-10-29 21:01:12 UTC
+--- src/frontends/uade123/Makefile.in.orig 2022-10-01 15:24:39 UTC
+++ src/frontends/uade123/Makefile.in
-@@ -2,7 +2,7 @@ BINDIR = {PACKAGEPREFIX}{BINDIR}
+@@ -2,7 +2,7 @@ BINDIR = $(DESTDIR){PACKAGEPREFIX}{BINDIR}
UADE123NAME = {UADE123NAME}
CC = {CC}
--CFLAGS = -Wall -O2 -I../../include -I../common {AOFLAGS} {DEBUGFLAGS} {ARCHFLAGS}
-+CFLAGS = -I../../include -I../common {AOFLAGS} {DEBUGFLAGS} {ARCHFLAGS}
- CLIBS = {AOLIBS} {ARCHLIBS} -lm
+-CFLAGS = -Wall -O2 -I../include -I../common {AOFLAGS} {DEBUGFLAGS} {ARCHFLAGS} {BENCODETOOLSFLAGS}
++CFLAGS = -I../include -I../common {AOFLAGS} {DEBUGFLAGS} {ARCHFLAGS} {BENCODETOOLSFLAGS}
+ CLIBS = {AOLIBS} {ARCHLIBS} -lm -lbencodetools
all: uade123
diff --git a/audio/uade/files/patch-write__audio_Makefile.in b/audio/uade/files/patch-write__audio_Makefile.in
new file mode 100644
index 000000000000..ef2101747f63
--- /dev/null
+++ b/audio/uade/files/patch-write__audio_Makefile.in
@@ -0,0 +1,19 @@
+--- write_audio/Makefile.in.orig 2022-10-01 15:31:57 UTC
++++ write_audio/Makefile.in
+@@ -1,12 +1,12 @@
+-CC = g++
+-CCFLAGS = -W -Wall -O2 -g
+-LDFLAGS =
++CXX ?= c++
++CCFLAGS ?= -W -Wall -O2 -g
++LDFLAGS ?=
+ EXES = write_audio
+
+ all: $(EXES)
+
+ write_audio: write_audio.cc
+- $(CC) $(CCFLAGS) -o $@ $< $(LDFLAGS)
++ $(CXX) $(CCFLAGS) -o $@ $< $(LDFLAGS)
+
+ clean:
+ rm -f $(EXES)
diff --git a/audio/uade/files/patch-write__audio_write__audio.cc b/audio/uade/files/patch-write__audio_write__audio.cc
new file mode 100644
index 000000000000..9c51979df7c9
--- /dev/null
+++ b/audio/uade/files/patch-write__audio_write__audio.cc
@@ -0,0 +1,11 @@
+--- write_audio/write_audio.cc.orig 2022-10-01 15:28:01 UTC
++++ write_audio/write_audio.cc
+@@ -3,7 +3,7 @@
+ #include <cassert>
+ #include <cstdio>
+ #include <cstring>
+-#include <endian.h>
++#include <sys/endian.h>
+ #include <iostream>
+ #include <math.h>
+ #include <string>
diff --git a/audio/uade/pkg-plist b/audio/uade/pkg-plist
index be70e04378e7..38bb6e0c1c38 100644
--- a/audio/uade/pkg-plist
+++ b/audio/uade/pkg-plist
@@ -1,20 +1,26 @@
bin/mod2ogg2.sh
bin/uade123
-%%FUSE%%bin/uadefs
-%%FUSE%%man/man1/uadefs.1.gz
+include/uade/options.h
+include/uade/uade.h
+include/uade/uadeconfstructure.h
+lib/libuade.so
+lib/uade/uadecore
+libdata/pkgconfig/libuade.pc
man/man1/uade123.1.gz
-lib/uade2/uadecore
-libdata/pkgconfig/uade.pc
%%DATADIR%%/eagleplayer.conf
%%DATADIR%%/players/ADPCM_mono
%%DATADIR%%/players/AM-Composer
%%DATADIR%%/players/AMOS
+%%DATADIR%%/players/AProSys
%%DATADIR%%/players/AbyssHighestExperience
%%DATADIR%%/players/ActionAmics
%%DATADIR%%/players/Alcatraz_Packer
+%%DATADIR%%/players/Anders_0land
+%%DATADIR%%/players/Andrew_Parton
%%DATADIR%%/players/ArtAndMagic
%%DATADIR%%/players/ArtOfNoise-4V
%%DATADIR%%/players/ArtOfNoise-8V
+%%DATADIR%%/players/Ashley_Hogg
%%DATADIR%%/players/AudioSculpture
%%DATADIR%%/players/BeathovenSynthesizer
%%DATADIR%%/players/BenDaglish
@@ -59,6 +65,7 @@ libdata/pkgconfig/uade.pc
%%DATADIR%%/players/FutureComposer1.3
%%DATADIR%%/players/FutureComposer1.4
%%DATADIR%%/players/FuturePlayer
+%%DATADIR%%/players/GMC
%%DATADIR%%/players/GlueMon
%%DATADIR%%/players/HowieDavies
%%DATADIR%%/players/ImagesMusicSystem
@@ -67,6 +74,7 @@ libdata/pkgconfig/uade.pc
%%DATADIR%%/players/Infogrames
%%DATADIR%%/players/JamCracker
%%DATADIR%%/players/JankoMrsicFlogel
+%%DATADIR%%/players/Janne_Salmijarvi_Optimizer
%%DATADIR%%/players/JasonBrooke
%%DATADIR%%/players/JasonPage
%%DATADIR%%/players/JasonPage_JP
@@ -78,6 +86,7 @@ libdata/pkgconfig/uade.pc
%%DATADIR%%/players/JochenHippel-CoSo
%%DATADIR%%/players/JochenHippel_UADE
%%DATADIR%%/players/Jochen_Hippel_ST
+%%DATADIR%%/players/Kim_Christensen
%%DATADIR%%/players/KrisHatlelid
%%DATADIR%%/players/Laxity
%%DATADIR%%/players/LegglessMusicEditor
@@ -96,6 +105,7 @@ libdata/pkgconfig/uade.pc
%%DATADIR%%/players/Maximum_Effect
%%DATADIR%%/players/Medley
%%DATADIR%%/players/MikeDavies
+%%DATADIR%%/players/Mosh_Packer
%%DATADIR%%/players/Mugician
%%DATADIR%%/players/MugicianII
%%DATADIR%%/players/MultiMedia_Sound
@@ -104,6 +114,7 @@ libdata/pkgconfig/uade.pc
%%DATADIR%%/players/MusicMaker-8V
%%DATADIR%%/players/MusiclineEditor
%%DATADIR%%/players/NTSP-system
+%%DATADIR%%/players/Nick_Pelling_Packer
%%DATADIR%%/players/NovoTradePacker
%%DATADIR%%/players/Octa-MED
%%DATADIR%%/players/Oktalyzer
@@ -111,8 +122,10 @@ libdata/pkgconfig/uade.pc
%%DATADIR%%/players/PaulRobotham
%%DATADIR%%/players/PaulShields
%%DATADIR%%/players/PaulSummers
+%%DATADIR%%/players/Paul_Tonge
%%DATADIR%%/players/PeterVerswyvelen
%%DATADIR%%/players/PierreAdane
+%%DATADIR%%/players/Pokeynoise
%%DATADIR%%/players/ProfessionalSoundArtists
%%DATADIR%%/players/PumaTracker
%%DATADIR%%/players/QuadraComposer
@@ -120,9 +133,10 @@ libdata/pkgconfig/uade.pc
%%DATADIR%%/players/Quartet_PSG
%%DATADIR%%/players/Quartet_ST
%%DATADIR%%/players/RichardJoseph
+%%DATADIR%%/players/RichardJoseph_Player
%%DATADIR%%/players/RiffRaff
%%DATADIR%%/players/RobHubbard
-%%DATADIR%%/players/RobHubbardOld
+%%DATADIR%%/players/RobHubbard_ST
%%DATADIR%%/players/SCUMM
%%DATADIR%%/players/SIDMon1.0
%%DATADIR%%/players/SIDMon2.0
@@ -155,6 +169,7 @@ libdata/pkgconfig/uade.pc
%%DATADIR%%/players/Synth
%%DATADIR%%/players/SynthDream
%%DATADIR%%/players/SynthPack
+%%DATADIR%%/players/TCB_Tracker
%%DATADIR%%/players/TFMX
%%DATADIR%%/players/TFMX-7V
%%DATADIR%%/players/TFMX-7V-TFHD
@@ -165,13 +180,18 @@ libdata/pkgconfig/uade.pc
%%DATADIR%%/players/TheMusicalEnlightenment
%%DATADIR%%/players/ThomasHermann
%%DATADIR%%/players/TimFollin
+%%DATADIR%%/players/TimeTracker
+%%DATADIR%%/players/Titanics_Packer
%%DATADIR%%/players/TomyTracker
%%DATADIR%%/players/Tronic
+%%DATADIR%%/players/UFO
%%DATADIR%%/players/UltimateSoundtracker
%%DATADIR%%/players/VoodooSupremeSynthesizer
%%DATADIR%%/players/WallyBeben
%%DATADIR%%/players/YM-2149
+%%DATADIR%%/players/ZoundMonitor
%%DATADIR%%/players/onEscapee
%%DATADIR%%/score
%%DATADIR%%/uade.conf
%%DATADIR%%/uaerc
+%%PORTDOCS%%@dir %%DOCSDIR%%