aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-08-01 21:25:35 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-08-01 21:25:35 +0000
commited7057c1e500708834bb01d3c97d5ed7734485ea (patch)
treeb309214cc07c24b2f49ba5bf27a51bd81e0693dd
parentcb10f9c1219a2ce3f960ce30bce95948d7283301 (diff)
downloadports-ed7057c1e500708834bb01d3c97d5ed7734485ea.tar.gz
ports-ed7057c1e500708834bb01d3c97d5ed7734485ea.zip
Properly fix build with clang
Fix build without gcc
Notes
Notes: svn path=/head/; revision=324129
-rw-r--r--security/zxid/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/zxid/Makefile b/security/zxid/Makefile
index 66e247a6c3a1..f8ed1c58139a 100644
--- a/security/zxid/Makefile
+++ b/security/zxid/Makefile
@@ -18,7 +18,8 @@ MAKE_JOBS_UNSAFE= yes
CFLAGS+= -D_LSEEK_DECLARED -fPIC
MAKE_ARGS= CC="${CC}" CURL_ROOT="${LOCALBASE}" LD="${CC}" \
PREFIX="${PREFIX}" OPENSSL_ROOT="${OPENSSLBASE}"
-USE_GMAKE= yes
+USES= gmake
+USE_CSTD= gnu89
USE_LDCONFIG= yes
USE_OPENSSL= yes
@@ -29,7 +30,7 @@ ZXID_BINS= smime zxcall zxcot zxdecode zxencdectest zxid zxidhlo \
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e 's/__inline//g' ${WRKSRC}/c/zx-attrs.c
+ @${REINPLACE_CMD} -e '/which gcc/d' ${WRKSRC}/Makefile
post-install:
${MKDIR} ${PREFIX}/include/zxid/