aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-28 16:48:01 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-29 18:24:39 +0000
commitee6c86aea577dec2643f6a9915033feda7f67e26 (patch)
tree36f2f4b966bacb640b14648c3bf90ee926a6c177
parent3d426c920c8a95998ff4fa5b80012055788905cf (diff)
*/*: Refactor with IGNORE_WITH_MYSQL
- There are multiple ports which has MYSQL options and are non-DEFAULT. Most of the time committers actually forget to check with the OPTION enabled and in some cases they are BROKEN with newr versions of mysql. So test with different versions of mysql and mark IGNOPRE_WITH_MYSQL appropriately. Due to the EOL of 5.7 this has not been checked. - Unbreak sysutils/cfengine* with MySQL 8.0 and later - The primary purpose of running this check is having statistics of the MySQL usability over MariaDB to explore the future possibility of shifting to MariaDB as the default as major ports upstream have moved their codebase to support MariaDB over MySQL. - The following actions will also be taken after the sunset of MySQL 5.7 If a port is broken on all instances of MySQL/MariaDB: - If a port has the option of multiple DB backends and MySQL is the default then the DEFAULT will be changed to PGSQL/SQLITE before 2024Q1. And the OPTION will be removed before 2024Q2. If a MAINTAINER is aware about such cases and want to prefer PGSQL over SQLITE or vice versa please do so at your own accord. Otherwise PGSQL will be preferred over SQLITE. - If a port has the option of multiple DB backends and MySQL is not the default then the the OPTION will be removed before 2024Q1. Approved by: portmgr (blanket)
-rw-r--r--biology/emboss/Makefile2
-rw-r--r--comms/gnokii/Makefile1
-rw-r--r--databases/luadbi/Makefile2
-rw-r--r--databases/mroonga/Makefile2
-rw-r--r--databases/mysql-connector-c++/Makefile2
-rw-r--r--databases/mysql-udf/Makefile2
-rw-r--r--databases/mysqltcl/Makefile2
-rw-r--r--databases/ocaml-mysql/Makefile2
-rw-r--r--databases/qt6-base_sqldriver/Makefile4
-rw-r--r--databases/rubygem-mysql/Makefile2
-rw-r--r--devel/gearmand/Makefile1
-rw-r--r--dns/opendnssec2/Makefile1
-rw-r--r--editors/openoffice-devel/Makefile1
-rw-r--r--finance/quickfix/Makefile2
-rw-r--r--ftp/smbftpd/Makefile1
-rw-r--r--ftp/wzdftpd/Makefile1
-rw-r--r--games/ldmud/Makefile2
-rw-r--r--games/pvpgn/Makefile1
-rw-r--r--lang/urweb/Makefile1
-rw-r--r--mail/dspam/Makefile1
-rw-r--r--mail/tpop3d/Makefile1
-rw-r--r--mail/vpopmail/Makefile1
-rw-r--r--net-im/jabberd/Makefile1
-rw-r--r--net-mgmt/super_mediator/Makefile2
-rw-r--r--net-p2p/xbt/Makefile1
-rw-r--r--net/linknx/Makefile1
-rw-r--r--security/barnyard2/Makefile2
-rw-r--r--sysutils/cfengine-devel/Makefile2
-rw-r--r--sysutils/cfengine320/Makefile2
-rw-r--r--sysutils/cfengine321/Makefile2
-rw-r--r--sysutils/cfengine322/Makefile2
-rw-r--r--sysutils/cfengine323/Makefile2
-rw-r--r--textproc/redland/Makefile1
-rw-r--r--www/kannel/Makefile2
34 files changed, 38 insertions, 17 deletions
diff --git a/biology/emboss/Makefile b/biology/emboss/Makefile
index 11b6b6c99fb0..2f43a2a05769 100644
--- a/biology/emboss/Makefile
+++ b/biology/emboss/Makefile
@@ -39,7 +39,7 @@ OPTIONS_DEFAULT= X11
DOCS_CONFIGURE_ON= --with-docroot=${DOCSDIR}
MYSQL_USES= mysql
-MYSQL_VARS= IGNORE_WITH_MYSQL=80
+MYSQL_VARS= IGNORE_WITH_MYSQL="80 81"
X11_USES= motif xorg
X11_USE= XORG=x11
X11_LIB_DEPENDS= libgd.so:graphics/gd \
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index efd225c5685a..8dfb203e0b29 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -59,6 +59,7 @@ MYSQL_USES= mysql ssl
MYSQL_PLIST_SUB= MSM=''
MYSQL_PLIST_SUB_OFF= MSM='@comment '
MYSQL_CONFIGURE_OFF= --disable-mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="80 81"
PGSQL_USES= pgsql
PGSQL_PLIST_SUB= PGM=''
PGSQL_PLIST_SUB_OFF= PGM='@comment '
diff --git a/databases/luadbi/Makefile b/databases/luadbi/Makefile
index 1f1ef208f298..37413e1749bf 100644
--- a/databases/luadbi/Makefile
+++ b/databases/luadbi/Makefile
@@ -41,7 +41,7 @@ MYSQL_ALL_TARGET= mysql
MYSQL_PLIST_FILES= %%LUA_MODLIBDIR%%/dbd/mysql.so
MYSQL_MAKE_ENV+= MYSQL_LDFLAGS="-L${LOCALBASE}/lib/mysql -lmysqlclient"
MYSQL_MAKE_ENV+= MYSQL_INC="-I${LOCALBASE}/include/mysql"
-MYSQL_VARS= IGNORE_WITH_MYSQL=80
+MYSQL_VARS= IGNORE_WITH_MYSQL="80 81"
SQLITE3_USES= localbase:ldflags sqlite:3
SQLITE3_ALL_TARGET= sqlite3
diff --git a/databases/mroonga/Makefile b/databases/mroonga/Makefile
index ad6051b4b023..159548452f64 100644
--- a/databases/mroonga/Makefile
+++ b/databases/mroonga/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= ${NONEXISTENT}:${_MYSQL_SERVER}:configure
LIB_DEPENDS= libgroonga.so:textproc/groonga
USES= compiler:c11 libtool mysql pkgconfig shebangfix
-IGNORE_WITH_MYSQL= 105m 57w
+IGNORE_WITH_MYSQL= 105m 106m 1011m 57w 81
SHEBANG_FILES= data/rpm/post.sh data/rpm/preun.sh
diff --git a/databases/mysql-connector-c++/Makefile b/databases/mysql-connector-c++/Makefile
index d92836b8f8f1..73cd4352bdd5 100644
--- a/databases/mysql-connector-c++/Makefile
+++ b/databases/mysql-connector-c++/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
libzstd.so:archivers/zstd
USES= cmake:noninja compiler:c++17-lang cpe gmake mysql ssl
-IGNORE_WITH_MYSQL= 105m
+IGNORE_WITH_MYSQL= 105m 106m 1011m
CPE_VENDOR= oracle
USE_CXXSTD= c++17
USE_LDCONFIG= yes
diff --git a/databases/mysql-udf/Makefile b/databases/mysql-udf/Makefile
index 5aa8b07e56f3..47b93958b828 100644
--- a/databases/mysql-udf/Makefile
+++ b/databases/mysql-udf/Makefile
@@ -14,7 +14,7 @@ DEPRECATED= Upstream last update was in 2007
EXPIRATION_DATE= 2023-12-31
USES= mysql
-IGNORE_WITH_MYSQL= 80
+IGNORE_WITH_MYSQL= 105m 106m 1011m 80 81
CFLAGS+= -fPIC
diff --git a/databases/mysqltcl/Makefile b/databases/mysqltcl/Makefile
index 6103ea539eda..dba640436ca9 100644
--- a/databases/mysqltcl/Makefile
+++ b/databases/mysqltcl/Makefile
@@ -8,7 +8,7 @@ COMMENT= TCL module for accessing MySQL databases based on msqltcl
WWW= http://www.xdobry.de/mysqltcl/
USES= mysql tcl
-IGNORE_WITH_MYSQL= 80
+IGNORE_WITH_MYSQL= 80 81
USE_LDCONFIG= yes
PLIST_FILES= lib/${PORTNAME}-${PORTVERSION}/libmysqltcl${PORTVERSION}.so \
diff --git a/databases/ocaml-mysql/Makefile b/databases/ocaml-mysql/Makefile
index 6dee49ad6204..7783983b5fb1 100644
--- a/databases/ocaml-mysql/Makefile
+++ b/databases/ocaml-mysql/Makefile
@@ -13,7 +13,7 @@ WWW= http://ygrek.org.ua/p/ocaml-mysql/
LICENSE= LGPL21
USES= gmake mysql
-IGNORE_WITH_MYSQL= 80
+IGNORE_WITH_MYSQL= 80 81
USE_OCAML= yes
USE_OCAML_FINDLIB= yes
USE_OCAML_CAMLP4= yes
diff --git a/databases/qt6-base_sqldriver/Makefile b/databases/qt6-base_sqldriver/Makefile
index b7f4abfe8308..fc30996a3275 100644
--- a/databases/qt6-base_sqldriver/Makefile
+++ b/databases/qt6-base_sqldriver/Makefile
@@ -30,4 +30,8 @@ sqlite_USES= sqlite:3
sqlite_CMAKE_ON= QT_FEATURE_system_sqlite
${FLAVOR}_PLIST= ${.CURDIR}/pkg-plist.${FLAVOR}
+.if ${FLAVOR:U} == mysql
+IGNORE_WITH_MYSQL= 105m 106m 1011m
+.endif
+
.include <bsd.port.mk>
diff --git a/databases/rubygem-mysql/Makefile b/databases/rubygem-mysql/Makefile
index d0a20eb92c53..462c4779a28d 100644
--- a/databases/rubygem-mysql/Makefile
+++ b/databases/rubygem-mysql/Makefile
@@ -12,6 +12,6 @@ LICENSE= GPLv2 RUBY
LICENSE_COMB= dual
USES= gem mysql
-IGNORE_WITH_MYSQL= 80
+IGNORE_WITH_MYSQL= 80 81
.include <bsd.port.mk>
diff --git a/devel/gearmand/Makefile b/devel/gearmand/Makefile
index 0ab3bf84fe37..c68d4a02e79c 100644
--- a/devel/gearmand/Makefile
+++ b/devel/gearmand/Makefile
@@ -55,6 +55,7 @@ MEMCACHED_CONFIGURE_ENABLE= libmemcached
MYSQL_USES= mysql
MYSQL_CONFIGURE_ON= --with-mysql=yes
MYSQL_CONFIGURE_OFF= --with-mysql=no
+MYSQL_VARS= IGNORE_WITH_MYSQL="80 81"
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ENABLE= libpq
SQLITE_USES= sqlite
diff --git a/dns/opendnssec2/Makefile b/dns/opendnssec2/Makefile
index ca1725c1ac33..44ac01a94e28 100644
--- a/dns/opendnssec2/Makefile
+++ b/dns/opendnssec2/Makefile
@@ -49,6 +49,7 @@ SQLITE_DESC= Use SQLite backend
MYSQL_USES= mysql
MYSQL_CONFIGURE_ON= --with-enforcer-database=mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="80 81"
SOFTHSM_RUN_DEPENDS= softhsm2>=2.5.0:security/softhsm2
SOFTHSM_CONFIGURE_ON= --with-pkcs11-softhsm=${LOCALBASE}/lib/softhsm/libsofthsm2.so
SQLITE_BUILD_DEPENDS= sqlite3>=3.3.9:databases/sqlite3
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index e10dc1a601b8..4b667933d96b 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -198,6 +198,7 @@ MYSQL_CONFIGURE_ENABLE= mysql-connector
MYSQL_CONFIGURE_WITH= system-mysql
MYSQL_LIB_DEPENDS= libmysqlcppconn.so:databases/mysql-connector-c++
MYSQL_USES= mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="80 81"
SDK_CONFIGURE_ENABLE= odk
SDK_DISTFILES= unowinreg.dll:unoreg
diff --git a/finance/quickfix/Makefile b/finance/quickfix/Makefile
index 0bcae8292c78..1130e83dbf20 100644
--- a/finance/quickfix/Makefile
+++ b/finance/quickfix/Makefile
@@ -32,7 +32,7 @@ PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= postgresql
MYSQL_USES= mysql
MYSQL_CONFIGURE_WITH= mysql
-MYSQL_VARS= IGNORE_WITH_MYSQL=80
+MYSQL_VARS= IGNORE_WITH_MYSQL="80 81"
PYTHON_USES= python:3.8
PYTHON_CONFIGURE_WITH= python3
RUBY_USES= ruby
diff --git a/ftp/smbftpd/Makefile b/ftp/smbftpd/Makefile
index 96b7e4ee6e36..9720edd46d0a 100644
--- a/ftp/smbftpd/Makefile
+++ b/ftp/smbftpd/Makefile
@@ -21,6 +21,7 @@ USE_RC_SUBR= ${PORTNAME}
MYSQL_USES= mysql
MYSQL_CONFIGURE_WITH= mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="105m 106m 1011m 80 81"
PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql
ICONV_USES= iconv
diff --git a/ftp/wzdftpd/Makefile b/ftp/wzdftpd/Makefile
index e4333430f59b..116b0cc95952 100644
--- a/ftp/wzdftpd/Makefile
+++ b/ftp/wzdftpd/Makefile
@@ -47,6 +47,7 @@ PERL_USES= perl5
MYSQL_CONFIGURE_ENABLE= mysql
MYSQL_USES= mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="80 81"
PAM_CONFIGURE_WITH= pam
diff --git a/games/ldmud/Makefile b/games/ldmud/Makefile
index c7260a2fee67..d6615796d964 100644
--- a/games/ldmud/Makefile
+++ b/games/ldmud/Makefile
@@ -45,7 +45,7 @@ IPV6_CONFIGURE_ENABLE= use-ipv6
MYSQL_USES= mysql
MYSQL_CONFIGURE_ENABLE= use-mysql
MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
-MYSQL_VARS= IGNORE_WITH_MYSQL=80
+MYSQL_VARS= IGNORE_WITH_MYSQL="105m 106m 1011m 80 81"
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ENABLE= use-pgsql
SQLITE_USES= sqlite
diff --git a/games/pvpgn/Makefile b/games/pvpgn/Makefile
index c3edb2131fbd..4c81e8487ee9 100644
--- a/games/pvpgn/Makefile
+++ b/games/pvpgn/Makefile
@@ -44,6 +44,7 @@ D2_CONFIGURE_ENABLE= d2cs d2dbs
MYSQL_USES= mysql
MYSQL_CONFIGURE_WITH= mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="80 81"
PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql
diff --git a/lang/urweb/Makefile b/lang/urweb/Makefile
index 6032091c0c6c..09fdba999199 100644
--- a/lang/urweb/Makefile
+++ b/lang/urweb/Makefile
@@ -37,6 +37,7 @@ ELISP_CONFIGURE_ON= with_emacs=yes
ELISP_CONFIGURE_OFF= with_emacs=no
MYSQL_USES= mysql
MYSQL_CONFIGURE_ENV_OFF= MSHEADER="no"
+MYSQL_VARS= IGNORE_WITH_MYSQL="105m 106m 1011m 80 81"
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ENV_OFF= PGHEADER="no"
PGSQL_VARS= WANT_PGSQL=server
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index 86033f5736f1..adfe4d029a81 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -271,6 +271,7 @@ CONFIGURE_ARGS+= --with-mysql-includes=${LOCALBASE}/include/mysql \
--with-mysql-libraries=${LOCALBASE}/lib/mysql
PLIST_SUB+= MYSQL=""
_DBDRV_COUNT:= ${_DBDRV_COUNT}o
+IGNORE_WITH_MYSQL= 105m 106m 1011m
. if ${PORT_OPTIONS:MMYSQL_COMPRESS}
CONFIGURE_ARGS+= --enable-client-compression
. endif
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
index dc5f18dfb8ef..3905f6c73aba 100644
--- a/mail/tpop3d/Makefile
+++ b/mail/tpop3d/Makefile
@@ -45,6 +45,7 @@ MYSQL_USES= mysql
MYSQL_CONFIGURE_ON= --enable-auth-mysql \
--with-mysql-lib-dir=${LOCALBASE}/lib/mysql \
--with-mysql-include-dir=${LOCALBASE}/include/mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="80 81"
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --enable-auth-pgsql \
--with-pgsql-lib-dir=${LOCALBASE}/lib \
diff --git a/mail/vpopmail/Makefile b/mail/vpopmail/Makefile
index a03b5cc197a2..fd7c9c3e64f3 100644
--- a/mail/vpopmail/Makefile
+++ b/mail/vpopmail/Makefile
@@ -148,6 +148,7 @@ ROAMING_CONFIGURE_ON= --enable-roaming-users \
MYSQL_CONFIGURE_ON= --enable-auth-module=mysql \
--enable-incdir=${LOCALBASE}/include/mysql \
--enable-libdir=${LOCALBASE}/lib/mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="105m 106m 1011m 80 81"
MYSQL_REPLICATION_CONFIGURE_ON= --enable-mysql-replication
MYSQL_LIMITS_CONFIGURE_ON= --enable-mysql-limits
diff --git a/net-im/jabberd/Makefile b/net-im/jabberd/Makefile
index 419aec13cda0..185e96e93bc5 100644
--- a/net-im/jabberd/Makefile
+++ b/net-im/jabberd/Makefile
@@ -75,6 +75,7 @@ SQLITE_LIB_DEPENDS= libsqlite3.so:databases/sqlite3
MYSQL_USES= mysql
MYSQL_CONFIGURE_ENABLE= mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="81"
BDB_USES= bdb
BDB_CONFIGURE_ENABLE= db
diff --git a/net-mgmt/super_mediator/Makefile b/net-mgmt/super_mediator/Makefile
index 7107c0db5615..755cbb35b01d 100644
--- a/net-mgmt/super_mediator/Makefile
+++ b/net-mgmt/super_mediator/Makefile
@@ -31,7 +31,7 @@ SPREAD_DESC= Enable Spread libary as a pub/sub distribution capability
MYSQL_LIB_DEPENDS= libmysqlclient.so:${_MYSQL_CLIENT}
MYSQL_USES= mysql
MYSQL_CONFIGURE_WITH= mysql
-MYSQL_VARS= IGNORE_WITH_MYSQL=80
+MYSQL_VARS= IGNORE_WITH_MYSQL="80 81"
SKIPSET_LIB_DEPENDS= libsilk.so:security/silktools
SKIPSET_CONFIGURE_WITH= skipset
SPREAD_LIB_DEPENDS= libspread.so:net/spread4
diff --git a/net-p2p/xbt/Makefile b/net-p2p/xbt/Makefile
index 3bdbafdacffb..e680d3c0c3b2 100644
--- a/net-p2p/xbt/Makefile
+++ b/net-p2p/xbt/Makefile
@@ -12,6 +12,7 @@ LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/include/boost/asio.hpp:devel/boost-libs
USES= compiler:c++17-lang mysql pkgconfig
+IGNORE_WITH_MYSQL= 105m 106m 1011m
USE_GITHUB= yes
GH_ACCOUNT= OlafvdSpek
GH_TAGNAME= 9c7dbc4
diff --git a/net/linknx/Makefile b/net/linknx/Makefile
index bd08f7794498..9d4b7147a9c5 100644
--- a/net/linknx/Makefile
+++ b/net/linknx/Makefile
@@ -48,6 +48,7 @@ LIBLUA_LDFLAGS= -L${LUA_LIBDIR}
MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}/bin/mysql_config
MYSQL_CONFIGURE_OFF= --without-mysql
MYSQL_USES= mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="80 81"
PORTDOCS= *
diff --git a/security/barnyard2/Makefile b/security/barnyard2/Makefile
index 365c62c69e10..7d9b157325da 100644
--- a/security/barnyard2/Makefile
+++ b/security/barnyard2/Makefile
@@ -52,7 +52,9 @@ MYSQL_USES= mysql
MYSQL_CONFIGURE_WITH= mysql
MYSQL_CONFIGURE_ON= --with-mysql-includes=${LOCALBASE}/include/mysql \
--with-mysql-libraries=${LOCALBASE}/lib/mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="80 81"
MYSQL_SSL_CONFIGURE_ENABLE= mysql-ssl-support
+MYSQL_SSL_VARS= IGNORE_WITH_MYSQL="80"
ODBC_BROKEN= fails to build with ODBC=on
ODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
ODBC_CONFIGURE_WITH= odbc
diff --git a/sysutils/cfengine-devel/Makefile b/sysutils/cfengine-devel/Makefile
index 9e961cb79a10..f08935556d08 100644
--- a/sysutils/cfengine-devel/Makefile
+++ b/sysutils/cfengine-devel/Makefile
@@ -60,10 +60,10 @@ PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= postgresql=${LOCALBASE}
MYSQL_USES= mysql
-MYSQL_BROKEN= configure: error: MySQL client library exports symbols (EVP_CIPHER_CTX_init) clashing with OpenSSL.
MYSQL_CONFIGURE_WITH= mysql=${LOCALBASE}
MYSQL_LIB_DEPENDS= libmysqlclient.so:${_MYSQL_CLIENT}
MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="57"
LIBVIRT_CONFIGURE_WITH= libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS+= libvirt.so:devel/libvirt
diff --git a/sysutils/cfengine320/Makefile b/sysutils/cfengine320/Makefile
index 79832a501e60..8626d32a4b81 100644
--- a/sysutils/cfengine320/Makefile
+++ b/sysutils/cfengine320/Makefile
@@ -57,11 +57,11 @@ PGSQL_CONFIGURE_WITH= --with-postgresql=${LOCALBASE}
PGSQL_CONFIGURE_OFF= --without-postgresql
MYSQL_USES= mysql
-MYSQL_BROKEN= configure: error: MySQL client library exports symbols (EVP_CIPHER_CTX_init) clashing with OpenSSL.
MYSQL_CONFIGURE_WITH= --with-mysql=${LOCALBASE}
MYSQL_CONFIGURE_OFF= --without-mysql
MYSQL_LIB_DEPENDS= libmysqlclient.so:${_MYSQL_CLIENT}
MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="57"
LIBVIRT_CONFIGURE_WITH= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS+= libvirt.so:devel/libvirt
diff --git a/sysutils/cfengine321/Makefile b/sysutils/cfengine321/Makefile
index 2df5fedc6105..8b331dbdf430 100644
--- a/sysutils/cfengine321/Makefile
+++ b/sysutils/cfengine321/Makefile
@@ -57,11 +57,11 @@ PGSQL_CONFIGURE_WITH= --with-postgresql=${LOCALBASE}
PGSQL_CONFIGURE_OFF= --without-postgresql
MYSQL_USES= mysql
-MYSQL_BROKEN= configure: error: MySQL client library exports symbols (EVP_CIPHER_CTX_init) clashing with OpenSSL.
MYSQL_CONFIGURE_WITH= --with-mysql=${LOCALBASE}
MYSQL_CONFIGURE_OFF= --without-mysql
MYSQL_LIB_DEPENDS= libmysqlclient.so:${_MYSQL_CLIENT}
MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="57"
LIBVIRT_CONFIGURE_WITH= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS+= libvirt.so:devel/libvirt
diff --git a/sysutils/cfengine322/Makefile b/sysutils/cfengine322/Makefile
index a47bf44b706c..5f09045821e2 100644
--- a/sysutils/cfengine322/Makefile
+++ b/sysutils/cfengine322/Makefile
@@ -57,11 +57,11 @@ PGSQL_CONFIGURE_WITH= --with-postgresql=${LOCALBASE}
PGSQL_CONFIGURE_OFF= --without-postgresql
MYSQL_USES= mysql
-MYSQL_BROKEN= configure: error: MySQL client library exports symbols (EVP_CIPHER_CTX_init) clashing with OpenSSL.
MYSQL_CONFIGURE_WITH= --with-mysql=${LOCALBASE}
MYSQL_CONFIGURE_OFF= --without-mysql
MYSQL_LIB_DEPENDS= libmysqlclient.so:${_MYSQL_CLIENT}
MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="57"
LIBVIRT_CONFIGURE_WITH= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS+= libvirt.so:devel/libvirt
diff --git a/sysutils/cfengine323/Makefile b/sysutils/cfengine323/Makefile
index 929fe25dc356..dfaf860c2c60 100644
--- a/sysutils/cfengine323/Makefile
+++ b/sysutils/cfengine323/Makefile
@@ -57,11 +57,11 @@ PGSQL_CONFIGURE_WITH= --with-postgresql=${LOCALBASE}
PGSQL_CONFIGURE_OFF= --without-postgresql
MYSQL_USES= mysql
-MYSQL_BROKEN= configure: error: MySQL client library exports symbols (EVP_CIPHER_CTX_init) clashing with OpenSSL.
MYSQL_CONFIGURE_WITH= --with-mysql=${LOCALBASE}
MYSQL_CONFIGURE_OFF= --without-mysql
MYSQL_LIB_DEPENDS= libmysqlclient.so:${_MYSQL_CLIENT}
MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="57"
LIBVIRT_CONFIGURE_WITH= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS+= libvirt.so:devel/libvirt
diff --git a/textproc/redland/Makefile b/textproc/redland/Makefile
index 72449e33a5bc..f621720fbaaa 100644
--- a/textproc/redland/Makefile
+++ b/textproc/redland/Makefile
@@ -42,6 +42,7 @@ BDB_CONFIGURE_WITH= bdb
MYSQL_LIB_DEPENDS= libunwind.so:devel/libunwind
MYSQL_USES= mysql ssl
MYSQL_CONFIGURE_WITH= mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="105m 106m 1011m"
PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= postgresql
diff --git a/www/kannel/Makefile b/www/kannel/Makefile
index f4d7bf3b2a85..206d89c87c41 100644
--- a/www/kannel/Makefile
+++ b/www/kannel/Makefile
@@ -38,7 +38,7 @@ OPTIONS_DEFAULT= SQLITE3
MYSQL_USES= mysql
MYSQL_CONFIGURE_WITH= mysql
-MYSQL_VARS= IGNORE_WITH_MYSQL=80
+MYSQL_VARS= IGNORE_WITH_MYSQL="80 81"
PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql
SQLITE3_USES= sqlite:3