aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-05-31 02:01:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-05-31 03:18:02 +0000
commitee993dc344b0eca45509efbf6597657c7fe5fe58 (patch)
treebd26694c78f30a2846ac00427a6c1127452828d3
parent895a12c65492a90d0c859f1c17c290fd54f9d544 (diff)
downloadports-ee993dc344b0eca45509efbf6597657c7fe5fe58.tar.gz
ports-ee993dc344b0eca45509efbf6597657c7fe5fe58.zip
devel/py-python-rapidjson: New port: Python wrapper around rapidjson
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-python-rapidjson/Makefile23
-rw-r--r--devel/py-python-rapidjson/distinfo3
-rw-r--r--devel/py-python-rapidjson/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e290ee930425..479941aa1e3c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5179,6 +5179,7 @@
SUBDIR += py-python-magic
SUBDIR += py-python-mimeparse
SUBDIR += py-python-pcre
+ SUBDIR += py-python-rapidjson
SUBDIR += py-python-socketio
SUBDIR += py-python-statsd
SUBDIR += py-python-subunit
diff --git a/devel/py-python-rapidjson/Makefile b/devel/py-python-rapidjson/Makefile
new file mode 100644
index 000000000000..4f745c6d237e
--- /dev/null
+++ b/devel/py-python-rapidjson/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= python-rapidjson
+DISTVERSION= 1.6
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python wrapper around rapidjson
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+do-test: install # tests fail: https://github.com/python-rapidjson/python-rapidjson/issues/163
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest
+
+.include <bsd.port.mk>
diff --git a/devel/py-python-rapidjson/distinfo b/devel/py-python-rapidjson/distinfo
new file mode 100644
index 000000000000..024d9243daa4
--- /dev/null
+++ b/devel/py-python-rapidjson/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1653961467
+SHA256 (python-rapidjson-1.6.tar.gz) = 189cf1a96bf9fcd86d00360f15ad76a83ce0889b8ae8d1cb0fdb2b2995e5a1c8
+SIZE (python-rapidjson-1.6.tar.gz) = 221016
diff --git a/devel/py-python-rapidjson/pkg-descr b/devel/py-python-rapidjson/pkg-descr
new file mode 100644
index 000000000000..0a3ad38a90e8
--- /dev/null
+++ b/devel/py-python-rapidjson/pkg-descr
@@ -0,0 +1,6 @@
+RapidJSON is an extremely fast C++ JSON parser and serialization
+library: this module wraps it into a Python 3 extension, exposing
+its serialization/deserialization (to/from either bytes, str or
+file-like instances) and JSON Schema validation capabilities.
+
+WWW: https://github.com/python-rapidjson/python-rapidjson