aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-09-08 15:29:00 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-09-19 09:03:22 +0000
commiteeb4b50dde8f23b2513958e5031d40a1057c7782 (patch)
treef3d1ada561427e2808bb386571043c17609e388c
parent93924a20b38e7856dc1a0df0c4514eaecdb624be (diff)
downloadports-eeb4b50dde8f23b2513958e5031d40a1057c7782.tar.gz
ports-eeb4b50dde8f23b2513958e5031d40a1057c7782.zip
Uses/cargo: Unbreak ports with CARGO_BUILD_TARGET set
While here fix their WITH_DEBUG builds too.
-rw-r--r--audio/gnome-podcasts/files/patch-scripts_cargo.sh8
-rw-r--r--audio/shortwave/files/patch-build-aux_cargo.sh15
-rw-r--r--databases/redisjson/Makefile2
-rw-r--r--deskutils/solanum/files/patch-build-aux_cargo.sh16
-rw-r--r--devel/pijul/Makefile2
-rw-r--r--editors/parinfer-rust/Makefile2
-rw-r--r--games/abstreet/Makefile2
-rw-r--r--multimedia/kooha/files/patch-build-aux_cargo.sh18
-rw-r--r--net-im/libsignal-client/Makefile2
-rw-r--r--net-im/zkgroup/Makefile2
-rw-r--r--net/quiche/Makefile8
-rw-r--r--security/arti/Makefile2
-rw-r--r--security/authenticator/files/patch-build-aux_cargo.sh15
-rw-r--r--security/sequoia/Makefile13
-rw-r--r--security/solana/Makefile2
-rw-r--r--www/deno/Makefile2
16 files changed, 91 insertions, 20 deletions
diff --git a/audio/gnome-podcasts/files/patch-scripts_cargo.sh b/audio/gnome-podcasts/files/patch-scripts_cargo.sh
new file mode 100644
index 000000000000..b69eb476b59d
--- /dev/null
+++ b/audio/gnome-podcasts/files/patch-scripts_cargo.sh
@@ -0,0 +1,8 @@
+--- scripts/cargo.sh.orig 2021-09-08 13:34:20 UTC
++++ scripts/cargo.sh
+@@ -22,4 +22,4 @@ if test -d vendor; then
+ fi
+
+ cargo build ${ARGS[@]} --manifest-path="$1"/Cargo.toml -p podcasts-gtk
+-cp "$CARGO_TARGET_DIR"/${TARGET}/podcasts-gtk "$OUTPUT"
++cp "$CARGO_TARGET_DIR"/${CARGO_BUILD_TARGET}/${TARGET}/podcasts-gtk "$OUTPUT"
diff --git a/audio/shortwave/files/patch-build-aux_cargo.sh b/audio/shortwave/files/patch-build-aux_cargo.sh
new file mode 100644
index 000000000000..80426270cd4f
--- /dev/null
+++ b/audio/shortwave/files/patch-build-aux_cargo.sh
@@ -0,0 +1,15 @@
+--- build-aux/cargo.sh.orig 2021-09-08 13:22:45 UTC
++++ build-aux/cargo.sh
+@@ -17,10 +17,10 @@ then
+ echo "** DEBUG MODE **"
+ cargo build --manifest-path \
+ "$MESON_SOURCE_ROOT"/Cargo.toml && \
+- cp "$CARGO_TARGET_DIR"/debug/shortwave $APP_OUTPUT
++ cp "$CARGO_TARGET_DIR"/$CARGO_BUILD_TARGET/debug/shortwave $APP_OUTPUT
+ else
+ echo "** RELEASE MODE **"
+ cargo build --manifest-path \
+ "$MESON_SOURCE_ROOT"/Cargo.toml --release && \
+- cp "$CARGO_TARGET_DIR"/release/shortwave $APP_OUTPUT
++ cp "$CARGO_TARGET_DIR"/$CARGO_BUILD_TARGET/release/shortwave $APP_OUTPUT
+ fi
diff --git a/databases/redisjson/Makefile b/databases/redisjson/Makefile
index 61e06337f68f..09aef0af3dc4 100644
--- a/databases/redisjson/Makefile
+++ b/databases/redisjson/Makefile
@@ -110,6 +110,6 @@ WRKSRC= ${WRKDIR}/RedisJSON-90bc4a0
PLIST_FILES= lib/librejson.so
do-install:
- ${INSTALL_LIB} ${WRKDIR}/target/release/librejson.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_LIB} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/librejson.so ${STAGEDIR}${PREFIX}/lib
.include <bsd.port.mk>
diff --git a/deskutils/solanum/files/patch-build-aux_cargo.sh b/deskutils/solanum/files/patch-build-aux_cargo.sh
new file mode 100644
index 000000000000..86989835971b
--- /dev/null
+++ b/deskutils/solanum/files/patch-build-aux_cargo.sh
@@ -0,0 +1,16 @@
+--- build-aux/cargo.sh.orig 2021-09-08 15:16:18 UTC
++++ build-aux/cargo.sh
+@@ -14,11 +14,11 @@ then
+ echo "RELEASE MODE"
+ cargo build --manifest-path \
+ "$MESON_SOURCE_ROOT"/Cargo.toml --release && \
+- cp "$CARGO_TARGET_DIR"/release/"$APP_BIN" "$OUTPUT"
++ cp "$CARGO_TARGET_DIR"/$CARGO_BUILD_TARGET/release/"$APP_BIN" "$OUTPUT"
+ else
+ echo "DEBUG MODE"
+ cargo build --manifest-path \
+ "$MESON_SOURCE_ROOT"/Cargo.toml --verbose && \
+- cp "$CARGO_TARGET_DIR"/debug/"$APP_BIN" "$OUTPUT"
++ cp "$CARGO_TARGET_DIR"/$CARGO_BUILD_TARGET/debug/"$APP_BIN" "$OUTPUT"
+ fi
+
diff --git a/devel/pijul/Makefile b/devel/pijul/Makefile
index 17bfbdc9cf17..8eea8ce5a542 100644
--- a/devel/pijul/Makefile
+++ b/devel/pijul/Makefile
@@ -283,7 +283,7 @@ post-patch:
${MV} ${WRKSRC}/cargo-crates/pijul-1.0.0-alpha.54/* ${WRKSRC}/
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/target/release/pijul ${STAGEDIR}${PREFIX}/bin/pijul
+ ${INSTALL_SCRIPT} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/pijul ${STAGEDIR}${PREFIX}/bin/pijul
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pijul
diff --git a/editors/parinfer-rust/Makefile b/editors/parinfer-rust/Makefile
index 7e5c36020f2e..08acb6f7dcf3 100644
--- a/editors/parinfer-rust/Makefile
+++ b/editors/parinfer-rust/Makefile
@@ -115,7 +115,7 @@ PLIST_FILES= bin/parinfer-rust \
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/parinfer-rust
- ${INSTALL_LIB} ${CARGO_TARGET_DIR}/*/libparinfer_rust.so \
+ ${INSTALL_LIB} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/libparinfer_rust.so \
${STAGEDIR}${PREFIX}/lib
@${MKDIR} ${STAGEDIR}${PREFIX}/share/kak/rc/extra \
${STAGEDIR}${PREFIX}/share/vim/vimfiles/doc \
diff --git a/games/abstreet/Makefile b/games/abstreet/Makefile
index e32721315db5..bca365d4ccf2 100644
--- a/games/abstreet/Makefile
+++ b/games/abstreet/Makefile
@@ -474,7 +474,7 @@ update-data: configure
${ECHO} "Please upload the file ${DISTDIR}/${PORTNAME}-data-${DISTVERSION}.tgz"
do-install:
- ${INSTALL_PROGRAM} ${WRKDIR}/target/release/game ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-game
+ ${INSTALL_PROGRAM} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/game ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-game
cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
cd ${WRKDIR}/data && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
diff --git a/multimedia/kooha/files/patch-build-aux_cargo.sh b/multimedia/kooha/files/patch-build-aux_cargo.sh
new file mode 100644
index 000000000000..058d5e193b37
--- /dev/null
+++ b/multimedia/kooha/files/patch-build-aux_cargo.sh
@@ -0,0 +1,18 @@
+--- build-aux/cargo.sh.orig 2021-09-10 08:14:31 UTC
++++ build-aux/cargo.sh
+@@ -8,13 +8,13 @@ export CARGO_HOME="$MESON_BUILD_ROOT"/cargo-home
+ if [ "$4" = "Devel" ]
+ then
+ echo "DEBUG MODE"
+ cargo build --manifest-path \
+ "$MESON_SOURCE_ROOT"/Cargo.toml && \
+- cp "$CARGO_TARGET_DIR"/debug/$5 $3
++ cp "$CARGO_TARGET_DIR"/$CARGO_BUILD_TARGET/debug/$5 $3
+ else
+ echo "RELEASE MODE"
+ cargo build --manifest-path \
+ "$MESON_SOURCE_ROOT"/Cargo.toml --release && \
+- cp "$CARGO_TARGET_DIR"/release/$5 $3
++ cp "$CARGO_TARGET_DIR"/$CARGO_BUILD_TARGET/release/$5 $3
+ fi
+
diff --git a/net-im/libsignal-client/Makefile b/net-im/libsignal-client/Makefile
index 56142af35d17..ddd49c1435f4 100644
--- a/net-im/libsignal-client/Makefile
+++ b/net-im/libsignal-client/Makefile
@@ -234,7 +234,7 @@ MAKE_ENV= CARGO_PROFILE_RELEASE_LTO=thin \
PLIST_FILES= lib/libsignal_jni.so
do-install:
- ${INSTALL_LIB} ${CARGO_TARGET_DIR}/release/libsignal_jni.so \
+ ${INSTALL_LIB} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/libsignal_jni.so \
${STAGEDIR}${PREFIX}/lib/
.include <bsd.port.mk>
diff --git a/net-im/zkgroup/Makefile b/net-im/zkgroup/Makefile
index 9fb9fb7e123e..1d67e4317728 100644
--- a/net-im/zkgroup/Makefile
+++ b/net-im/zkgroup/Makefile
@@ -134,7 +134,7 @@ CARGO_USE_GITHUB= yes
PLIST_FILES= lib/lib${PORTNAME}.so
do-install:
- ${INSTALL_LIB} ${WRKDIR}/target/release/lib${PORTNAME}.so \
+ ${INSTALL_LIB} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/lib${PORTNAME}.so \
${STAGEDIR}${PREFIX}/lib/
.include <bsd.port.mk>
diff --git a/net/quiche/Makefile b/net/quiche/Makefile
index 92408169d2e4..03a77ac30d2b 100644
--- a/net/quiche/Makefile
+++ b/net/quiche/Makefile
@@ -148,10 +148,10 @@ do-build:
# install quiche apps and libquiche
do-install:
${INSTALL_DATA} ${WRKSRC}/include/quiche.h ${STAGEDIR}${PREFIX}/include
- ${INSTALL_LIB} ${CARGO_TARGET_DIR}/release/libquiche.so ${STAGEDIR}${PREFIX}/lib
- ${INSTALL_LIB} ${CARGO_TARGET_DIR}/release/libquiche.a ${STAGEDIR}${PREFIX}/lib
- ${INSTALL_PROGRAM} ${CARGO_TARGET_DIR}/release/quiche-server ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_PROGRAM} ${CARGO_TARGET_DIR}/release/quiche-client ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_LIB} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/libquiche.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_LIB} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/libquiche.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_PROGRAM} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/quiche-server ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/quiche-client ${STAGEDIR}${PREFIX}/bin
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/security/arti/Makefile b/security/arti/Makefile
index 3514e8e39769..5aebcc585121 100644
--- a/security/arti/Makefile
+++ b/security/arti/Makefile
@@ -288,7 +288,7 @@ CARGO_CRATES= adler-1.0.2 \
PLIST_FILES= bin/arti
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/target/release/arti ${STAGEDIR}${PREFIX}/bin/arti
+ ${INSTALL_SCRIPT} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/arti ${STAGEDIR}${PREFIX}/bin/arti
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/arti
diff --git a/security/authenticator/files/patch-build-aux_cargo.sh b/security/authenticator/files/patch-build-aux_cargo.sh
new file mode 100644
index 000000000000..4682a5974221
--- /dev/null
+++ b/security/authenticator/files/patch-build-aux_cargo.sh
@@ -0,0 +1,15 @@
+--- build-aux/cargo.sh.orig 2021-09-08 15:33:49 UTC
++++ build-aux/cargo.sh
+@@ -12,10 +12,10 @@ if [ "$BUILDTYPE" = "release" ]; then
+ echo "RELEASE MODE"
+ cargo build --manifest-path \
+ "$MESON_SOURCE_ROOT"/Cargo.toml --release &&
+- cp "$CARGO_TARGET_DIR"/release/"$APP_BIN" "$OUTPUT"
++ cp "$CARGO_TARGET_DIR"/$CARGO_BUILD_TARGET/release/"$APP_BIN" "$OUTPUT"
+ else
+ echo "DEBUG MODE"
+ cargo build --manifest-path \
+ "$MESON_SOURCE_ROOT"/Cargo.toml &&
+- cp "$CARGO_TARGET_DIR"/debug/"$APP_BIN" "$OUTPUT"
++ cp "$CARGO_TARGET_DIR"/$CARGO_BUILD_TARGET/debug/"$APP_BIN" "$OUTPUT"
+ fi
diff --git a/security/sequoia/Makefile b/security/sequoia/Makefile
index df313b4195ea..3fb8334b1899 100644
--- a/security/sequoia/Makefile
+++ b/security/sequoia/Makefile
@@ -309,17 +309,16 @@ do-install:
${STAGEDIR}${PREFIX}/etc/bash_completion.d \
${STAGEDIR}${PREFIX}/share/fish/completions \
${STAGEDIR}${PREFIX}/share/zsh/site-functions
-.for f in ffi ffi_macros openpgp_ffi
- ${STRIP_CMD} ${CARGO_TARGET_DIR}/release/libsequoia_${f}.so
- ${INSTALL_LIB} ${CARGO_TARGET_DIR}/release/libsequoia_${f}.so ${STAGEDIR}${PREFIX}/lib/libsequoia_${f}.so.${SOVERS}
+.for f in ffi openpgp_ffi
+ ${INSTALL_LIB} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/libsequoia_${f}.so ${STAGEDIR}${PREFIX}/lib/libsequoia_${f}.so.${SOVERS}
${LN} -sf libsequoia_${f}.so.${SOVERS} ${STAGEDIR}${PREFIX}/lib/libsequoia_${f}.so
.endfor
+ ${INSTALL_LIB} ${CARGO_TARGET_DIR}/*/libsequoia_ffi_macros.so ${STAGEDIR}${PREFIX}/lib/libsequoia_ffi_macros.so.${SOVERS}
+ ${LN} -sf libsequoia_ffi_macros.so.${SOVERS} ${STAGEDIR}${PREFIX}/lib/libsequoia_ffi_macros.so
.for f in sq sqop sqv
- ${STRIP_CMD} ${CARGO_TARGET_DIR}/release/${f}
- ${INSTALL_PROGRAM} ${CARGO_TARGET_DIR}/release/${f} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
- ${STRIP_CMD} ${CARGO_TARGET_DIR}/release/sequoia-public-key-store
- ${INSTALL_PROGRAM} ${CARGO_TARGET_DIR}/release/sequoia-public-key-store ${STAGEDIR}${PREFIX}/lib/sequoia/sequoia-public-key-store
+ ${INSTALL_PROGRAM} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/sequoia-public-key-store ${STAGEDIR}${PREFIX}/lib/sequoia/sequoia-public-key-store
(cd ${WRKSRC}/ffi/include && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/include)
(cd ${WRKSRC}/openpgp-ffi/include/sequoia && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/include/sequoia)
diff --git a/security/solana/Makefile b/security/solana/Makefile
index a18de962357b..a2d2d6261873 100644
--- a/security/solana/Makefile
+++ b/security/solana/Makefile
@@ -566,7 +566,7 @@ LLVM_VERSION= 12
BINARY_ALIAS= llvm-config=${PREFIX}/bin/llvm-config${LLVM_VERSION}
do-install:
- for f in ${WRKDIR}/target/release/${PORTNAME}*; do \
+ for f in ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/${PORTNAME}*; do \
if [ -f $$f -a -x $$f ]; then \
${INSTALL_PROGRAM} $$f ${STAGEDIR}${PREFIX}/bin; \
fi \
diff --git a/www/deno/Makefile b/www/deno/Makefile
index 589941b81608..6a0b1b64b568 100644
--- a/www/deno/Makefile
+++ b/www/deno/Makefile
@@ -462,6 +462,6 @@ post-patch:
${WRKSRC}/cargo-crates/rusty_v8-${RUSTY_VERS}/buildtools/third_party/libc++/BUILD.gn
do-install:
- ${INSTALL_PROGRAM} ${WRKDIR}/target/release/deno ${STAGEDIR}${LOCALBASE}/bin
+ ${INSTALL_PROGRAM} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/deno ${STAGEDIR}${LOCALBASE}/bin
.include <bsd.port.mk>