aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Bowling <kbowling@FreeBSD.org>2022-11-17 20:37:33 +0000
committerKevin Bowling <kbowling@FreeBSD.org>2022-11-17 20:37:33 +0000
commitef05af24b96df5cf4b4a879b4e018ebc631e038f (patch)
treea3e9b9e7342ad6bc4d88befb7a3c539cc74bb69c
parent3addd2c76fff6267fe90bd6019dc3ae0bf2d8452 (diff)
downloadports-ef05af24b96df5cf4b4a879b4e018ebc631e038f.tar.gz
ports-ef05af24b96df5cf4b4a879b4e018ebc631e038f.zip
net/stc: New port - Syncthing CLI
-rw-r--r--net/Makefile1
-rw-r--r--net/stc/Makefile26
-rw-r--r--net/stc/distinfo11
-rw-r--r--net/stc/pkg-descr5
4 files changed, 43 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 562d45659075..bcfc9d5d68e7 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1457,6 +1457,7 @@
SUBDIR += ssldump
SUBDIR += sslh
SUBDIR += ssspl
+ SUBDIR += stc
SUBDIR += stone
SUBDIR += storj
SUBDIR += stund
diff --git a/net/stc/Makefile b/net/stc/Makefile
new file mode 100644
index 000000000000..7329086caf0f
--- /dev/null
+++ b/net/stc/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= stc
+PORTVERSION= 1.4
+CATEGORIES= net
+
+MAINTAINER= kbowling@FreeBSD.org
+COMMENT= Syncthing CLI Tool
+WWW= https://github.com/tenox7/stc
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+USE_GITHUB= yes
+GH_ACCOUNT= tenox7
+GH_TUPLE= dustin:go-humanize:v1.0.0:dustin_go_humanize/vendor/github.com/dustin/go-humanize \
+ go-resty:resty:v2.7.0:go_resty_resty_v2/vendor/github.com/go-resty/resty/v2 \
+ golang:net:99673261e6eb:golang_net/vendor/golang.org/x/net \
+ hako:durafmt:5c1018a4e16b:hako_durafmt/vendor/github.com/hako/durafmt
+
+PLIST_FILES= bin/stc
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|"homedir", ""|"homedir", "${LOCALBASE}/etc/syncthing"|' ${WRKSRC}/stc.go
+
+.include <bsd.port.mk>
+
diff --git a/net/stc/distinfo b/net/stc/distinfo
new file mode 100644
index 000000000000..f8d8bced0bbe
--- /dev/null
+++ b/net/stc/distinfo
@@ -0,0 +1,11 @@
+TIMESTAMP = 1668716754
+SHA256 (tenox7-stc-1.4_GH0.tar.gz) = 5bae51e0fa34311c1ec9e2798badc6fb8b6333485d295beb8631936faeaeb1dc
+SIZE (tenox7-stc-1.4_GH0.tar.gz) = 10810
+SHA256 (dustin-go-humanize-v1.0.0_GH0.tar.gz) = e4540bd50ac855143b4f2e509313079c50cf5d8774f09cc10dbca5ae9803d8ba
+SIZE (dustin-go-humanize-v1.0.0_GH0.tar.gz) = 17260
+SHA256 (go-resty-resty-v2.7.0_GH0.tar.gz) = 9afa2ab22afb81b4ff7275f5a2cb055b1bf3b19ff9506036f35c85ec0465beee
+SIZE (go-resty-resty-v2.7.0_GH0.tar.gz) = 2644943
+SHA256 (golang-net-99673261e6eb_GH0.tar.gz) = d510c40d6888589063dd5a9c6c08aee8c6b841d7ba46098758ada330e0adc923
+SIZE (golang-net-99673261e6eb_GH0.tar.gz) = 1262432
+SHA256 (hako-durafmt-5c1018a4e16b_GH0.tar.gz) = dde0e91c9bb3b662c74b86ef6ae28f72f795a59051ba5b8254ba0402ce714ccf
+SIZE (hako-durafmt-5c1018a4e16b_GH0.tar.gz) = 9790
diff --git a/net/stc/pkg-descr b/net/stc/pkg-descr
new file mode 100644
index 000000000000..db0832115093
--- /dev/null
+++ b/net/stc/pkg-descr
@@ -0,0 +1,5 @@
+Stc is a command line tool for Syncthing. It can be used to quickly check
+status of Syncthing from a terminal / command line without need of a Web
+Browser. For example on a remote machine over ssh, without port forwarding or
+if you have large number of machines to query. Also run from a script,
+crontab, scheduled task, etc.