aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-02-11 12:09:55 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-02-11 12:12:27 +0000
commitef2d0a35dd40b8b59bf9f94b3887d26631b3465d (patch)
treed6022e4e3e12c6ab8b30d6e25ce29e50670ac955
parent929a40f5e1c91f3930f7567ad6b312d2d40f89d3 (diff)
downloadports-ef2d0a35dd40b8b59bf9f94b3887d26631b3465d.tar.gz
ports-ef2d0a35dd40b8b59bf9f94b3887d26631b3465d.zip
x11-wm/gamescope: unbundle libliftoff after 929a40f5e1c9
This reverts commit 8947b5348e896ba308935f13823954443ca3655c.
-rw-r--r--x11-wm/gamescope/Makefile5
-rw-r--r--x11-wm/gamescope/distinfo2
-rw-r--r--x11-wm/gamescope/files/patch-private-libs27
3 files changed, 2 insertions, 32 deletions
diff --git a/x11-wm/gamescope/Makefile b/x11-wm/gamescope/Makefile
index 501d1f6364e0..ad93b7e39eeb 100644
--- a/x11-wm/gamescope/Makefile
+++ b/x11-wm/gamescope/Makefile
@@ -20,6 +20,7 @@ BUILD_DEPENDS= glslangValidator:graphics/glslang \
wlroots>=0.15.0<0.16.0:x11-toolkits/wlroots
LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
libdrm.so:graphics/libdrm \
+ libliftoff.so:graphics/libliftoff \
libvulkan.so:graphics/vulkan-loader \
libwayland-server.so:graphics/wayland \
libwlroots.so:x11-toolkits/wlroots \
@@ -27,14 +28,12 @@ LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
USES= compiler:c++11-lib meson pkgconfig sdl xorg
USE_GITHUB= yes
-USE_GITLAB= nodefault
USE_SDL= sdl2
USE_XORG= x11 xcomposite xdamage xext xfixes xrender xres xtst xxf86vm
GH_ACCOUNT= Plagman
GH_TUPLE= nothings:stb:af1a5bc:stb/subprojects/stb
-GL_TUPLE= https://gitlab.freedesktop.org:emersion:libliftoff:378ccb4f84a2473fe73dbdc56fe35a0d2ee661cc:libliftoff/subprojects/libliftoff
PLIST_FILES= bin/${PORTNAME}
-MESON_ARGS= --force-fallback-for=libliftoff # allow system wlroots
+MESON_ARGS= --force-fallback-for= # allow system wlroots + libliftoff
OPTIONS_DEFINE= PIPEWIRE
OPTIONS_DEFAULT=PIPEWIRE
diff --git a/x11-wm/gamescope/distinfo b/x11-wm/gamescope/distinfo
index 08648a55d336..43421b132073 100644
--- a/x11-wm/gamescope/distinfo
+++ b/x11-wm/gamescope/distinfo
@@ -3,8 +3,6 @@ SHA256 (Plagman-gamescope-3.11.10_GH0.tar.gz) = c353cb9dd310ea74be25ec96104ff1bb
SIZE (Plagman-gamescope-3.11.10_GH0.tar.gz) = 153805
SHA256 (nothings-stb-af1a5bc_GH0.tar.gz) = 3facf6e6f8c3e1715e1a088f22bad9c9202973f9369fb3f088f46cced3f64058
SIZE (nothings-stb-af1a5bc_GH0.tar.gz) = 1387334
-SHA256 (emersion-libliftoff-378ccb4f84a2473fe73dbdc56fe35a0d2ee661cc_GL0.tar.gz) = 7f296842c84e536432c38d069518c705be04c4c44937bc19a28e887e84ee9103
-SIZE (emersion-libliftoff-378ccb4f84a2473fe73dbdc56fe35a0d2ee661cc_GL0.tar.gz) = 31371
SHA256 (2a84a44f6897.patch) = fd892d4477885926b0ef5793d5222764afa2ba334fd25c4cc671c89812e100b5
SIZE (2a84a44f6897.patch) = 2931
SHA256 (e0927f7bce95.patch) = 6bbab2f37d7e76a1eade6d81bc0b441cc09f0020143bafb53555b767bf056600
diff --git a/x11-wm/gamescope/files/patch-private-libs b/x11-wm/gamescope/files/patch-private-libs
deleted file mode 100644
index e2961b1e65e9..000000000000
--- a/x11-wm/gamescope/files/patch-private-libs
+++ /dev/null
@@ -1,27 +0,0 @@
-libliftoff is untagged and has no other consumers. Keep it private to
-gamescope package for now.
-
---- subprojects/libliftoff/meson.build.orig 2020-05-26 19:30:31 UTC
-+++ subprojects/libliftoff/meson.build
-@@ -38,7 +38,7 @@ liftoff_lib = library(
- include_directories: liftoff_inc,
- version: meson.project_version(),
- dependencies: liftoff_deps,
-- install: true,
-+ install: not meson.is_subproject(),
- )
-
- liftoff = declare_dependency(
-@@ -47,6 +47,7 @@ liftoff = declare_dependency(
- dependencies: liftoff_deps,
- )
-
-+if not meson.is_subproject()
- install_headers('include/libliftoff.h')
-
- pkgconfig = import('pkgconfig')
-@@ -60,3 +61,4 @@ pkgconfig.generate(
-
- subdir('example')
- subdir('test')
-+endif