aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-02-07 21:43:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-02-07 21:43:29 +0000
commitefeac52180feb8ee346f787151ed082ff449b260 (patch)
treea8b4b0024648e95c1fc1f5bd81bac9379ccdfd31
parentca98d073c82b6fd0d5d622d7a475639c13b7a638 (diff)
downloadports-efeac52180feb8ee346f787151ed082ff449b260.tar.gz
ports-efeac52180feb8ee346f787151ed082ff449b260.zip
Check the PEP-8 naming conventions.
This module provides a plugin for flake8, the Python code checker. (It replaces the plugin flint-naming for the flint checker.) WWW: https://pypi.python.org/pypi/pep8-naming
Notes
Notes: svn path=/head/; revision=461188
-rw-r--r--devel/Makefile3
-rw-r--r--devel/py-pep8-naming/Makefile25
-rw-r--r--devel/py-pep8-naming/distinfo3
-rw-r--r--devel/py-pep8-naming/pkg-descr7
4 files changed, 37 insertions, 1 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 451d2a5f2f5f..49ae9938b92a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4681,6 +4681,7 @@
SUBDIR += py-paver
SUBDIR += py-pbr
SUBDIR += py-pefile
+ SUBDIR += py-pep8-naming
SUBDIR += py-period
SUBDIR += py-petname
SUBDIR += py-pex
@@ -5959,8 +5960,8 @@
SUBDIR += sysconftool
SUBDIR += sysfsutils
SUBDIR += t1lib
- SUBDIR += tablist
SUBDIR += ta-lib
+ SUBDIR += tablist
SUBDIR += tailor
SUBDIR += talloc
SUBDIR += tass64
diff --git a/devel/py-pep8-naming/Makefile b/devel/py-pep8-naming/Makefile
new file mode 100644
index 000000000000..24eec23d901a
--- /dev/null
+++ b/devel/py-pep8-naming/Makefile
@@ -0,0 +1,25 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pep8-naming
+PORTVERSION= 0.5.0
+CATEGORIES= devel
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Check PEP-8 naming conventions, plugin for flake8
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flake8-polyfill>=0:devel/py-flake8-polyfill@${FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/devel/py-pep8-naming/distinfo b/devel/py-pep8-naming/distinfo
new file mode 100644
index 000000000000..fa6b3d87afbf
--- /dev/null
+++ b/devel/py-pep8-naming/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518037481
+SHA256 (pep8-naming-0.5.0.tar.gz) = 5a2a085340b1d530605a7f4a96816433be43504c58eace799dbacdcfd6febe9d
+SIZE (pep8-naming-0.5.0.tar.gz) = 9277
diff --git a/devel/py-pep8-naming/pkg-descr b/devel/py-pep8-naming/pkg-descr
new file mode 100644
index 000000000000..73e0cfbb4c4d
--- /dev/null
+++ b/devel/py-pep8-naming/pkg-descr
@@ -0,0 +1,7 @@
+Check the PEP-8 naming conventions.
+
+This module provides a plugin for flake8, the Python code checker.
+
+(It replaces the plugin flint-naming for the flint checker.)
+
+WWW: https://pypi.python.org/pypi/pep8-naming