aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-10-22 06:39:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-10-22 08:57:03 +0000
commiteff5086be6c0ccdbb464c3c7db0c743e5371e191 (patch)
treeee6baac590dd32f5474a622d99b76aa918be4137
parentedc0a1f182bf6a490f0a442ec954493e1b6926b4 (diff)
www/cpp-httplib: Update 0.9.4 -> 0.9.7
Reported by: portscout
-rw-r--r--www/cpp-httplib/Makefile2
-rw-r--r--www/cpp-httplib/distinfo6
-rw-r--r--www/cpp-httplib/files/patch-test_Makefile10
3 files changed, 10 insertions, 8 deletions
diff --git a/www/cpp-httplib/Makefile b/www/cpp-httplib/Makefile
index 39fee9d6649e..6e63927edf6d 100644
--- a/www/cpp-httplib/Makefile
+++ b/www/cpp-httplib/Makefile
@@ -1,6 +1,6 @@
PORTNAME= cpp-httplib
DISTVERSIONPREFIX= v
-DISTVERSION= 0.9.4
+DISTVERSION= 0.9.7
CATEGORIES= www devel
MAINTAINER= yuri@FreeBSD.org
diff --git a/www/cpp-httplib/distinfo b/www/cpp-httplib/distinfo
index f1a7df9b19d8..ad816b931789 100644
--- a/www/cpp-httplib/distinfo
+++ b/www/cpp-httplib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1630860508
-SHA256 (yhirose-cpp-httplib-v0.9.4_GH0.tar.gz) = 0ff62e28eb0f6e563178d44b77c94dddb8702141d83dd34b83cb046399c2b1d5
-SIZE (yhirose-cpp-httplib-v0.9.4_GH0.tar.gz) = 601066
+TIMESTAMP = 1634884150
+SHA256 (yhirose-cpp-httplib-v0.9.7_GH0.tar.gz) = c8ef7d19842c63747eaa844d25732eb999250716bdf658b876a9c34b274af22c
+SIZE (yhirose-cpp-httplib-v0.9.7_GH0.tar.gz) = 605134
diff --git a/www/cpp-httplib/files/patch-test_Makefile b/www/cpp-httplib/files/patch-test_Makefile
index c818a121e196..20daf919ce67 100644
--- a/www/cpp-httplib/files/patch-test_Makefile
+++ b/www/cpp-httplib/files/patch-test_Makefile
@@ -1,4 +1,4 @@
---- test/Makefile.orig 2021-08-24 16:49:33 UTC
+--- test/Makefile.orig 2021-10-15 11:13:16 UTC
+++ test/Makefile
@@ -1,5 +1,5 @@
#CXX = clang++
@@ -7,13 +7,15 @@
OPENSSL_DIR = /usr/local/opt/openssl@1.1
OPENSSL_SUPPORT = -DCPPHTTPLIB_OPENSSL_SUPPORT -I$(OPENSSL_DIR)/include -L$(OPENSSL_DIR)/lib -lssl -lcrypto
-@@ -20,13 +20,13 @@ proxy : test_proxy
+@@ -26,15 +26,15 @@ proxy : test_proxy
./test_proxy
test : test.cc include_httplib.cc ../httplib.h Makefile cert.pem
- $(CXX) -o $@ -I.. $(CXXFLAGS) test.cc include_httplib.cc $(TEST_ARGS)
+ $(CXX) -o $@ -I.. $(CXXFLAGS) test.cc include_httplib.cc ${LDFLAGS} $(TEST_ARGS)
+ # Note: The intention of test_split is to verify that it works to compile and
+ # link the split httplib.h, so there is normally no need to execute it.
test_split : test.cc ../httplib.h httplib.cc Makefile cert.pem
- $(CXX) -o $@ $(CXXFLAGS) test.cc httplib.cc $(TEST_ARGS)
+ $(CXX) -o $@ $(CXXFLAGS) test.cc httplib.cc ${LDFLAGS} $(TEST_ARGS)
@@ -22,5 +24,5 @@
- $(CXX) -o $@ -I.. $(CXXFLAGS) test_proxy.cc $(TEST_ARGS)
+ $(CXX) -o $@ -I.. $(CXXFLAGS) test_proxy.cc ${LDFLAGS} $(TEST_ARGS)
- httplib.cc : ../httplib.h
- python3 ../split.py -o .
+ # Runs server_fuzzer.cc based on value of $(LIB_FUZZING_ENGINE).
+ # Usage: make fuzz_test LIB_FUZZING_ENGINE=/path/to/libFuzzer