aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-05 15:20:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-05 15:38:27 +0000
commitf08c70e21923fcf2e37f087bddbcc1abd6a336b5 (patch)
treeae301416ad6d8997f48ee1cfe430364097edd795
parent6d9b7dea668df2009e3fd41675991fa253bbbf34 (diff)
downloadports-f08c70e21923fcf2e37f087bddbcc1abd6a336b5.tar.gz
ports-f08c70e21923fcf2e37f087bddbcc1abd6a336b5.zip
devel/py-numba: Remove BROKEN and disable TBB instead
numba is not compatible with onetbb-2021.6.0 Approved by: portmgr (unbreak)
-rw-r--r--devel/py-numba/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/py-numba/Makefile b/devel/py-numba/Makefile
index ca658f6189bc..5ec716d6b3f3 100644
--- a/devel/py-numba/Makefile
+++ b/devel/py-numba/Makefile
@@ -11,7 +11,6 @@ WWW= https://numba.pydata.org/
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN= not compatible with onetbb-2021.6.0, see https://github.com/numba/numba/issues/8487
.if !exists(/usr/include/omp.h)
BROKEN= requires OpenMP support that is missing on this architecture
.endif
@@ -23,6 +22,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}llvmlite>=0.31.0:devel/py-llvmlite@${PY_FLAV
USES= compiler:c++11-lang python:3.6+ fortran localbase
USE_PYTHON= distutils concurrent autoplist unittest
+MAKE_ENV= NUMBA_DISABLE_TBB=1 # workaround for: not compatible with onetbb-2021.6.0, see https://github.com/numba/numba/issues/8487
TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
TEST_WRKSRC= ${WRKSRC}/numba/tests