aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-01-10 10:52:42 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-01-10 10:52:42 +0000
commitf0dd69ce62987415664eb8d9dba3dde079a19a38 (patch)
tree91ed0c1a0e3ed05e4c1565600e241ea2a62a66de
parentc5a743203c5c76c2b8bc427c22c2ac3bfffd37f8 (diff)
downloadports-f0dd69ce62987415664eb8d9dba3dde079a19a38.tar.gz
ports-f0dd69ce62987415664eb8d9dba3dde079a19a38.zip
lang/php81: Fix some compile-time warning
Sponsored by: Bounce Experts
-rw-r--r--lang/php81/Makefile28
1 files changed, 9 insertions, 19 deletions
diff --git a/lang/php81/Makefile b/lang/php81/Makefile
index 1a2919fa1ffb..14f0dd453fec 100644
--- a/lang/php81/Makefile
+++ b/lang/php81/Makefile
@@ -264,19 +264,17 @@ CONFIGURE_ARGS+= --enable-exif
.if ${PHP_MODNAME} == "ffi"
LIB_DEPENDS= libffi.so:devel/libffi
-CONFIGURE_ARGS+= --enable-ffi
+CONFIGURE_ARGS+= --with-ffi
.endif
.if ${PHP_MODNAME} == "fileinfo"
-CONFIGURE_ARGS+= --enable-fileinfo \
- --with-pcre-dir=${LOCALBASE}
+CONFIGURE_ARGS+= --enable-fileinfo
PHP_HEADER_DIRS= libmagic
.endif
.if ${PHP_MODNAME} == "filter"
-CONFIGURE_ARGS+= --enable-filter \
- --with-pcre-dir=${LOCALBASE}
+CONFIGURE_ARGS+= --enable-filter
.endif
.if ${PHP_MODNAME} == "ftp"
@@ -344,8 +342,7 @@ PANDA_LIB_DEPENDS= libc-client4.so.10:mail/panda-cclient
PANDA_LIB_DEPENDS_OFF= libc-client4.so.9:mail/cclient
CONFIGURE_ARGS+= --with-imap-ssl=${OPENSSLBASE} \
- --with-imap=${LOCALBASE} \
- --with-pcre-dir=${LOCALBASE}
+ --with-imap=${LOCALBASE}
CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
OPENSSL_LIBS="-L${OPENSSLLIB} -lssl -lcrypto" \
@@ -375,15 +372,13 @@ USE_OPENLDAP= yes
.if ${PHP_MODNAME} == "mbstring"
-CONFIGURE_ARGS+= --enable-mbstring \
- --with-pcre-dir=${LOCALBASE}
+CONFIGURE_ARGS+= --enable-mbstring
OPTIONS_DEFINE= REGEX
OPTIONS_DEFAULT= REGEX
REGEX_DESC= Enable multibyte regex support
REGEX_LIB_DEPENDS= libonig.so:devel/oniguruma
-REGEX_CONFIGURE_ON= --with-onig=${LOCALBASE}
REGEX_CONFIGURE_OFF= --disable-mbregex
PHP_HEADER_DIRS= libmbfl libmbfl/filters libmbfl/mbfl libmbfl/nls
@@ -489,8 +484,7 @@ CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "phar"
-CONFIGURE_ARGS+= --enable-phar \
- --with-pcre-dir=${LOCALBASE}
+CONFIGURE_ARGS+= --enable-phar
.endif
.if ${PHP_MODNAME} == "posix"
@@ -518,16 +512,14 @@ CONFIGURE_ARGS+= --enable-shmop
.endif
.if ${PHP_MODNAME} == "simplexml"
-CONFIGURE_ARGS+= --enable-simplexml \
- --with-pcre-dir=${LOCALBASE}
+CONFIGURE_ARGS+= --enable-simplexml
USES+= pkgconfig
USE_GNOME= libxml2
.endif
.if ${PHP_MODNAME} == "snmp"
-CONFIGURE_ARGS+= --with-openssl-dir=${OPENSSLBASE} \
- --with-snmp=${LOCALBASE}
+CONFIGURE_ARGS+= --with-snmp=${LOCALBASE}
CONFIGURE_ENV+= ac_cv_buggy_snprint_value="no"
@@ -623,9 +615,7 @@ USE_PHP= dom:build xml:build
.if ${PHP_MODNAME} == "zip"
LIB_DEPENDS+= libzip.so:archivers/libzip
-CONFIGURE_ARGS+= --enable-zip \
- --with-libzip=${LOCALBASE} \
- --with-pcre-dir=${LOCALBASE} \
+CONFIGURE_ARGS+= --with-zip \
--with-zlib-dir=/usr
USES+= pkgconfig
.endif