aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2022-02-12 14:25:52 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2022-02-12 14:28:05 +0000
commitf0f667985b8db89511e7caf5a37fa151f10e1cde (patch)
tree72db005a5321955dce517e89fed8c0adde1ba312
parent48c4e18b780d35c9e5750d247a2359e17c2ff93c (diff)
downloadports-f0f667985b8db89511e7caf5a37fa151f10e1cde.tar.gz
ports-f0f667985b8db89511e7caf5a37fa151f10e1cde.zip
net/asterisk16: Fix build when textproc/xmlstarlet is installed
Asterisk build system checks for presence of xmlstarlet as "xml" binary on the system. If found it triggers part of the build system trying to download some external files during the install phase which even uses a command line tool not available on FreeBSD. Such code is not necessary for the port, as all supported modules are downloaded using ports tree provided functionality. Furthermore downloading files from the internet is forbidden during the install phase. This patch forces the variable used by the Makefiles to identify xmlstarlet presence to be empty. so the code path described above is not triggered. PR: 261884
-rw-r--r--net/asterisk16/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index 13cfd4632e91..423862bbf71c 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -240,6 +240,7 @@ post-extract-OPUS-on:
post-patch:
@${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/samples/musiconhold.conf.sample
+ @${REINPLACE_CMD} -e 's/@XMLSTARLET@//' ${WRKSRC}/makeopts.in
.if exists(${FILESDIR}/.asterisk.makeopts)
${CP} ${FILESDIR}/.asterisk.makeopts ${WRKSRC}/menuselect.makeopts
.endif