aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-18 20:56:23 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-18 20:58:13 +0000
commitf2488f960dc89761a6bd51a036168f737bb99988 (patch)
tree18bc322a2d0f9150fce9f69fdf23dea49772a4bc
parente78f59a93488ac118e3b2a8e4e8a0f10a86aef58 (diff)
downloadports-f2488f960dc89761a6bd51a036168f737bb99988.tar.gz
ports-f2488f960dc89761a6bd51a036168f737bb99988.zip
games/openttd: fix build with LLVM 15 on powerpc*
Use LLVM 16 instead: Assertion failed: (!KnownValid && "Explicit template arguments?"), function AddOverloadedCallCandidate, file /usr/local/poudriere/jails/main-powerpc64le/usr/src/contrib/llvm-project/clang/lib/Sema/SemaOverload.cpp, line 12672.
-rw-r--r--games/openttd/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 12ef1dbac690..48a7d231120e 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png \
liblzo2.so:archivers/lzo2
-USES= cmake compiler:c++17-lang cpe pkgconfig tar:xz
+USES= cmake cpe pkgconfig tar:xz
CMAKE_ARGS= -DCMAKE_INSTALL_BINDIR:PATH=bin \
-DCMAKE_INSTALL_DATADIR:PATH=share
@@ -41,6 +41,14 @@ SERVER_VARS= USE_RC_SUBR=${PORTNAME}
.include <bsd.port.options.mk>
+.if ${ARCH:Mpowerpc*} && ${OSVERSION} > 1400078
+USES+= llvm:min=16
+CC= clang${LLVM_VERSION}
+CXX= clang++${LLVM_VERSION}
+.else
+USES+= compiler:c++17-lang
+.endif
+
.if exists(${LOCALBASE}/lib/libSDL2.so)
_SDL_VERSION= sdl2
.else