aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2024-08-05 22:12:04 +0000
committerBrooks Davis <brooks@FreeBSD.org>2024-08-05 22:14:25 +0000
commitf29d2e2be68d1bd86a5a58467dbd808b8854783e (patch)
tree20137d03eb68e87f2fbbc81bc429ce20c535d818
parent39f3db52995f34c4dd479a51090bb9297ff333bb (diff)
downloadports-f29d2e2be68d1bd86a5a58467dbd808b8854783e.tar.gz
ports-f29d2e2be68d1bd86a5a58467dbd808b8854783e.zip
devel/llvm-devel: new snapshot
In limited testing, this appears to resolve excess memory use in llvm-tblgen for some RISC-V related backend bits. This showed up as all the i386 builds failing over the weekend. Sponsored by: DARPA, AFRL
-rw-r--r--devel/llvm-devel/Makefile.RUNTIMES3
-rw-r--r--devel/llvm-devel/Makefile.snapshot4
-rw-r--r--devel/llvm-devel/distinfo6
-rw-r--r--devel/llvm-devel/pkg-plist9
4 files changed, 16 insertions, 6 deletions
diff --git a/devel/llvm-devel/Makefile.RUNTIMES b/devel/llvm-devel/Makefile.RUNTIMES
index aa085a453cb7..697bca5b182d 100644
--- a/devel/llvm-devel/Makefile.RUNTIMES
+++ b/devel/llvm-devel/Makefile.RUNTIMES
@@ -59,6 +59,9 @@ LIBCLANG_RT_LIBS_i386= \
builtins.a \
cfi.a \
cfi_diag.a \
+ fuzzer.a \
+ fuzzer_interceptors.a \
+ fuzzer_no_main.a \
profile.a \
safestack.a \
stats.a \
diff --git a/devel/llvm-devel/Makefile.snapshot b/devel/llvm-devel/Makefile.snapshot
index 9c854da6f027..bd6c334b2928 100644
--- a/devel/llvm-devel/Makefile.snapshot
+++ b/devel/llvm-devel/Makefile.snapshot
@@ -4,6 +4,6 @@
#
LLVM_MAJOR= 20
LLVM_RELEASE= ${LLVM_MAJOR}.0.0
-SNAPDATE= 20240801
+SNAPDATE= 20240805
-LLVM_PROJECT_COMMIT= a0d8fa5d3a7e05d30004dd4faeb45c1a96fd8769
+LLVM_PROJECT_COMMIT= 88d288489e09a261f6740972dcaf6fedaf87a762
diff --git a/devel/llvm-devel/distinfo b/devel/llvm-devel/distinfo
index 1f80ed4296c2..4e00691e5071 100644
--- a/devel/llvm-devel/distinfo
+++ b/devel/llvm-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1722467788
-SHA256 (llvm-llvm-project-20.0.d20240801-a0d8fa5d3a7e05d30004dd4faeb45c1a96fd8769_GH0.tar.gz) = 465bcde57a05cffccc6f5bd08de2a493a518a37c6d88c297696e3e2bad591065
-SIZE (llvm-llvm-project-20.0.d20240801-a0d8fa5d3a7e05d30004dd4faeb45c1a96fd8769_GH0.tar.gz) = 217778096
+TIMESTAMP = 1722888177
+SHA256 (llvm-llvm-project-20.0.d20240805-88d288489e09a261f6740972dcaf6fedaf87a762_GH0.tar.gz) = be9af397e8c6bdac7520b03635d85e391cd92299980ad9f075b3d6bc0ad8539c
+SIZE (llvm-llvm-project-20.0.d20240805-88d288489e09a261f6740972dcaf6fedaf87a762_GH0.tar.gz) = 218023440
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index 68350d6ec775..f914b1c68098 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -1066,6 +1066,7 @@ llvm-devel/bin/verify-uselistorder
%%CLANG%%llvm-devel/include/clang/Basic/FileManager.h
%%CLANG%%llvm-devel/include/clang/Basic/FileSystemOptions.h
%%CLANG%%llvm-devel/include/clang/Basic/FileSystemStatCache.h
+%%CLANG%%llvm-devel/include/clang/Basic/HLSLIntangibleTypes.def
%%CLANG%%llvm-devel/include/clang/Basic/HLSLRuntime.h
%%CLANG%%llvm-devel/include/clang/Basic/HeaderInclude.h
%%CLANG%%llvm-devel/include/clang/Basic/IdentifierTable.h
@@ -1793,7 +1794,9 @@ llvm-devel/bin/verify-uselistorder
%%FLANG%%llvm-devel/include/flang/Parser/tools.h
%%FLANG%%llvm-devel/include/flang/Parser/unparse.h
%%FLANG%%llvm-devel/include/flang/Parser/user-state.h
+%%FLANG%%llvm-devel/include/flang/Runtime/CUDA/allocator.h
%%FLANG%%llvm-devel/include/flang/Runtime/allocatable.h
+%%FLANG%%llvm-devel/include/flang/Runtime/allocator-registry.h
%%FLANG%%llvm-devel/include/flang/Runtime/array-constructor.h
%%FLANG%%llvm-devel/include/flang/Runtime/assign.h
%%FLANG%%llvm-devel/include/flang/Runtime/c-or-cpp.h
@@ -2300,6 +2303,7 @@ llvm-devel/bin/verify-uselistorder
%%LLDB%%llvm-devel/include/lldb/Target/RegisterTypeBuilder.h
%%LLDB%%llvm-devel/include/lldb/Target/RemoteAwarePlatform.h
%%LLDB%%llvm-devel/include/lldb/Target/Runtime.h
+%%LLDB%%llvm-devel/include/lldb/Target/ScriptedThreadPlan.h
%%LLDB%%llvm-devel/include/lldb/Target/SectionLoadHistory.h
%%LLDB%%llvm-devel/include/lldb/Target/SectionLoadList.h
%%LLDB%%llvm-devel/include/lldb/Target/StackFrame.h
@@ -2321,7 +2325,6 @@ llvm-devel/bin/verify-uselistorder
%%LLDB%%llvm-devel/include/lldb/Target/ThreadPlanCallFunctionUsingABI.h
%%LLDB%%llvm-devel/include/lldb/Target/ThreadPlanCallOnFunctionExit.h
%%LLDB%%llvm-devel/include/lldb/Target/ThreadPlanCallUserExpression.h
-%%LLDB%%llvm-devel/include/lldb/Target/ThreadPlanPython.h
%%LLDB%%llvm-devel/include/lldb/Target/ThreadPlanRunToAddress.h
%%LLDB%%llvm-devel/include/lldb/Target/ThreadPlanShouldStopHere.h
%%LLDB%%llvm-devel/include/lldb/Target/ThreadPlanStack.h
@@ -6252,6 +6255,10 @@ llvm-devel/include/llvm/XRay/YAMLXRayRecord.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_MAJOR%%/include/arm_sve.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_MAJOR%%/include/arm_vector_types.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_MAJOR%%/include/armintr.h
+%%CLANG%%llvm-devel/lib/clang/%%LLVM_MAJOR%%/include/avx10_2_512minmaxintrin.h
+%%CLANG%%llvm-devel/lib/clang/%%LLVM_MAJOR%%/include/avx10_2_512niintrin.h
+%%CLANG%%llvm-devel/lib/clang/%%LLVM_MAJOR%%/include/avx10_2minmaxintrin.h
+%%CLANG%%llvm-devel/lib/clang/%%LLVM_MAJOR%%/include/avx10_2niintrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_MAJOR%%/include/avx2intrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_MAJOR%%/include/avx512bf16intrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_MAJOR%%/include/avx512bitalgintrin.h