aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2022-11-15 00:26:06 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2022-11-15 00:26:06 +0000
commitf3b1ad45c3b6e926824002047157993e8f05beb8 (patch)
tree4d3316607268f9cf96d55f56fcb3403cf7c8d59c
parent87ab6d409fe6e8988872b18a4128713fe0e3d9eb (diff)
downloadports-f3b1ad45c3b6e926824002047157993e8f05beb8.tar.gz
ports-f3b1ad45c3b6e926824002047157993e8f05beb8.zip
lang/ldc: Update to 1.30.0
- Commit forgotten files ChangeLog at: https://github.com/ldc-developers/ldc/releases/tag/v1.30.0 PR: 266828
-rw-r--r--lang/ldc/Makefile49
-rw-r--r--lang/ldc/distinfo16
-rw-r--r--lang/ldc/pkg-plist109
3 files changed, 112 insertions, 62 deletions
diff --git a/lang/ldc/Makefile b/lang/ldc/Makefile
index 2c8c4aa742a6..b2f030adc948 100644
--- a/lang/ldc/Makefile
+++ b/lang/ldc/Makefile
@@ -1,8 +1,8 @@
PORTNAME= ldc
-PORTVERSION= 1.23.0
-DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTVERSION= 1.30.0
CATEGORIES= lang
+MASTER_SITES= https://github.com/ldc-developers/${PORTNAME}/releases/download/v${DISTVERSION}/
+DISTVERSIONSUFFIX= -src
MAINTAINER= acm@FreeBSD.org
COMMENT= LLVM-based D compiler
@@ -15,23 +15,17 @@ BROKEN_armv7= fails to compile: Error: undefined identifier _jmp_buf, did you me
BROKEN_i386= function core.bitop.bsf (uint v) is not callable using argument types (ulong)
BROKEN_riscv64= fails to compile: unable to get target for 'riscv64-portbld-freebsd13.0', see -version and -mtriple.
-LLVM_VERSION= 10
-BUILD_DEPENDS= llvm70>0:devel/llvm70 \
- llvm${LLVM_VERSION}>0:devel/llvm${LLVM_VERSION}
-RUN_DEPENDS= llvm70>0:devel/llvm70 \
- llvm${LLVM_VERSION}>0:devel/llvm${LLVM_VERSION}
+LLVM_VERSION= 13
+BUILD_DEPENDS= gdmd>0:devel/gdmd \
+ gdc11:lang/gcc11
+RUN_DEPENDS= llvm${LLVM_VERSION}>0:devel/llvm${LLVM_VERSION}
LIB_DEPENDS= libconfig.so:devel/libconfig
-USES= ninja cmake:insource
+USES= ninja cmake:insource pkgconfig
-USE_GITHUB= yes
-GH_ACCOUNT= ldc-developers
-GH_PROJECT= ldc
-GH_TUPLE= ldc-developers:ldc:911589c:tree/ltsmaster \
- ldc-developers:druntime:13b1ccf:druntimelts/ltsmaster/runtime/druntime \
- ldc-developers:phobos:1d758b2:phoboslts/ltsmaster/runtime/phobos \
- ldc-developers:druntime:cc97ccd:druntime/runtime/druntime \
- ldc-developers:phobos:8ae121c:phobos/runtime/phobos
+#USE_GITHUB= yes
+#GH_ACCOUNT= ldc-developers
+#GH_PROJECT= ldc
USE_LDCONFIG= yes
@@ -46,21 +40,12 @@ LDCVER= ${PORTVERSION}
CFLAGS+= -fPIC
.endif
-.if ${OPSYS} == FreeBSD
-EXTRA_PATCHES= ${PATCHDIR}/fbsd12-*
-.endif
-
CMAKE_ARGS+= -DLDC_INSTALL_PREFIX="${PREFIX}" \
- -DD_COMPILER:STRING="${WRKSRC}/ltsmaster/bin/ldmd2" \
- -DCMAKE_C_COMPILER:STRING="${CC}" \
- -DCMAKE_CXX_COMPILER:STRING="${CXX}" \
- -DLLVM_CONFIG:PATH=${LLVM_CONFIG} \
- -DBUILD_SHARED_LIBS:STRING="BOTH"
-
-pre-configure:
- @cd ${WRKSRC}/ltsmaster && \
- ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} -GNinja .
- @cd ${WRKSRC}/ltsmaster && \
- ${SETENV} ${MAKE_ENV} ninja
+ -DD_COMPILER="${PREFIX}/bin/gdmd" \
+ -DCMAKE_C_COMPILER="${CC}" \
+ -DCMAKE_CXX_COMPILER="${CXX}" \
+ -DLLVM_CONFIG=${LLVM_CONFIG} \
+ -DBUILD_SHARED_LIBS="BOTH" \
+ -DBUILD_LTO_LIBS=ON
.include <bsd.port.post.mk>
diff --git a/lang/ldc/distinfo b/lang/ldc/distinfo
index 3ca30bc46b7b..436ccc8b3bd8 100644
--- a/lang/ldc/distinfo
+++ b/lang/ldc/distinfo
@@ -1,13 +1,3 @@
-TIMESTAMP = 1597912509
-SHA256 (ldc-developers-ldc-v1.23.0_GH0.tar.gz) = 09e78bab1281609aec2dc50d73f14acd9e32b45231701bddf075a7f6910f725c
-SIZE (ldc-developers-ldc-v1.23.0_GH0.tar.gz) = 1869981
-SHA256 (ldc-developers-ldc-911589c_GH0.tar.gz) = c10ee47d857358ea97eccd14b49b4152c7b2621c0129eee1e8f98988f1d13f5e
-SIZE (ldc-developers-ldc-911589c_GH0.tar.gz) = 1231073
-SHA256 (ldc-developers-druntime-13b1ccf_GH0.tar.gz) = 0be26cb90b540e972eae3660e1b865f97d5b1cb6c7ffe76e2ec4eae89ed63f4a
-SIZE (ldc-developers-druntime-13b1ccf_GH0.tar.gz) = 953762
-SHA256 (ldc-developers-phobos-1d758b2_GH0.tar.gz) = af70f2d4b09e0062ba986e215677f484c1cec2977a74ca1a73d3534a120992e9
-SIZE (ldc-developers-phobos-1d758b2_GH0.tar.gz) = 1923043
-SHA256 (ldc-developers-druntime-cc97ccd_GH0.tar.gz) = 3ab1e2560c640bb0e77f0a5f91a84c9b464bdc461b8bcf84827b5644e505d64e
-SIZE (ldc-developers-druntime-cc97ccd_GH0.tar.gz) = 1829988
-SHA256 (ldc-developers-phobos-8ae121c_GH0.tar.gz) = 32aaaf8c8f6578840a7c802962eba1cfb0814c94a6bce854c0b6cd82cb466f43
-SIZE (ldc-developers-phobos-8ae121c_GH0.tar.gz) = 2415254
+TIMESTAMP = 1667402925
+SHA256 (ldc-1.30.0-src.tar.gz) = fdbb376f08242d917922a6a22a773980217fafa310046fc5d6459490af23dacd
+SIZE (ldc-1.30.0-src.tar.gz) = 8292548
diff --git a/lang/ldc/pkg-plist b/lang/ldc/pkg-plist
index 654f4dbfe5e6..96539fb0b339 100644
--- a/lang/ldc/pkg-plist
+++ b/lang/ldc/pkg-plist
@@ -4,9 +4,11 @@ bin/ldc-prune-cache
bin/ldc2
bin/ldmd2
etc/ldc2.conf
+include/d/__builtins.di
include/d/core/atomic.d
include/d/core/attribute.d
include/d/core/bitop.d
+include/d/core/builtins.d
include/d/core/checkedint.d
include/d/core/cpuid.d
include/d/core/demangle.d
@@ -14,6 +16,7 @@ include/d/core/exception.d
include/d/core/gc/config.d
include/d/core/gc/gcinterface.d
include/d/core/gc/registry.d
+include/d/core/int128.d
include/d/core/internal/abort.d
include/d/core/internal/array/appending.d
include/d/core/internal/array/capacity.d
@@ -26,6 +29,16 @@ include/d/core/internal/array/operations.d
include/d/core/internal/array/utils.d
include/d/core/internal/atomic.d
include/d/core/internal/attributes.d
+include/d/core/internal/backtrace/dwarf.d
+include/d/core/internal/backtrace/elf.d
+include/d/core/internal/backtrace/handler.d
+include/d/core/internal/backtrace/libunwind.d
+include/d/core/internal/backtrace/macho.d
+include/d/core/internal/backtrace/unwind.d
+include/d/core/internal/container/array.d
+include/d/core/internal/container/common.d
+include/d/core/internal/container/hashtab.d
+include/d/core/internal/container/treap.d
include/d/core/internal/convert.d
include/d/core/internal/dassert.d
include/d/core/internal/destruction.d
@@ -33,17 +46,26 @@ include/d/core/internal/elf/dl.d
include/d/core/internal/elf/io.d
include/d/core/internal/entrypoint.d
include/d/core/internal/execinfo.d
+include/d/core/internal/gc/bits.d
+include/d/core/internal/gc/impl/conservative/gc.d
+include/d/core/internal/gc/impl/manual/gc.d
+include/d/core/internal/gc/impl/proto/gc.d
+include/d/core/internal/gc/os.d
+include/d/core/internal/gc/pooltable.d
+include/d/core/internal/gc/proxy.d
include/d/core/internal/hash.d
include/d/core/internal/lifetime.d
include/d/core/internal/moving.d
include/d/core/internal/parseoptions.d
include/d/core/internal/postblit.d
+include/d/core/internal/qsort.d
include/d/core/internal/spinlock.d
include/d/core/internal/string.d
include/d/core/internal/switch_.d
include/d/core/internal/traits.d
include/d/core/internal/utf.d
include/d/core/internal/util/array.d
+include/d/core/internal/util/math.d
include/d/core/internal/vararg/aarch64.d
include/d/core/internal/vararg/sysv_x64.d
include/d/core/lifetime.d
@@ -82,6 +104,7 @@ include/d/core/stdcpp/string.d
include/d/core/stdcpp/string_view.d
include/d/core/stdcpp/type_traits.d
include/d/core/stdcpp/typeinfo.d
+include/d/core/stdcpp/utility.d
include/d/core/stdcpp/vector.d
include/d/core/stdcpp/xutility.d
include/d/core/sync/barrier.d
@@ -94,30 +117,39 @@ include/d/core/sync/rwmutex.d
include/d/core/sync/semaphore.d
include/d/core/sys/bionic/err.d
include/d/core/sys/bionic/fcntl.d
+include/d/core/sys/bionic/stdlib.d
include/d/core/sys/bionic/string.d
include/d/core/sys/bionic/unistd.d
include/d/core/sys/darwin/crt_externs.d
include/d/core/sys/darwin/dlfcn.d
include/d/core/sys/darwin/err.d
include/d/core/sys/darwin/execinfo.d
+include/d/core/sys/darwin/fcntl.d
+include/d/core/sys/darwin/ifaddrs.d
include/d/core/sys/darwin/mach/dyld.d
include/d/core/sys/darwin/mach/getsect.d
include/d/core/sys/darwin/mach/kern_return.d
include/d/core/sys/darwin/mach/loader.d
+include/d/core/sys/darwin/mach/nlist.d
include/d/core/sys/darwin/mach/port.d
include/d/core/sys/darwin/mach/semaphore.d
+include/d/core/sys/darwin/mach/stab.d
include/d/core/sys/darwin/mach/thread_act.d
include/d/core/sys/darwin/netinet/in_.d
include/d/core/sys/darwin/pthread.d
+include/d/core/sys/darwin/stdlib.d
include/d/core/sys/darwin/string.d
+include/d/core/sys/darwin/sys/attr.d
include/d/core/sys/darwin/sys/cdefs.d
include/d/core/sys/darwin/sys/event.d
include/d/core/sys/darwin/sys/mman.d
+include/d/core/sys/darwin/sys/sysctl.d
include/d/core/sys/dragonflybsd/dlfcn.d
include/d/core/sys/dragonflybsd/err.d
include/d/core/sys/dragonflybsd/execinfo.d
include/d/core/sys/dragonflybsd/netinet/in_.d
include/d/core/sys/dragonflybsd/pthread_np.d
+include/d/core/sys/dragonflybsd/stdlib.d
include/d/core/sys/dragonflybsd/string.d
include/d/core/sys/dragonflybsd/sys/_bitset.d
include/d/core/sys/dragonflybsd/sys/_cpuset.d
@@ -130,12 +162,15 @@ include/d/core/sys/dragonflybsd/sys/event.d
include/d/core/sys/dragonflybsd/sys/link_elf.d
include/d/core/sys/dragonflybsd/sys/mman.d
include/d/core/sys/dragonflybsd/sys/socket.d
+include/d/core/sys/dragonflybsd/sys/sysctl.d
include/d/core/sys/dragonflybsd/time.d
+include/d/core/sys/freebsd/config.d
include/d/core/sys/freebsd/dlfcn.d
include/d/core/sys/freebsd/err.d
include/d/core/sys/freebsd/execinfo.d
include/d/core/sys/freebsd/netinet/in_.d
include/d/core/sys/freebsd/pthread_np.d
+include/d/core/sys/freebsd/stdlib.d
include/d/core/sys/freebsd/string.d
include/d/core/sys/freebsd/sys/_bitset.d
include/d/core/sys/freebsd/sys/_cpuset.d
@@ -148,6 +183,7 @@ include/d/core/sys/freebsd/sys/event.d
include/d/core/sys/freebsd/sys/link_elf.d
include/d/core/sys/freebsd/sys/mman.d
include/d/core/sys/freebsd/sys/mount.d
+include/d/core/sys/freebsd/sys/sysctl.d
include/d/core/sys/freebsd/time.d
include/d/core/sys/freebsd/unistd.d
include/d/core/sys/linux/config.d
@@ -158,10 +194,13 @@ include/d/core/sys/linux/err.d
include/d/core/sys/linux/errno.d
include/d/core/sys/linux/execinfo.d
include/d/core/sys/linux/fcntl.d
+include/d/core/sys/linux/fs.d
include/d/core/sys/linux/ifaddrs.d
+include/d/core/sys/linux/io_uring.d
include/d/core/sys/linux/link.d
include/d/core/sys/linux/netinet/in_.d
include/d/core/sys/linux/netinet/tcp.d
+include/d/core/sys/linux/perf_event.d
include/d/core/sys/linux/sched.d
include/d/core/sys/linux/stdio.d
include/d/core/sys/linux/string.d
@@ -171,6 +210,7 @@ include/d/core/sys/linux/sys/file.d
include/d/core/sys/linux/sys/inotify.d
include/d/core/sys/linux/sys/mman.d
include/d/core/sys/linux/sys/prctl.d
+include/d/core/sys/linux/sys/procfs.d
include/d/core/sys/linux/sys/signalfd.d
include/d/core/sys/linux/sys/socket.d
include/d/core/sys/linux/sys/sysinfo.d
@@ -184,6 +224,7 @@ include/d/core/sys/linux/unistd.d
include/d/core/sys/netbsd/dlfcn.d
include/d/core/sys/netbsd/err.d
include/d/core/sys/netbsd/execinfo.d
+include/d/core/sys/netbsd/stdlib.d
include/d/core/sys/netbsd/string.d
include/d/core/sys/netbsd/sys/elf.d
include/d/core/sys/netbsd/sys/elf32.d
@@ -193,9 +234,14 @@ include/d/core/sys/netbsd/sys/event.d
include/d/core/sys/netbsd/sys/featuretest.d
include/d/core/sys/netbsd/sys/link_elf.d
include/d/core/sys/netbsd/sys/mman.d
+include/d/core/sys/netbsd/sys/sysctl.d
include/d/core/sys/netbsd/time.d
include/d/core/sys/openbsd/dlfcn.d
include/d/core/sys/openbsd/err.d
+include/d/core/sys/openbsd/execinfo.d
+include/d/core/sys/openbsd/pthread_np.d
+include/d/core/sys/openbsd/pwd.d
+include/d/core/sys/openbsd/stdlib.d
include/d/core/sys/openbsd/string.d
include/d/core/sys/openbsd/sys/cdefs.d
include/d/core/sys/openbsd/sys/elf.d
@@ -204,7 +250,9 @@ include/d/core/sys/openbsd/sys/elf64.d
include/d/core/sys/openbsd/sys/elf_common.d
include/d/core/sys/openbsd/sys/link_elf.d
include/d/core/sys/openbsd/sys/mman.d
+include/d/core/sys/openbsd/sys/sysctl.d
include/d/core/sys/openbsd/time.d
+include/d/core/sys/openbsd/unistd.d
include/d/core/sys/posix/aio.d
include/d/core/sys/posix/arpa/inet.d
include/d/core/sys/posix/config.d
@@ -229,6 +277,7 @@ include/d/core/sys/posix/semaphore.d
include/d/core/sys/posix/setjmp.d
include/d/core/sys/posix/signal.d
include/d/core/sys/posix/spawn.d
+include/d/core/sys/posix/stdc/time.d
include/d/core/sys/posix/stdio.d
include/d/core/sys/posix/stdlib.d
include/d/core/sys/posix/string.d
@@ -264,6 +313,7 @@ include/d/core/sys/solaris/err.d
include/d/core/sys/solaris/execinfo.d
include/d/core/sys/solaris/libelf.d
include/d/core/sys/solaris/link.d
+include/d/core/sys/solaris/stdlib.d
include/d/core/sys/solaris/sys/elf.d
include/d/core/sys/solaris/sys/elf_386.d
include/d/core/sys/solaris/sys/elf_SPARC.d
@@ -409,6 +459,8 @@ include/d/core/sys/windows/sqlucode.d
include/d/core/sys/windows/sspi.d
include/d/core/sys/windows/stacktrace.d
include/d/core/sys/windows/stat.d
+include/d/core/sys/windows/stdc/malloc.d
+include/d/core/sys/windows/stdc/time.d
include/d/core/sys/windows/subauth.d
include/d/core/sys/windows/threadaux.d
include/d/core/sys/windows/tlhelp32.d
@@ -441,9 +493,13 @@ include/d/core/sys/windows/winuser.d
include/d/core/sys/windows/winver.d
include/d/core/sys/windows/wtsapi32.d
include/d/core/sys/windows/wtypes.d
+include/d/core/thread/context.d
include/d/core/thread/fiber.d
include/d/core/thread/osthread.d
include/d/core/thread/package.d
+include/d/core/thread/threadbase.d
+include/d/core/thread/threadgroup.d
+include/d/core/thread/types.d
include/d/core/time.d
include/d/core/vararg.d
include/d/core/volatile.d
@@ -455,10 +511,10 @@ include/d/etc/c/odbc/sqlucode.d
include/d/etc/c/sqlite3.d
include/d/etc/c/zlib.d
include/d/etc/linux/memoryerror.d
+include/d/importc.h
include/d/ldc/asan.d
include/d/ldc/attributes.d
include/d/ldc/dcompute.d
-include/d/ldc/dynamic_compile.d
include/d/ldc/eh_msvc.d
include/d/ldc/gccbuiltins_aarch64.di
include/d/ldc/gccbuiltins_amdgcn.di
@@ -471,6 +527,7 @@ include/d/ldc/gccbuiltins_x86.di
include/d/ldc/intrinsics.di
include/d/ldc/libfuzzer.di
include/d/ldc/llvmasm.di
+include/d/ldc/opencl.di
include/d/ldc/profile.di
include/d/ldc/sanitizer_common.d
include/d/ldc/sanitizers_optionally_linked.d
@@ -489,6 +546,7 @@ include/d/std/ascii.d
include/d/std/base64.d
include/d/std/bigint.d
include/d/std/bitmanip.d
+include/d/std/checkedint.d
include/d/std/compiler.d
include/d/std/complex.d
include/d/std/concurrency.d
@@ -550,9 +608,16 @@ include/d/std/experimental/logger/nulllogger.d
include/d/std/experimental/logger/package.d
include/d/std/experimental/typecons.d
include/d/std/file.d
-include/d/std/format.d
+include/d/std/format/internal/floats.d
+include/d/std/format/internal/read.d
+include/d/std/format/internal/write.d
+include/d/std/format/package.d
+include/d/std/format/read.d
+include/d/std/format/spec.d
+include/d/std/format/write.d
include/d/std/functional.d
include/d/std/getopt.d
+include/d/std/int128.d
include/d/std/internal/attributes.d
include/d/std/internal/cstring.d
include/d/std/internal/digest/sha_SSSE3.d
@@ -574,7 +639,16 @@ include/d/std/internal/unicode_norm.d
include/d/std/internal/unicode_tables.d
include/d/std/internal/windows/advapi32.d
include/d/std/json.d
-include/d/std/math.d
+include/d/std/math/algebraic.d
+include/d/std/math/constants.d
+include/d/std/math/exponential.d
+include/d/std/math/hardware.d
+include/d/std/math/operations.d
+include/d/std/math/package.d
+include/d/std/math/remainder.d
+include/d/std/math/rounding.d
+include/d/std/math/traits.d
+include/d/std/math/trigonometry.d
include/d/std/mathspecial.d
include/d/std/meta.d
include/d/std/mmfile.d
@@ -604,11 +678,12 @@ include/d/std/socket.d
include/d/std/stdint.d
include/d/std/stdio.d
include/d/std/string.d
+include/d/std/sumtype.d
include/d/std/system.d
include/d/std/traits.d
include/d/std/typecons.d
include/d/std/typetuple.d
-include/d/std/uni.d
+include/d/std/uni/package.d
include/d/std/uri.d
include/d/std/utf.d
include/d/std/uuid.d
@@ -619,24 +694,24 @@ include/d/std/windows/syserror.d
include/d/std/xml.d
include/d/std/zip.d
include/d/std/zlib.d
+lib/ldc_rt.dso.o
lib/libdruntime-ldc-debug-shared.so
-lib/libdruntime-ldc-debug-shared.so.2.0.93
-lib/libdruntime-ldc-debug-shared.so.93
+lib/libdruntime-ldc-debug-shared.so.100
+lib/libdruntime-ldc-debug-shared.so.100.1
lib/libdruntime-ldc-debug.a
+lib/libdruntime-ldc-lto.a
lib/libdruntime-ldc-shared.so
-lib/libdruntime-ldc-shared.so.2.0.93
-lib/libdruntime-ldc-shared.so.93
+lib/libdruntime-ldc-shared.so.100
+lib/libdruntime-ldc-shared.so.100.1
lib/libdruntime-ldc.a
-lib/libldc-jit-rt.a
-lib/libldc-jit.so
-lib/libldc-jit.so.2.0.93
-lib/libldc-jit.so.93
lib/libphobos2-ldc-debug-shared.so
-lib/libphobos2-ldc-debug-shared.so.2.0.93
-lib/libphobos2-ldc-debug-shared.so.93
+lib/libphobos2-ldc-debug-shared.so.100
+lib/libphobos2-ldc-debug-shared.so.100.1
lib/libphobos2-ldc-debug.a
+lib/libphobos2-ldc-lto.a
lib/libphobos2-ldc-shared.so
-lib/libphobos2-ldc-shared.so.2.0.93
-lib/libphobos2-ldc-shared.so.93
+lib/libphobos2-ldc-shared.so.100
+lib/libphobos2-ldc-shared.so.100.1
lib/libphobos2-ldc.a
-@dir include/d/etc/c/zlib
+@dir include/d/etc/c/zlib/doc
+@dir include/d/etc/c/zlib/test