aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-03-16 09:05:43 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-04-10 20:33:36 +0000
commitf406592a8e37f2c889ea0a2966cdd9cc751f7c8c (patch)
tree7147dcee551560dbefdba350daf2476f8c916371
parentf5d0c53d72296109a0861c4eb9365bc877b80e54 (diff)
downloadports-f406592a8e37f2c889ea0a2966cdd9cc751f7c8c.tar.gz
ports-f406592a8e37f2c889ea0a2966cdd9cc751f7c8c.zip
x11-toolkits/wlroots: expose x11/nvidia-driver support
Allow debugging EGLStreams itself on FreeBSD. Like CONSOLEKIT this relies on a rejected patch, so may break on updates or be eventually removed. See also NVIDIA option in x11-servers/xwayland-devel
-rw-r--r--x11-toolkits/wlroots/Makefile9
-rw-r--r--x11-toolkits/wlroots/distinfo2
-rw-r--r--x11-toolkits/wlroots/pkg-message1
3 files changed, 11 insertions, 1 deletions
diff --git a/x11-toolkits/wlroots/Makefile b/x11-toolkits/wlroots/Makefile
index 4beb26390650..d26363f1814c 100644
--- a/x11-toolkits/wlroots/Makefile
+++ b/x11-toolkits/wlroots/Makefile
@@ -31,7 +31,7 @@ USE_LDCONFIG= yes
GH_ACCOUNT= swaywm
MESON_ARGS= -Dexamples=false
-OPTIONS_DEFINE= CONSOLEKIT LIBSEAT UUID X11
+OPTIONS_DEFINE= CONSOLEKIT LIBSEAT NVIDIA UUID X11
OPTIONS_DEFAULT=LIBSEAT UUID X11
OPTIONS_SUB= yes
@@ -49,6 +49,13 @@ LIBSEAT_DESC= DRM sessions with/without root via libseat
LIBSEAT_LIB_DEPENDS= libseat.so:sysutils/seatd
LIBSEAT_MESON_ENABLED= libseat
+NVIDIA_DESC= EGLStreams support for DRM backend (experimental)
+NVIDIA_PATCH_SITES= https://github.com/danvd/${GH_PROJECT}-eglstreams/commit/:nvidia
+NVIDIA_PATCHFILES= eba4b66f92ca.patch:-p1:nvidia # https://github.com/swaywm/wlroots/pull/2769
+.if make(makesum)
+.MAKEFLAGS: WITH+=NVIDIA
+.endif
+
# uuid_create() is random on NetBSD and OpenBSD but not DragonFly and FreeBSD
# See also https://github.com/netbsd/src/commit/8651e9a438af
UUID_DESC= Exported surfaces to use random UUIDs via libuuid
diff --git a/x11-toolkits/wlroots/distinfo b/x11-toolkits/wlroots/distinfo
index cbe229bd594e..d797fa4fa287 100644
--- a/x11-toolkits/wlroots/distinfo
+++ b/x11-toolkits/wlroots/distinfo
@@ -7,3 +7,5 @@ SHA256 (e1b5323f56c3.patch) = 13145323caf9e56412ee3766fb9eacca9c6e4ca7088a320e79
SIZE (e1b5323f56c3.patch) = 4028
SHA256 (fb837ae10b1f.patch) = ecf07d813ae796eca946e909a35434a93b07fc349d6ca8b48d7834cb2dfb4071
SIZE (fb837ae10b1f.patch) = 27075
+SHA256 (eba4b66f92ca.patch) = a271c30c414fb2ae2cb6e0cbca77c37c1e15a3b160097f6e78298bfcec8df352
+SIZE (eba4b66f92ca.patch) = 96009
diff --git a/x11-toolkits/wlroots/pkg-message b/x11-toolkits/wlroots/pkg-message
index 63f713926391..ba814bf0ca4d 100644
--- a/x11-toolkits/wlroots/pkg-message
+++ b/x11-toolkits/wlroots/pkg-message
@@ -4,6 +4,7 @@
Known issues:
- On FreeBSD 11.* kernel needs to be rebuilt with EVDEV_SUPPORT
- On FreeBSD 11.* drm-kmod needs https://github.com/FreeBSDDesktop/kms-drm/pull/213
+- NVIDIA may be affected by https://github.com/aritger/eglstreams-kms-example/issues/7
When built with LIBSEAT enabled you may see the following: