aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-23 14:22:35 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-23 14:49:32 +0000
commitf46b24f811fb7a635662c202deee6bdc0df28373 (patch)
treedd1b2056c57ca27ace880f35b67cabd7304d1313
parent4753ecc942a9dc8a2ced2c34cdea6e6e86457e59 (diff)
downloadports-f46b24f811fb7a635662c202deee6bdc0df28373.tar.gz
ports-f46b24f811fb7a635662c202deee6bdc0df28373.zip
security/py-pyhanko: Update to 0.23.1
-rw-r--r--security/py-pyhanko/Makefile9
-rw-r--r--security/py-pyhanko/distinfo6
-rw-r--r--security/py-pyhanko/files/patch-pyproject.toml9
3 files changed, 12 insertions, 12 deletions
diff --git a/security/py-pyhanko/Makefile b/security/py-pyhanko/Makefile
index 4e1a1bfd1597..6630e4fcf84f 100644
--- a/security/py-pyhanko/Makefile
+++ b/security/py-pyhanko/Makefile
@@ -1,7 +1,8 @@
PORTNAME= pyhanko
-PORTVERSION= 0.21.0
+PORTVERSION= 0.23.1
CATEGORIES= security python
-MASTER_SITES= PYPI
+MASTER_SITES= PYPI \
+ https://github.com/MatthiasValvekens/pyHanko/releases/download/v${PORTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= pyHanko-${PORTVERSION}
@@ -37,11 +38,11 @@ PKGCS11_DESC= PKGCS\#11 support
XMP_DESC= XMP (Extensible Metadata Platform) support
ASYNC_HTTP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=3.9.0<3.10:www/py-aiohttp@${PY_FLAVOR}
-ETSI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xsdata>=23.8<4:devel/py-xsdata@${PY_FLAVOR}
+ETSI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xsdata>=23.8<25.0:devel/py-xsdata@${PY_FLAVOR}
IMAGE_SUPPORT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=7.2.0:graphics/py-pillow@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}python-barcode>=0.15.1<0.15.1_99:graphics/py-python-barcode@${PY_FLAVOR}
OPENTYPE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fonttools>=4.33.3:print/py-fonttools@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}uharfbuzz>=0.25.0<0.38.0:print/py-uharfbuzz@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}uharfbuzz>=0.25.0<0.40.0:print/py-uharfbuzz@${PY_FLAVOR}
PKGCS11_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-pkcs11>=0.7.0<0.8:security/py-python-pkcs11@${PY_FLAVOR}
XMP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}defusedxml>=0.7.1<0.8:devel/py-defusedxml@${PY_FLAVOR}
diff --git a/security/py-pyhanko/distinfo b/security/py-pyhanko/distinfo
index be4ea86e48a5..31917057bbd0 100644
--- a/security/py-pyhanko/distinfo
+++ b/security/py-pyhanko/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1701083404
-SHA256 (pyHanko-0.21.0.tar.gz) = e5609fb8a0b8d60168999cffaa382f0361066cb429204ad2b76e84e6e7f5eb93
-SIZE (pyHanko-0.21.0.tar.gz) = 376386
+TIMESTAMP = 1710712534
+SHA256 (pyHanko-0.23.1.tar.gz) = 253fce52004e0856f4aa39e29a295c6957f2a8d2c4d5701356ea64da29c82aee
+SIZE (pyHanko-0.23.1.tar.gz) = 375541
diff --git a/security/py-pyhanko/files/patch-pyproject.toml b/security/py-pyhanko/files/patch-pyproject.toml
index a4ba7610b2ca..ae9322c3aa0f 100644
--- a/security/py-pyhanko/files/patch-pyproject.toml
+++ b/security/py-pyhanko/files/patch-pyproject.toml
@@ -1,12 +1,11 @@
---- pyproject.toml.orig 2023-11-25 23:58:39 UTC
+--- pyproject.toml.orig 2024-03-07 22:13:09 UTC
+++ pyproject.toml
-@@ -1,12 +1,12 @@
+@@ -1,12 +1,12 @@ requires = [
[build-system]
requires = [
- "setuptools>=67.4",
-- "wheel", "pytest-runner",
+ "setuptools>=61",
-+ "wheel",
+ "wheel"
]
build-backend = "setuptools.build_meta"
@@ -16,7 +15,7 @@
description = "Tools for stamping and signing PDF files"
authors = [{name = "Matthias Valvekens", email = "dev@mvalvekens.be"}]
maintainers = [{name = "Matthias Valvekens", email = "dev@mvalvekens.be"}]
-@@ -36,7 +36,7 @@ requires-python = ">=3.8"
+@@ -36,7 +36,7 @@ dependencies = [
dependencies = [
"asn1crypto>=1.5.1",
"qrcode>=7.3.1",