aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-03-25 03:55:47 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-03-25 03:55:47 +0000
commitf5b7a121320ece42e5ce7a90f713e0f2105f796b (patch)
tree6302d1737d1c31f7723605de2e205b4c8bdbf865
parent91d6e479cf90fe766b8c890f93a244facd58a8da (diff)
downloadports-f5b7a121320ece42e5ce7a90f713e0f2105f796b.tar.gz
ports-f5b7a121320ece42e5ce7a90f713e0f2105f796b.zip
- Add LICENSE
- Add MAKE_JOBS_SAFE - Add OPTIONS for disabling Qt-based GUI support PR: 166020 Submitted by: Ports Fury Feature safe: yes
Notes
Notes: svn path=/head/; revision=293788
-rw-r--r--deskutils/recoll/Makefile67
-rw-r--r--deskutils/recoll/pkg-descr33
-rw-r--r--deskutils/recoll/pkg-plist28
3 files changed, 85 insertions, 43 deletions
diff --git a/deskutils/recoll/Makefile b/deskutils/recoll/Makefile
index 2b5a05842025..4cbc4eb71e4a 100644
--- a/deskutils/recoll/Makefile
+++ b/deskutils/recoll/Makefile
@@ -11,23 +11,70 @@ CATEGORIES= deskutils
MASTER_SITES= http://www.lesbonscomptes.com/recoll/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A personal full text search package, based on QT and Xapian
+COMMENT= A personal full text search package, based on Xapian
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= xapian.26:${PORTSDIR}/databases/xapian-core
-USE_QT_VER= 4
-QT_COMPONENTS= gui qmake_build uic_build moc_build rcc_build \
- qt3support uic3_build porting
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
+OPTIONS= QT "Enable Qt-based GUI support" on \
+ ASPELL "Enable ASpell support" on \
+ X11MON "Enable X11 session monitoring support" on
+
USE_ICONV= yes
-INSTALLS_ICONS= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
-MAN1= recoll.1 recollindex.1
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+MAN1= recollindex.1
MAN5= recoll.conf.5
+.include <bsd.port.options.mk>
+
+.if defined(WITHOUT_QT)
+CONFIGURE_ARGS+=--disable-qtgui
+PLIST_SUB+= QT="@comment "
+.else
+USE_QT_VER= 4
+QT_COMPONENTS= gui moc_build qmake_build rcc_build uic_build
+QT_NONSTANDARD= yes
+CONFIGURE_ENV+= QTDIR="${QT_PREFIX}" QMAKE="${QMAKE}"
+INSTALLS_ICONS= yes
+PLIST_SUB+= QT=""
+MAN1+= recoll.1
+.endif
+
+.if defined(WITHOUT_ASPELL)
+CONFIGURE_ARGS+=--without-aspell
+.else
+LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
+.endif
+
+.if defined(WITHOUT_X11MON)
+CONFIGURE_ARGS+=--disable-x11mon
+.else
+USE_XORG+= ice sm x11
+USE_FAM= yes
+CONFIGURE_ARGS+=--with-fam
+.endif
+
post-patch:
- ${REINPLACE_CMD} -e 's/^CXXFLAGS =/CXXFLAGS ?=/' \
- ${WRKSRC}/mk/localdefs.in
+ @${REINPLACE_CMD} -e \
+ '/recoll.pro/s|^|#|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|/usr/local/lib|${LOCALBASE}/lib|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|= -g -O2|=|' ${WRKSRC}/mk/localdefs.in
+ @${REINPLACE_CMD} -e \
+ 's|-pthread|${PTHREAD_LIBS}|' ${WRKSRC}/mk/${OPSYS}
+
+post-configure:
+.if !defined(WITHOUT_QT)
+ @(cd ${WRKSRC}/qtgui && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS})
+.endif
.include <bsd.port.mk>
diff --git a/deskutils/recoll/pkg-descr b/deskutils/recoll/pkg-descr
index 1aa20b03f798..ecc4f749ede5 100644
--- a/deskutils/recoll/pkg-descr
+++ b/deskutils/recoll/pkg-descr
@@ -1,24 +1,19 @@
-Recoll is a personal full text search package with a QT graphical
-interface. It is based on a very strong backend (Xapian), for which it
-provides an easy to use and feature-rich interface.
+Recoll is a personal full text search package. It is based on a very
+strong backend (Xapian), for which it provides an easy to use and
+feature-rich interface.
Features:
* Free, GPL license.
- * QT-based GUI.
- * Supports the following document types (and their compressed versions):
- - Natively: text, html, OpenOffice files, maildir and mailbox
- (Mozilla and Thunderbird mail ok) with attachments, gaim log files.
- - With external helpers: pdf (pdftotext), postscript (ghostscript),
- msword (antiword), excel, ppt (catdoc), rtf (unrtf),
- * Powerful query facilities, with boolean searches, phrases, filter on
- file types and directory tree.
- * Support for multiple charsets. Internal processing and storage uses
- Unicode UTF-8.
- * Stemming performed at query time (can switch stemming language after
- indexing)
- * Easy installation. No database daemon, web server or exotic language
- necessary.
- * An indexer which runs either as a thread inside the GUI or as an
- external, cron'able program.
+ * Easy installation, few dependancies. No database daemon, web server,
+ desktop environment or exotic language necessary.
+ * Will run on most Unix-based systems
+ * Qt 4 GUI, plus command line.
+ * Searches most common document types, emails and their attachments.
+ Transparently handles decompression (gzip, bzip2).
+ * Powerful query facilities, with boolean searches, phrases, proximity,
+ wildcards, filter on file types and directory tree.
+ * Multi-language and multi-character set with Unicode based internals.
+ * Extensive documentation, with a complete user manual and manual pages
+ for each command.
WWW: http://www.lesbonscomptes.com/recoll/
diff --git a/deskutils/recoll/pkg-plist b/deskutils/recoll/pkg-plist
index a108e04d55fe..2cddbbb41806 100644
--- a/deskutils/recoll/pkg-plist
+++ b/deskutils/recoll/pkg-plist
@@ -1,8 +1,8 @@
-bin/recoll
+%%QT%%bin/recoll
bin/recollindex
-share/applications/recoll-searchgui.desktop
-share/icons/hicolor/48x48/apps/recoll.png
-share/pixmaps/recoll.png
+%%QT%%share/applications/recoll-searchgui.desktop
+%%QT%%share/icons/hicolor/48x48/apps/recoll.png
+%%QT%%share/pixmaps/recoll.png
%%DATADIR%%/doc/docbook.css
%%DATADIR%%/doc/usermanual.html
%%DATADIR%%/examples/fields
@@ -37,10 +37,10 @@ share/pixmaps/recoll.png
%%DATADIR%%/filters/rclogg
%%DATADIR%%/filters/rclopxml
%%DATADIR%%/filters/rclpdf
-%%DATADIR%%/filters/rclpurple
-%%DATADIR%%/filters/rclpython
%%DATADIR%%/filters/rclppt
%%DATADIR%%/filters/rclps
+%%DATADIR%%/filters/rclpurple
+%%DATADIR%%/filters/rclpython
%%DATADIR%%/filters/rclrar
%%DATADIR%%/filters/rclrtf
%%DATADIR%%/filters/rclscribus
@@ -70,30 +70,30 @@ share/pixmaps/recoll.png
%%DATADIR%%/images/postscript.png
%%DATADIR%%/images/presentation.png
%%DATADIR%%/images/sidux-book.png
+%%DATADIR%%/images/soffice.png
%%DATADIR%%/images/source.png
%%DATADIR%%/images/sownd.png
-%%DATADIR%%/images/soffice.png
%%DATADIR%%/images/spreadsheet.png
%%DATADIR%%/images/text-x-python.png
%%DATADIR%%/images/txt.png
%%DATADIR%%/images/wordprocessing.png
%%DATADIR%%/translations/recoll_cs.qm
+%%DATADIR%%/translations/recoll_de.qm
%%DATADIR%%/translations/recoll_fr.qm
%%DATADIR%%/translations/recoll_it.qm
%%DATADIR%%/translations/recoll_lt.qm
-%%DATADIR%%/translations/recoll_de.qm
-%%DATADIR%%/translations/recoll_uk.qm
%%DATADIR%%/translations/recoll_ru.qm
%%DATADIR%%/translations/recoll_tr.qm
+%%DATADIR%%/translations/recoll_uk.qm
%%DATADIR%%/translations/recoll_xx.qm
-@dirrm %%DATADIR%%/doc
-@dirrm %%DATADIR%%/examples
-@dirrm %%DATADIR%%/filters
-@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%/translations
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/filters
+@dirrm %%DATADIR%%/examples
+@dirrm %%DATADIR%%/doc
@dirrm %%DATADIR%%
-@dirrmtry share/applications
@dirrmtry share/icons/hicolor/48x48/apps
@dirrmtry share/icons/hicolor/48x48
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
+@dirrmtry share/applications