aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-02-13 06:07:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-02-13 06:39:14 +0000
commitf6a4845f37eb2c01c2749dd5f9780a7f4db00d43 (patch)
tree6889449372901630d579c52bda3f2a0ce0415075
parent88edcb709cd181f59676b867a4187e9de335cf9f (diff)
downloadports-f6a4845f37eb2c01c2749dd5f9780a7f4db00d43.tar.gz
ports-f6a4845f37eb2c01c2749dd5f9780a7f4db00d43.zip
finance/py-pycoingecko: New port: Python wrapper around the CoinGecko API
-rw-r--r--finance/Makefile1
-rw-r--r--finance/py-pycoingecko/Makefile25
-rw-r--r--finance/py-pycoingecko/distinfo3
-rw-r--r--finance/py-pycoingecko/pkg-descr4
4 files changed, 33 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index b4fae6b8e223..d464035247c4 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -120,6 +120,7 @@
SUBDIR += py-pandas-market-calendars
SUBDIR += py-pandas-ta
SUBDIR += py-pycoin
+ SUBDIR += py-pycoingecko
SUBDIR += py-python-bitcoinlib
SUBDIR += py-python-obelisk
SUBDIR += py-quantecon
diff --git a/finance/py-pycoingecko/Makefile b/finance/py-pycoingecko/Makefile
new file mode 100644
index 000000000000..639f2f5e003b
--- /dev/null
+++ b/finance/py-pycoingecko/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= pycoingecko
+DISTVERSION= 3.1.0
+CATEGORIES= finance python
+#MASTER_SITES= PYPI # no tests
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python wrapper around the CoinGecko API
+WWW= https://github.com/man-c/pycoingecko
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}responses>0:devel/py-responses@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist pytest
+
+USE_GITHUB= yes
+GH_ACCOUNT= man-c
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/finance/py-pycoingecko/distinfo b/finance/py-pycoingecko/distinfo
new file mode 100644
index 000000000000..69ad45d7da03
--- /dev/null
+++ b/finance/py-pycoingecko/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1676267813
+SHA256 (man-c-pycoingecko-3.1.0_GH0.tar.gz) = 577866265a06a8791a7f30163992c81a9b4baa1bd0e1510520bc9da142115e12
+SIZE (man-c-pycoingecko-3.1.0_GH0.tar.gz) = 13783
diff --git a/finance/py-pycoingecko/pkg-descr b/finance/py-pycoingecko/pkg-descr
new file mode 100644
index 000000000000..511715400773
--- /dev/null
+++ b/finance/py-pycoingecko/pkg-descr
@@ -0,0 +1,4 @@
+pycoingecko is Pi ython wrapper for the CoinGecko API.
+
+CoinGecko provides information about cryptocurrency prices, excghange rates,
+market caps, etc.