aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Limberger <flo@purplekraken.com>2022-08-01 17:32:11 +0000
committerGleb Popov <arrowd@FreeBSD.org>2022-08-01 17:36:14 +0000
commitf71e44bc779b8f557ae07132574af72b9d064bc2 (patch)
treef1e641d5a94b1c536c06d792431a7dc203f58688
parente88737dc736b43e86d088fd739b49440996032e3 (diff)
comms/cyclonedds: + Eclipse Cyclone DDS middleware
Test Plan: * portlint: OK * portclippy: OK * testport: amd64, 13.1-RELEASE tested Reviewed by: arrowd Differential Revision: https://reviews.freebsd.org/D35997
-rw-r--r--comms/Makefile1
-rw-r--r--comms/cyclonedds/Makefile34
-rw-r--r--comms/cyclonedds/distinfo3
-rw-r--r--comms/cyclonedds/pkg-descr7
-rw-r--r--comms/cyclonedds/pkg-plist225
5 files changed, 270 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 6382411cc1b9..841716e29433 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -25,6 +25,7 @@
SUBDIR += cutecom
SUBDIR += cwdaemon
SUBDIR += cwstudio
+ SUBDIR += cyclonedds
SUBDIR += dcf77pi
SUBDIR += deforaos-phone
SUBDIR += dfu-programmer
diff --git a/comms/cyclonedds/Makefile b/comms/cyclonedds/Makefile
new file mode 100644
index 000000000000..d23cc4b0a63a
--- /dev/null
+++ b/comms/cyclonedds/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= CycloneDDS
+DISTVERSION= 0.9.1
+CATEGORIES= comms
+
+MAINTAINER= flo@purplekraken.com
+COMMENT= Eclipse Cyclone DDS middleware
+
+LICENSE= EPL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libiceoryx_posh.so:comms/iceoryx
+
+USES= bison cmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= eclipse-cyclonedds
+GH_PROJECT= cyclonedds
+
+USE_LDCONFIG= yes
+
+CMAKE_ON= ENABLE_SHM
+
+OPTIONS_DEFINE= DOCS SSL TEST
+OPTIONS_DEFAULT= SSL
+
+SSL_DESC= Enable SSL support
+TEST_DESC= Build tests
+
+SSL_USES= ssl
+SSL_CMAKE_BOOL= ENABLE_SSL
+TEST_LIB_DEPENDS= libcunit.so:devel/cunit
+TEST_CMAKE_BOOL= BUILD_TESTING
+
+.include <bsd.port.mk>
diff --git a/comms/cyclonedds/distinfo b/comms/cyclonedds/distinfo
new file mode 100644
index 000000000000..4569e3ec8880
--- /dev/null
+++ b/comms/cyclonedds/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1654017442
+SHA256 (eclipse-cyclonedds-cyclonedds-0.9.1_GH0.tar.gz) = b2ae16fa6a1812e453f5bf31e4dcb7ce263e486279c0530565a33a49c71c74b8
+SIZE (eclipse-cyclonedds-cyclonedds-0.9.1_GH0.tar.gz) = 5065586
diff --git a/comms/cyclonedds/pkg-descr b/comms/cyclonedds/pkg-descr
new file mode 100644
index 000000000000..a31d5c92c67d
--- /dev/null
+++ b/comms/cyclonedds/pkg-descr
@@ -0,0 +1,7 @@
+Eclipse Cyclone DDS is a very performant and robust open-source implementation
+of the OMG DDS specification. Cyclone DDS is developed completely in the open
+as an Eclipse IoT project (see eclipse-cyclone-dds) with a growing list of
+adopters (if you're one of them, please add your logo). It is a tier-1
+middleware for the Robot Operating System ROS 2.
+
+WWW: https://cyclonedds.io/
diff --git a/comms/cyclonedds/pkg-plist b/comms/cyclonedds/pkg-plist
new file mode 100644
index 000000000000..8a1e0732d8d7
--- /dev/null
+++ b/comms/cyclonedds/pkg-plist
@@ -0,0 +1,225 @@
+bin/ddsperf
+bin/idlc
+bin/pubsub
+include/dds/config.h
+include/dds/dds.h
+include/dds/ddsc/dds_basic_types.h
+include/dds/ddsc/dds_data_allocator.h
+include/dds/ddsc/dds_internal_api.h
+include/dds/ddsc/dds_loan_api.h
+include/dds/ddsc/dds_opcodes.h
+include/dds/ddsc/dds_public_alloc.h
+include/dds/ddsc/dds_public_error.h
+include/dds/ddsc/dds_public_impl.h
+include/dds/ddsc/dds_public_listener.h
+include/dds/ddsc/dds_public_qos.h
+include/dds/ddsc/dds_public_qosdefs.h
+include/dds/ddsc/dds_public_status.h
+include/dds/ddsc/dds_rhc.h
+include/dds/ddsc/dds_statistics.h
+include/dds/ddsi/ddsi_acknack.h
+include/dds/ddsi/ddsi_builtin_topic_if.h
+include/dds/ddsi/ddsi_cdrstream.h
+include/dds/ddsi/ddsi_cfgelems.h
+include/dds/ddsi/ddsi_cfgunits.h
+include/dds/ddsi/ddsi_config.h
+include/dds/ddsi/ddsi_config_impl.h
+include/dds/ddsi/ddsi_deadline.h
+include/dds/ddsi/ddsi_deliver_locally.h
+include/dds/ddsi/ddsi_domaingv.h
+include/dds/ddsi/ddsi_entity_index.h
+include/dds/ddsi/ddsi_guid.h
+include/dds/ddsi/ddsi_handshake.h
+include/dds/ddsi/ddsi_iid.h
+include/dds/ddsi/ddsi_ipaddr.h
+include/dds/ddsi/ddsi_keyhash.h
+include/dds/ddsi/ddsi_lifespan.h
+include/dds/ddsi/ddsi_list_genptr.h
+include/dds/ddsi/ddsi_list_tmpl.h
+include/dds/ddsi/ddsi_locator.h
+include/dds/ddsi/ddsi_mcgroup.h
+include/dds/ddsi/ddsi_ownip.h
+include/dds/ddsi/ddsi_plist.h
+include/dds/ddsi/ddsi_plist_generic.h
+include/dds/ddsi/ddsi_pmd.h
+include/dds/ddsi/ddsi_portmapping.h
+include/dds/ddsi/ddsi_raweth.h
+include/dds/ddsi/ddsi_rhc.h
+include/dds/ddsi/ddsi_security_exchange.h
+include/dds/ddsi/ddsi_security_msg.h
+include/dds/ddsi/ddsi_security_omg.h
+include/dds/ddsi/ddsi_security_util.h
+include/dds/ddsi/ddsi_serdata.h
+include/dds/ddsi/ddsi_serdata_default.h
+include/dds/ddsi/ddsi_serdata_plist.h
+include/dds/ddsi/ddsi_serdata_pserop.h
+include/dds/ddsi/ddsi_sertopic.h
+include/dds/ddsi/ddsi_sertype.h
+include/dds/ddsi/ddsi_shm_transport.h
+include/dds/ddsi/ddsi_ssl.h
+include/dds/ddsi/ddsi_statistics.h
+include/dds/ddsi/ddsi_tcp.h
+include/dds/ddsi/ddsi_threadmon.h
+include/dds/ddsi/ddsi_time.h
+include/dds/ddsi/ddsi_tkmap.h
+include/dds/ddsi/ddsi_tran.h
+include/dds/ddsi/ddsi_typelib.h
+include/dds/ddsi/ddsi_typelookup.h
+include/dds/ddsi/ddsi_typewrap.h
+include/dds/ddsi/ddsi_udp.h
+include/dds/ddsi/ddsi_vendor.h
+include/dds/ddsi/ddsi_vnet.h
+include/dds/ddsi/ddsi_wraddrset.h
+include/dds/ddsi/ddsi_xqos.h
+include/dds/ddsi/ddsi_xt_impl.h
+include/dds/ddsi/ddsi_xt_typeinfo.h
+include/dds/ddsi/ddsi_xt_typeinfo.idl
+include/dds/ddsi/ddsi_xt_typelookup.h
+include/dds/ddsi/ddsi_xt_typelookup.idl
+include/dds/ddsi/ddsi_xt_typemap.h
+include/dds/ddsi/ddsi_xt_typemap.idl
+include/dds/ddsi/q_addrset.h
+include/dds/ddsi/q_bitset.h
+include/dds/ddsi/q_bswap.h
+include/dds/ddsi/q_ddsi_discovery.h
+include/dds/ddsi/q_debmon.h
+include/dds/ddsi/q_entity.h
+include/dds/ddsi/q_feature_check.h
+include/dds/ddsi/q_freelist.h
+include/dds/ddsi/q_gc.h
+include/dds/ddsi/q_hbcontrol.h
+include/dds/ddsi/q_init.h
+include/dds/ddsi/q_inverse_uint32_set.h
+include/dds/ddsi/q_lat_estim.h
+include/dds/ddsi/q_lease.h
+include/dds/ddsi/q_log.h
+include/dds/ddsi/q_misc.h
+include/dds/ddsi/q_pcap.h
+include/dds/ddsi/q_protocol.h
+include/dds/ddsi/q_qosmatch.h
+include/dds/ddsi/q_radmin.h
+include/dds/ddsi/q_receive.h
+include/dds/ddsi/q_rtps.h
+include/dds/ddsi/q_sockwaitset.h
+include/dds/ddsi/q_thread.h
+include/dds/ddsi/q_transmit.h
+include/dds/ddsi/q_unused.h
+include/dds/ddsi/q_whc.h
+include/dds/ddsi/q_xevent.h
+include/dds/ddsi/q_xmsg.h
+include/dds/ddsi/sysdeps.h
+include/dds/ddsrt/arch.h
+include/dds/ddsrt/atomics.h
+include/dds/ddsrt/atomics/arm.h
+include/dds/ddsrt/atomics/gcc.h
+include/dds/ddsrt/atomics/msvc.h
+include/dds/ddsrt/atomics/sun.h
+include/dds/ddsrt/attributes.h
+include/dds/ddsrt/avl.h
+include/dds/ddsrt/bswap.h
+include/dds/ddsrt/cdtors.h
+include/dds/ddsrt/circlist.h
+include/dds/ddsrt/countargs.h
+include/dds/ddsrt/dynlib.h
+include/dds/ddsrt/endian.h
+include/dds/ddsrt/environ.h
+include/dds/ddsrt/expand_vars.h
+include/dds/ddsrt/fibheap.h
+include/dds/ddsrt/filesystem.h
+include/dds/ddsrt/filesystem/posix.h
+include/dds/ddsrt/filesystem/windows.h
+include/dds/ddsrt/heap.h
+include/dds/ddsrt/hopscotch.h
+include/dds/ddsrt/ifaddrs.h
+include/dds/ddsrt/io.h
+include/dds/ddsrt/iovec.h
+include/dds/ddsrt/log.h
+include/dds/ddsrt/md5.h
+include/dds/ddsrt/mh3.h
+include/dds/ddsrt/misc.h
+include/dds/ddsrt/netstat.h
+include/dds/ddsrt/process.h
+include/dds/ddsrt/random.h
+include/dds/ddsrt/retcode.h
+include/dds/ddsrt/rusage.h
+include/dds/ddsrt/sched.h
+include/dds/ddsrt/sockets.h
+include/dds/ddsrt/sockets/posix.h
+include/dds/ddsrt/sockets/windows.h
+include/dds/ddsrt/static_assert.h
+include/dds/ddsrt/string.h
+include/dds/ddsrt/strtod.h
+include/dds/ddsrt/strtol.h
+include/dds/ddsrt/sync.h
+include/dds/ddsrt/sync/freertos.h
+include/dds/ddsrt/sync/posix.h
+include/dds/ddsrt/sync/windows.h
+include/dds/ddsrt/threads.h
+include/dds/ddsrt/threads/freertos.h
+include/dds/ddsrt/threads/posix.h
+include/dds/ddsrt/threads/windows.h
+include/dds/ddsrt/time.h
+include/dds/ddsrt/time/freertos.h
+include/dds/ddsrt/types.h
+include/dds/ddsrt/types/posix.h
+include/dds/ddsrt/types/vxworks.h
+include/dds/ddsrt/types/windows.h
+include/dds/ddsrt/xmlparser.h
+include/dds/export.h
+include/dds/features.h
+include/dds/security/core/dds_security_fsm.h
+include/dds/security/core/dds_security_plugins.h
+include/dds/security/core/dds_security_serialize.h
+include/dds/security/core/dds_security_timed_cb.h
+include/dds/security/core/dds_security_types.h
+include/dds/security/core/dds_security_utils.h
+include/dds/security/core/shared_secret.h
+include/dds/security/dds_security_api.h
+include/dds/security/dds_security_api_access_control.h
+include/dds/security/dds_security_api_authentication.h
+include/dds/security/dds_security_api_cryptography.h
+include/dds/security/dds_security_api_defs.h
+include/dds/security/dds_security_api_err.h
+include/dds/security/dds_security_api_types.h
+include/dds/version.h
+include/ddsc/dds.h
+include/idl/attributes.h
+include/idl/endian.h
+include/idl/export.h
+include/idl/expression.h
+include/idl/file.h
+include/idl/md5.h
+include/idl/misc.h
+include/idl/print.h
+include/idl/processor.h
+include/idl/retcode.h
+include/idl/scope.h
+include/idl/stream.h
+include/idl/string.h
+include/idl/symbol.h
+include/idl/tree.h
+include/idl/version.h
+include/idl/visit.h
+include/idlc/generator.h
+include/idlc/options.h
+lib/cmake/CycloneDDS/CycloneDDSConfig.cmake
+lib/cmake/CycloneDDS/CycloneDDSConfigVersion.cmake
+lib/cmake/CycloneDDS/CycloneDDSTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/CycloneDDS/CycloneDDSTargets.cmake
+lib/cmake/CycloneDDS/idlc/Generate.cmake
+lib/libcycloneddsidl.so
+lib/libcycloneddsidl.so.0
+lib/libcycloneddsidl.so.0.9.1
+lib/libdds_security_ac.so
+lib/libdds_security_auth.so
+lib/libdds_security_crypto.so
+lib/libddsc.so
+lib/libddsc.so.0
+lib/libddsc.so.0.9.1
+libdata/pkgconfig/CycloneDDS.pc
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG.rst
+%%PORTDOCS%%%%DOCSDIR%%/CONTRIBUTING.md
+%%PORTDOCS%%%%DOCSDIR%%/CYCLONEDDS_QUALITY_DECLARATION.md
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NOTICE.md
+%%PORTDOCS%%%%DOCSDIR%%/README.md