aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-08-16 13:05:49 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-08-16 13:30:47 +0000
commitf733f4069b4e53ee20d16df4d57b50a6ab650735 (patch)
tree1b198f484e60df2c4513cceb7d87d9f834a49eea
parent590db982a0dc14ee1614170083dff3d78d34edcd (diff)
downloadports-f733f4069b4e53ee20d16df4d57b50a6ab650735.tar.gz
ports-f733f4069b4e53ee20d16df4d57b50a6ab650735.zip
x11/plasma-wayland-protocols: remove run depend on self
- reducing unnecessary run-time dependencies will make it easier to add ports for KDE Plasma 6 & Co.
-rw-r--r--audio/plasma5-kpipewire/Makefile6
-rw-r--r--x11-toolkits/kf5-kguiaddons/Makefile8
-rw-r--r--x11-wm/plasma5-kwin/Makefile13
-rw-r--r--x11/kf5-kwayland/Makefile10
-rw-r--r--x11/plasma5-kwayland-integration/Makefile7
-rw-r--r--x11/plasma5-libkscreen/Makefile5
6 files changed, 25 insertions, 24 deletions
diff --git a/audio/plasma5-kpipewire/Makefile b/audio/plasma5-kpipewire/Makefile
index 576501345d3c..bba02f0af347 100644
--- a/audio/plasma5-kpipewire/Makefile
+++ b/audio/plasma5-kpipewire/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kpipewire
DISTVERSION= ${KDE_PLASMA_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -16,8 +16,8 @@ USES= cmake compiler:c++11-lib gettext gl gnome kde:5 pkgconfig qt:5 \
shebangfix tar:xz
USE_GL= egl gbm gl
USE_GNOME= glib20
-USE_KDE= coreaddons i18n plasma-wayland-protocols wayland \
- ecm:build
+USE_KDE= coreaddons i18n wayland \
+ ecm:build plasma-wayland-protocols:build
USE_QT= core dbus declarative gui network wayland \
buildtools:build qmake:build
diff --git a/x11-toolkits/kf5-kguiaddons/Makefile b/x11-toolkits/kf5-kguiaddons/Makefile
index c8741d575824..5ff322d21d8c 100644
--- a/x11-toolkits/kf5-kguiaddons/Makefile
+++ b/x11-toolkits/kf5-kguiaddons/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kguiaddons
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-toolkits kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -7,10 +8,9 @@ COMMENT= KF5 addons to QtGui
LIB_DEPENDS= libwayland-client.so:graphics/wayland
-USES= cmake compiler:c++11-lib desktop-file-utils kde:5 \
- pkgconfig qt:5 tar:xz xorg
-USE_KDE= plasma-wayland-protocols \
- ecm:build
+USES= cmake compiler:c++11-lib desktop-file-utils kde:5 pkgconfig \
+ qt:5 tar:xz xorg
+USE_KDE= ecm:build plasma-wayland-protocols:build
USE_QT= core gui wayland widgets x11extras \
buildtools:build qmake:build testlib:build
USE_XORG= ice sm x11 xcb xext
diff --git a/x11-wm/plasma5-kwin/Makefile b/x11-wm/plasma5-kwin/Makefile
index f50ba58cb9ac..7834fc8abf34 100644
--- a/x11-wm/plasma5-kwin/Makefile
+++ b/x11-wm/plasma5-kwin/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kwin
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-wm kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -33,18 +34,18 @@ RUN_DEPENDS= xwayland-devel>0:x11-servers/xwayland-devel \
CONFLICTS_INSTALL= kwinft # bin/kwin_wayland
-USES= cmake compiler:c++11-lib gettext gl gnome kde:5 pkgconfig \
- python:run qt:5 shebangfix tar:xz xorg
+USES= cmake compiler:c++11-lib gettext gl gnome kde:5 pkgconfig qt:5 \
+ shebangfix tar:xz xorg \
+ python:run
USE_GL= egl gbm
USE_GNOME= glib20
USE_KDE= activities attica auth breeze codecs completion config \
configwidgets coreaddons crash dbusaddons decoration \
globalaccel i18n iconthemes idletime init itemviews jobwidgets \
kcmutils kdeclarative kio kscreenlocker kwayland-integration \
- newstuff notifications package plasma-framework \
- plasma-wayland-protocols runner service sonnet textwidgets \
- wayland widgetsaddons windowsystem xmlgui \
- doctools:build ecm:build
+ newstuff notifications package plasma-framework runner service \
+ sonnet textwidgets wayland widgetsaddons windowsystem xmlgui \
+ doctools:build ecm:build plasma-wayland-protocols:build
USE_LDCONFIG= yes
USE_QT= concurrent core dbus declarative gui multimedia network script \
sensors uiplugin uitools widgets x11extras xml \
diff --git a/x11/kf5-kwayland/Makefile b/x11/kf5-kwayland/Makefile
index a48e937b38db..1b1fc524be10 100644
--- a/x11/kf5-kwayland/Makefile
+++ b/x11/kf5-kwayland/Makefile
@@ -1,22 +1,22 @@
PORTNAME= kwayland
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
COMMENT= KF5 Client and Server library wrapper for the Wayland libraries
BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto \
- wayland-protocols>=0:graphics/wayland-protocols \
- plasma-wayland-protocols>=0:x11/plasma-wayland-protocols
+ wayland-protocols>=0:graphics/wayland-protocols
LIB_DEPENDS= libwayland-client.so:graphics/wayland
LICENSE= LGPL21 LGPL3
LICENSE_COMB= dual
-USES= cmake compiler:c++11-lib gettext gl kde:5 pkgconfig \
- qt:5 tar:xz
+USES= cmake compiler:c++11-lib gettext gl kde:5 pkgconfig qt:5 \
+ tar:xz
USE_GL= egl
-USE_KDE= ecm:build
+USE_KDE= ecm:build plasma-wayland-protocols:build
USE_QT= concurrent core gui wayland \
buildtools:build qmake:build testlib:build
diff --git a/x11/plasma5-kwayland-integration/Makefile b/x11/plasma5-kwayland-integration/Makefile
index 605754095662..d7d47428a294 100644
--- a/x11/plasma5-kwayland-integration/Makefile
+++ b/x11/plasma5-kwayland-integration/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kwayland-integration
DISTVERSION= ${KDE_PLASMA_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -15,9 +15,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto \
USES= cmake compiler:c++11-lib gl kde:5 pkgconfig qt:5 tar:xz xorg
USE_GL= gl
-USE_KDE= guiaddons idletime plasma-wayland-protocols wayland \
- windowsystem \
- ecm:build
+USE_KDE= guiaddons idletime wayland windowsystem \
+ ecm:build plasma-wayland-protocols:build
USE_QT= core gui wayland widgets \
buildtools:build qmake:build
USE_XORG= x11
diff --git a/x11/plasma5-libkscreen/Makefile b/x11/plasma5-libkscreen/Makefile
index e54ef7ecc6fc..cb386d742125 100644
--- a/x11/plasma5-libkscreen/Makefile
+++ b/x11/plasma5-libkscreen/Makefile
@@ -1,5 +1,6 @@
PORTNAME= libkscreen
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -10,8 +11,8 @@ LIB_DEPENDS= libwayland-client.so:graphics/wayland
USES= cmake compiler:c++11-lib kde:5 pathfix pkgconfig qt:5 tar:xz \
xorg
-USE_KDE= config plasma-wayland-protocols wayland \
- ecm:build
+USE_KDE= config wayland \
+ ecm:build plasma-wayland-protocols:build
USE_QT= core dbus gui wayland x11extras \
buildtools:build qmake:build testlib:build
USE_XORG= x11 xcb xrandr