aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-12-08 08:38:09 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-12-12 20:56:40 +0000
commitf735bc3d93c4559aef3b2c9924d3c408ff3a3191 (patch)
treeb088d288ed38266e1288fdf5eaea7d730880e01f
parent7b20f87790b64c5e3c068c4ab055f5f9758db0b7 (diff)
Mk/Uses/meson.mk: pass --localstatedir like GNU_CONFIGURE after 9f4546a03cc0
Meson defaults to --localstatedir=/var/local if --prefix=/usr/local but this is not valid for ports/ or FreeBSD hier(7). See also 68edbeeaae96 and https://github.com/mesonbuild/meson/commit/24549dbed5fe PR: 273605 Analyzed by: Tatsuki Makino Exp-run by: antoine
-rw-r--r--Mk/Uses/meson.mk1
-rw-r--r--devel/glib20/Makefile1
-rw-r--r--devel/libvirt/Makefile7
-rw-r--r--graphics/colord/Makefile3
-rw-r--r--net/netatalk3/Makefile1
-rw-r--r--ports-mgmt/packagekit/Makefile2
-rw-r--r--sysutils/accountsservice/Makefile1
-rw-r--r--sysutils/pacman/Makefile2
-rw-r--r--sysutils/polkit/Makefile1
-rw-r--r--sysutils/upower/Makefile1
-rw-r--r--x11-fonts/fontconfig/Makefile1
11 files changed, 6 insertions, 15 deletions
diff --git a/Mk/Uses/meson.mk b/Mk/Uses/meson.mk
index 571e8a990be0..eded01a885bf 100644
--- a/Mk/Uses/meson.mk
+++ b/Mk/Uses/meson.mk
@@ -33,6 +33,7 @@ BUILD_DEPENDS+= meson:devel/meson
USE_LOCALE?= en_US.UTF-8
CONFIGURE_ARGS+= --prefix ${PREFIX} \
+ --localstatedir /var \
--infodir ${INFO_PATH}
# Enable all optional features to make builds deterministic. Consumers can
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index fbeed640d9ae..4d5b1133aa50 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -33,7 +33,6 @@ MESON_ARGS= -Db_lundef=false \
-Dinstalled_tests=false \
-Dintrospection=disabled \
-Dlibmount=disabled \
- -Dlocalstatedir=/var \
-Druntime_dir=/var/run \
-Dselinux=disabled \
-Dxattr=false
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index b73b94317ebb..96500977e6fe 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -71,8 +71,6 @@ LIBSSH2_LIB_DEPENDS= libssh2.so:security/libssh2
ZFS_MESON_ENABLED= storage_zfs
-VARDIR= /var
-
MESON_ARGS+= \
-Dapparmor=disabled \
-Dapparmor_profiles=disabled \
@@ -122,8 +120,7 @@ MESON_ARGS+= \
-Dwireshark_dissector=disabled \
-Dinit_script=none \
-Dbash_completion=disabled \
- -Duserfaultfd_sysctl=disabled \
- -Dlocalstatedir=${VARDIR}
+ -Duserfaultfd_sysctl=disabled
# random_data fix can be removed when 8.x is eol
CONFIGURE_ENV= ac_cv_type_struct_random_data=""
@@ -203,7 +200,7 @@ post-install:
lib/libvirt/network \
lib/libvirt/qemu/channel/target \
cache/libvirt/qemu
- @${MKDIR} "${STAGEDIR}/${VARDIR}/${dir}"
+ @${MKDIR} "${STAGEDIR}/var/${dir}"
.endfor
.for file in ${CONF_FILES}
diff --git a/graphics/colord/Makefile b/graphics/colord/Makefile
index c3a369abcd8e..34a8ec0f0596 100644
--- a/graphics/colord/Makefile
+++ b/graphics/colord/Makefile
@@ -28,8 +28,7 @@ MAKE_JOBS_UNSAFE= yes
MAKE_ENV= PYTHONDONTWRITEBYTECODE=1
MESON_ARGS= -Dsystemd=false -Dudev_rules=false \
-Ddaemon_user=colord -Dlibcolordcompat=true \
- -Dpnp_ids=${LOCALBASE}/share/hwdata/pnp.ids \
- --localstatedir=/var \
+ -Dpnp_ids=${LOCALBASE}/share/hwdata/pnp.ids
INSTALL_TARGET= install-strip
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index 847aedfefe42..495828d87590 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -30,7 +30,6 @@ MESON_ARGS= -Dwith-libgcrypt-path=${LOCALBASE} \
-Dwith-shadow=false \
-Dwith-pgp-uam=false \
-Ddefault_library=both \
- --localstatedir=/var \
--infodir=${PREFIX}/share/info
OPTIONS_DEFINE=PAM KERBEROS5 LDAP SENDFILE KERBEROS DBUS MYSQL ACL LIBWRAP SPOTLIGHT
diff --git a/ports-mgmt/packagekit/Makefile b/ports-mgmt/packagekit/Makefile
index 405978bfc380..bf0290e2eb9f 100644
--- a/ports-mgmt/packagekit/Makefile
+++ b/ports-mgmt/packagekit/Makefile
@@ -27,7 +27,7 @@ USE_LDCONFIG= yes
CPE_VENDOR= packagekit_project
SHEBANG_FILES= contrib/cron/packagekit-background.cron
-MESON_ARGS= -Dlocalstatedir=/var -Dsysconfdir=${PREFIX}/etc \
+MESON_ARGS= -Dsysconfdir=${PREFIX}/etc \
-Dpackaging_backend=freebsd -Dsystemd=false -Doffline_update=false \
-Dbash_completion=false -Dbash_command_not_found=false \
-Dgstreamer_plugin=false
diff --git a/sysutils/accountsservice/Makefile b/sysutils/accountsservice/Makefile
index 95c78eed1ac9..d7b57124c667 100644
--- a/sysutils/accountsservice/Makefile
+++ b/sysutils/accountsservice/Makefile
@@ -22,7 +22,6 @@ USE_LDCONFIG= yes
MESON_ARGS= -Dconsolekit=true \
-Dgdmconffile=${LOCALBASE}/etc/gdm/custom.conf \
-Dlightdmconffile=${LOCALBASE}/etc/lightdm/lightdm.conf \
- -Dlocalstatedir=/var \
-Dsystemdsystemunitdir=no \
-Dvapi=false \
-Dtests=false
diff --git a/sysutils/pacman/Makefile b/sysutils/pacman/Makefile
index 54515cca4732..1ac37bce8b2f 100644
--- a/sysutils/pacman/Makefile
+++ b/sysutils/pacman/Makefile
@@ -28,7 +28,7 @@ SHEBANG_FILES= ${WRKSRC}/scripts/makepkg-template.pl.in \
${WRKSRC}/scripts/libmakepkg/lint_config.sh.in
BINARY_ALIAS= python3=${PYTHON_CMD}
MESON_ARGS= -Droot-dir=${PACMAN_ROOT} \
- -Dlocalstatedir=${PACMAN_ROOT}/var \
+ --localstatedir=${PACMAN_ROOT}/var \
-Dsysconfdir=${PREFIX}/etc \
-Dcrypto=openssl
USE_LDCONFIG= yes
diff --git a/sysutils/polkit/Makefile b/sysutils/polkit/Makefile
index 432a074478a4..2a5b51483b3e 100644
--- a/sysutils/polkit/Makefile
+++ b/sysutils/polkit/Makefile
@@ -32,7 +32,6 @@ MESON_ARGS= -Dpam_include=system \
-Dsession_tracking=ConsoleKit \
-Dtests=false \
-Dintrospection=true \
- -Dlocalstatedir=/var \
-Dgtk_doc=false
OPTIONS_DEFINE= MANPAGES
diff --git a/sysutils/upower/Makefile b/sysutils/upower/Makefile
index 6c05643139fe..e32dbca3355a 100644
--- a/sysutils/upower/Makefile
+++ b/sysutils/upower/Makefile
@@ -20,7 +20,6 @@ USE_GNOME= glib20 introspection:build
USE_LDCONFIG= yes
MESON_ARGS= -Dgtk-doc=false \
-Dos_backend=freebsd \
- -Dlocalstatedir=/var \
-Dudevrulesdir=no \
-Dudevhwdbdir=no \
-Dsystemdsystemunitdir=no \
diff --git a/x11-fonts/fontconfig/Makefile b/x11-fonts/fontconfig/Makefile
index 1418e8e48fe5..6d2d51eaa975 100644
--- a/x11-fonts/fontconfig/Makefile
+++ b/x11-fonts/fontconfig/Makefile
@@ -35,7 +35,6 @@ SUB_LIST= LOCALBASE=${LOCALBASE}
MESON_ARGS= -Ddefault_library=both -Ddoc=disabled -Dcache-build=disabled \
-Ddefault-fonts-dirs=${PREFIX}/share/fonts \
-Dadditional-fonts-dirs=${LOCALBASE}/lib/X11/fonts \
- -Dlocalstatedir=/var \
-Dcache-dir=/var/db/fontconfig \
-Dtemplate-dir=${LOCALBASE}/etc/fonts/conf.avail \
-Dxml-dir=${LOCALBASE}/etc/fonts