aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-03 08:50:15 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-03 09:00:26 +0000
commitf7ac403ff2998b883ecccfe06c3da98799a9de92 (patch)
tree2eb38de15fd1508da8af6d0cb684c5709ed7abf5
parenta85386a0fc736d22a1928886b0b35b7acd659fa2 (diff)
downloadports-f7ac403ff2998b883ecccfe06c3da98799a9de92.tar.gz
ports-f7ac403ff2998b883ecccfe06c3da98799a9de92.zip
www/npm: Update to 8.10.0
-rw-r--r--www/npm/Makefile2
-rw-r--r--www/npm/distinfo6
-rw-r--r--www/npm/pkg-plist13
3 files changed, 7 insertions, 14 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index e90c5e0435f4..adfcea7cee56 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -1,7 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= npm
-PORTVERSION= 8.8.0
+PORTVERSION= 8.10.0
CATEGORIES= www
MASTER_SITES= LOCAL/sunpoet
diff --git a/www/npm/distinfo b/www/npm/distinfo
index 749bee5a7b94..726a0f3cb89c 100644
--- a/www/npm/distinfo
+++ b/www/npm/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1652122593
-SHA256 (npm-8.8.0.tar.xz) = ee43694cdef336ba621e72c19bcf7bc23a4adb6cd5a3b2eb61a428f849d6779a
-SIZE (npm-8.8.0.tar.xz) = 1600424
+TIMESTAMP = 1653925904
+SHA256 (npm-8.10.0.tar.xz) = 694765c780dbcd9fa320d39cec1b094a434597fbe6d24a3545224b030674c8f3
+SIZE (npm-8.10.0.tar.xz) = 1601548
diff --git a/www/npm/pkg-plist b/www/npm/pkg-plist
index 7359167b57f0..0c7a80dfa9f8 100644
--- a/www/npm/pkg-plist
+++ b/www/npm/pkg-plist
@@ -250,8 +250,7 @@ lib/node_modules/npm/lib/commands/whoami.js
lib/node_modules/npm/lib/exec/get-workspace-location-msg.js
lib/node_modules/npm/lib/lifecycle-cmd.js
lib/node_modules/npm/lib/npm.js
-lib/node_modules/npm/lib/search/format-package-stream.js
-lib/node_modules/npm/lib/search/package-filter.js
+lib/node_modules/npm/lib/package-url-cmd.js
lib/node_modules/npm/lib/utils/ansi-trim.js
lib/node_modules/npm/lib/utils/audit-error.js
lib/node_modules/npm/lib/utils/cmd-list.js
@@ -269,10 +268,9 @@ lib/node_modules/npm/lib/utils/error-message.js
lib/node_modules/npm/lib/utils/exit-handler.js
lib/node_modules/npm/lib/utils/explain-dep.js
lib/node_modules/npm/lib/utils/explain-eresolve.js
-lib/node_modules/npm/lib/utils/file-exists.js
lib/node_modules/npm/lib/utils/format-bytes.js
+lib/node_modules/npm/lib/utils/format-search-stream.js
lib/node_modules/npm/lib/utils/get-identity.js
-lib/node_modules/npm/lib/utils/hosted-git-info-from-manifest.js
lib/node_modules/npm/lib/utils/is-windows.js
lib/node_modules/npm/lib/utils/log-file.js
lib/node_modules/npm/lib/utils/log-shim.js
@@ -282,7 +280,6 @@ lib/node_modules/npm/lib/utils/otplease.js
lib/node_modules/npm/lib/utils/ping.js
lib/node_modules/npm/lib/utils/pulse-till-done.js
lib/node_modules/npm/lib/utils/queryable.js
-lib/node_modules/npm/lib/utils/read-package-name.js
lib/node_modules/npm/lib/utils/read-user-info.js
lib/node_modules/npm/lib/utils/reify-finish.js
lib/node_modules/npm/lib/utils/reify-output.js
@@ -456,6 +453,7 @@ lib/node_modules/npm/node_modules/@npmcli/arborist/lib/inventory.js
lib/node_modules/npm/node_modules/@npmcli/arborist/lib/link.js
lib/node_modules/npm/node_modules/@npmcli/arborist/lib/node.js
lib/node_modules/npm/node_modules/@npmcli/arborist/lib/optional-set.js
+lib/node_modules/npm/node_modules/@npmcli/arborist/lib/override-resolves.js
lib/node_modules/npm/node_modules/@npmcli/arborist/lib/override-set.js
lib/node_modules/npm/node_modules/@npmcli/arborist/lib/peer-entry-sets.js
lib/node_modules/npm/node_modules/@npmcli/arborist/lib/place-dep.js
@@ -689,7 +687,6 @@ lib/node_modules/npm/node_modules/cacache/lib/index.js
lib/node_modules/npm/node_modules/cacache/lib/memoization.js
lib/node_modules/npm/node_modules/cacache/lib/put.js
lib/node_modules/npm/node_modules/cacache/lib/rm.js
-lib/node_modules/npm/node_modules/cacache/lib/util/disposer.js
lib/node_modules/npm/node_modules/cacache/lib/util/fix-owner.js
lib/node_modules/npm/node_modules/cacache/lib/util/hash-to-segments.js
lib/node_modules/npm/node_modules/cacache/lib/util/move-file.js
@@ -994,7 +991,6 @@ lib/node_modules/npm/node_modules/init-package-json/lib/init-package-json.js
lib/node_modules/npm/node_modules/init-package-json/package.json
lib/node_modules/npm/node_modules/ip/lib/ip.js
lib/node_modules/npm/node_modules/ip/package.json
-lib/node_modules/npm/node_modules/ip/test/api-test.js
lib/node_modules/npm/node_modules/ip-regex/index.d.ts
lib/node_modules/npm/node_modules/ip-regex/index.js
lib/node_modules/npm/node_modules/ip-regex/license
@@ -1737,9 +1733,6 @@ lib/node_modules/npm/node_modules/socks/typings/common/helpers.d.ts
lib/node_modules/npm/node_modules/socks/typings/common/receivebuffer.d.ts
lib/node_modules/npm/node_modules/socks/typings/common/util.d.ts
lib/node_modules/npm/node_modules/socks/typings/index.d.ts
-lib/node_modules/npm/node_modules/socks-proxy-agent/dist/agent.d.ts
-lib/node_modules/npm/node_modules/socks-proxy-agent/dist/agent.js
-lib/node_modules/npm/node_modules/socks-proxy-agent/dist/agent.js.map
lib/node_modules/npm/node_modules/socks-proxy-agent/dist/index.d.ts
lib/node_modules/npm/node_modules/socks-proxy-agent/dist/index.js
lib/node_modules/npm/node_modules/socks-proxy-agent/dist/index.js.map