aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2022-05-17 15:10:31 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2022-05-17 15:14:20 +0000
commitf7aef8540293ec1a4e47857ccec9592023c953c5 (patch)
tree720c8a300e21b9f8c73e953e0e3120921741edce
parent6acc4f06297bee8a9dfe5d055a9c7ec0b3dc692d (diff)
downloadports-f7aef8540293ec1a4e47857ccec9592023c953c5.tar.gz
ports-f7aef8540293ec1a4e47857ccec9592023c953c5.zip
net/asterisk16: Fix configure issue when PJSIP option is disabled
pkgconfig is now used by asterisk to detect most required dependencies, so add it to the global USES. At the same time there is a bug in the menuselect configure script that shows up when the PJSIP option is disabled. It tries to run sed through a $SED variable before populating it. As a workaround for now I just replace the $SED variable with the bare sed command. PR: 263980 Fixes: e8e6fba878cf12
-rw-r--r--net/asterisk16/Makefile3
-rw-r--r--net/asterisk16/files/patch-menuselect_configure11
2 files changed, 12 insertions, 2 deletions
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index 2e818c1bbb99..ba2fca18f020 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libuuid.so:misc/e2fsprogs-libuuid \
libjansson.so:devel/jansson
USES= bison compiler:c11 cpe gmake gnome iconv libedit localbase \
- shebangfix sqlite ssl ncurses
+ pkgconfig shebangfix sqlite ssl ncurses
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_RC_SUBR= asterisk
@@ -166,7 +166,6 @@ PGSQL_CONFIGURE_WITH= postgres
PGSQL_USES= pgsql
PJSIP_CONFIGURE_WITH= pjproject pjproject-bundled
-PJSIP_USES= pkgconfig
PJSIP_LIB_DEPENDS= libsrtp2.so:net/libsrtp2 \
libspeex.so:audio/speex \
libspeexdsp.so:audio/speexdsp
diff --git a/net/asterisk16/files/patch-menuselect_configure b/net/asterisk16/files/patch-menuselect_configure
new file mode 100644
index 000000000000..30b3d50d7a34
--- /dev/null
+++ b/net/asterisk16/files/patch-menuselect_configure
@@ -0,0 +1,11 @@
+--- menuselect/configure.orig 2022-05-12 11:47:40 UTC
++++ menuselect/configure
+@@ -5024,7 +5024,7 @@ printf "%s\n" "yes" >&6; }
+ printf "%s\n" "yes" >&6; }
+
+ PBX_LIBXML2=1
+- LIBXML2_INCLUDE=$(echo ${LIBXML2_CFLAGS} | $SED -e "s|-std=c99||g")
++ LIBXML2_INCLUDE=$(echo ${LIBXML2_CFLAGS} | sed -e "s|-std=c99||g")
+ LIBXML2_LIB="$LIBXML2_LIBS"
+
+ printf "%s\n" "#define HAVE_LIBXML2 1" >>confdefs.h