aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2024-10-26 20:37:37 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2024-10-28 12:42:06 +0000
commitf7b1e63b41d0c8b645c23e0d93c8ad644cbbba4b (patch)
treeea657884f145e977f14eb2c8e4e3e4dd1e00dc6c
parentbec3162cc0d7607405ac59a6e6e93a03cfabfa3f (diff)
games/quadra: fix build on 15-CURRENT
Link with -lutil to get ftime() which was moved there with recently. This is harmless on older FreeBSD. While we are at it, define LICENSE. Approved by: portmgr (build fix blanket, infrastructure blanket) MFH: 2024Q4
-rw-r--r--games/quadra/Makefile5
-rw-r--r--games/quadra/files/patch-source__rules.mk2
2 files changed, 5 insertions, 2 deletions
diff --git a/games/quadra/Makefile b/games/quadra/Makefile
index 6573e7a9cc81..3a7da5315d58 100644
--- a/games/quadra/Makefile
+++ b/games/quadra/Makefile
@@ -1,6 +1,6 @@
PORTNAME= quadra
PORTVERSION= 1.3.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= http://kbrandt.sdf-eu.org/FreeBSD/distfiles/ \
ftp://ftp.bsdforen.de/pub/BSDForen/distfiles/ \
@@ -10,6 +10,9 @@ MAINTAINER= kbrandt@sdf-eu.org
COMMENT= Tetris like game with multiplayer support
WWW= https://code.google.com/p/quadra/
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
LIB_DEPENDS= libpng.so:graphics/png
USES= autoreconf gmake localbase sdl tar:bzip2 xorg
diff --git a/games/quadra/files/patch-source__rules.mk b/games/quadra/files/patch-source__rules.mk
index e06522efadd5..ae74283075ea 100644
--- a/games/quadra/files/patch-source__rules.mk
+++ b/games/quadra/files/patch-source__rules.mk
@@ -5,7 +5,7 @@
# $Id: rules.mk 684 2008-12-20 07:14:57Z pphaneuf $
-source/quadra: LDLIBS+=$(SDL_LIBS) -lpng -lz
-+EXT_LIBS := -lcompat # needed in FBSD for the ftime function
++EXT_LIBS := -lcompat -lutil # needed in FBSD for the ftime function
+
+source/quadra: LDLIBS+=$(SDL_LIBS) -lpng -lz $(EXT_LIBS)
source/quadra: $(QUADRA_OBJECTS) $(SDL_MAIN_OBJ) skelton/lib/libugs_s.a