aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-08-15 09:44:49 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-08-15 10:55:30 +0000
commitf8667c851539e6b263ae5461b81465085e6fe17d (patch)
tree9453a26e8b5e7a4b1cc1a05984143ca1f78156c9
parent9bccc8dbafbd89b5f993e3915ff3a903037b58fd (diff)
devel/avro-c: Update to 1.12.0
- Update MASTER_SITES - Update WWW - Bump PORTREVISION of dependent ports for shlib change Changes: https://github.com/apache/avro/releases
-rw-r--r--devel/avro-c/Makefile9
-rw-r--r--devel/avro-c/distinfo6
-rw-r--r--devel/avro-c/files/patch-CMakeLists.txt22
-rw-r--r--devel/avro-c/pkg-plist4
-rw-r--r--devel/libserdes/Makefile1
-rw-r--r--net-mgmt/pmacct/Makefile1
6 files changed, 14 insertions, 29 deletions
diff --git a/devel/avro-c/Makefile b/devel/avro-c/Makefile
index 378d8b2931fd..8273d7952320 100644
--- a/devel/avro-c/Makefile
+++ b/devel/avro-c/Makefile
@@ -1,13 +1,14 @@
PORTNAME= avro
-PORTVERSION= 1.11.3
+PORTVERSION= 1.12.0
CATEGORIES= devel
-MASTER_SITES= APACHE/avro/stable/c
+MASTER_SITES= APACHE/avro/avro-${PORTVERSION}/c
PKGNAMESUFFIX= -c
DISTNAME= avro-c-${PORTVERSION}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= C library for Apache Avro
-WWW= https://avro.apache.org/
+WWW= https://avro.apache.org/ \
+ https://github.com/apache/avro
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -15,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libjansson.so:devel/jansson \
libsnappy.so:archivers/snappy
-USES= cmake compiler:c++11-lang cpe pathfix pkgconfig shebangfix
+USES= cmake cpe pathfix pkgconfig shebangfix
USE_LDCONFIG= yes
diff --git a/devel/avro-c/distinfo b/devel/avro-c/distinfo
index 0f3cd07b35b4..c69041b9adfa 100644
--- a/devel/avro-c/distinfo
+++ b/devel/avro-c/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1696001296
-SHA256 (avro-c-1.11.3.tar.gz) = 7217caacfb7d5f34611766473a66c2e279bc7bfaf1ba298c7f04b3b2fba57365
-SIZE (avro-c-1.11.3.tar.gz) = 214344
+TIMESTAMP = 1723201037
+SHA256 (avro-c-1.12.0.tar.gz) = 74333d431079c35d770cef6996cb4de04058d19e81bd0b9a363bcfd38575037f
+SIZE (avro-c-1.12.0.tar.gz) = 219070
diff --git a/devel/avro-c/files/patch-CMakeLists.txt b/devel/avro-c/files/patch-CMakeLists.txt
index 1cb58a87964c..e13c676a44c3 100644
--- a/devel/avro-c/files/patch-CMakeLists.txt
+++ b/devel/avro-c/files/patch-CMakeLists.txt
@@ -1,24 +1,6 @@
---- CMakeLists.txt.orig 2022-02-23 16:45:22 UTC
+--- CMakeLists.txt.orig 2024-07-25 19:23:22 UTC
+++ CMakeLists.txt
-@@ -151,7 +151,7 @@ endif (ZLIB_FOUND)
-
- find_package(Snappy)
- if (SNAPPY_FOUND AND ZLIB_FOUND) # Snappy borrows crc32 from zlib
-- set(SNAPPY_PKG libsnappy)
-+ set(SNAPPY_PKG snappy)
- add_definitions(-DSNAPPY_CODEC)
- include_directories(${SNAPPY_INCLUDE_DIRS})
- message("Enabled snappy codec")
-@@ -176,7 +176,7 @@ else (LZMA_FOUND)
- endif (LZMA_FOUND)
-
- set(CODEC_LIBRARIES ${ZLIB_LIBRARIES} ${LZMA_LIBRARIES} ${SNAPPY_LIBRARIES})
--set(CODEC_PKG "@ZLIB_PKG@ @LZMA_PKG@ @SNAPPY_PKG@")
-+set(CODEC_PKG ${ZLIB_PKG} ${LZMA_PKG} ${SNAPPY_PKG})
-
- # Jansson JSON library
- pkg_check_modules(JANSSON jansson>=2.3)
-@@ -192,7 +192,6 @@ endif (JANSSON_FOUND)
+@@ -192,7 +192,6 @@ add_subdirectory(tests)
add_subdirectory(src)
add_subdirectory(examples)
add_subdirectory(tests)
diff --git a/devel/avro-c/pkg-plist b/devel/avro-c/pkg-plist
index d3280069443b..b0f56c1ad92d 100644
--- a/devel/avro-c/pkg-plist
+++ b/devel/avro-c/pkg-plist
@@ -20,6 +20,6 @@ include/avro/schema.h
include/avro/value.h
lib/libavro.a
lib/libavro.so
-lib/libavro.so.23
-lib/libavro.so.23.0.0
+lib/libavro.so.24
+lib/libavro.so.24.0.1
libdata/pkgconfig/avro-c.pc
diff --git a/devel/libserdes/Makefile b/devel/libserdes/Makefile
index 5274814ef9fa..577bfa232442 100644
--- a/devel/libserdes/Makefile
+++ b/devel/libserdes/Makefile
@@ -1,6 +1,7 @@
PORTNAME= libserdes
PORTVERSION= 6.0.2
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= sergey@akhmatov.ru
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index f106397f51e6..584609cacfc5 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -1,5 +1,6 @@
PORTNAME= pmacct
DISTVERSION= 1.7.8
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://www.pmacct.net/