aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2024-09-30 15:56:09 +0000
committerBrooks Davis <brooks@FreeBSD.org>2024-09-30 22:11:21 +0000
commitf92880d3e5824f943fb5de9eb395dbfe30a55c1c (patch)
tree22953e61830880518e0f0886158d3c63afb16e20
parent74b8645f51e965106064373b43ce13b552adfe1e (diff)
downloadports-f92880d3e5824f943fb5de9eb395dbfe30a55c1c.tar.gz
ports-f92880d3e5824f943fb5de9eb395dbfe30a55c1c.zip
mail/qmail-dk: include errno.h for errno
errno must be accessed by a macro from errno.h.
-rw-r--r--mail/qmail-dk/Makefile2
-rw-r--r--mail/qmail-dk/files/patch-cdb__seek.c9
-rw-r--r--mail/qmail-dk/files/patch-dns.c10
-rw-r--r--mail/qmail-dk/files/patch-error.h11
4 files changed, 31 insertions, 1 deletions
diff --git a/mail/qmail-dk/Makefile b/mail/qmail-dk/Makefile
index 76ec823dc763..27e55fc91560 100644
--- a/mail/qmail-dk/Makefile
+++ b/mail/qmail-dk/Makefile
@@ -1,6 +1,6 @@
PORTNAME= dk
PORTVERSION= 0.54
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= QMAIL
PKGNAMEPREFIX= qmail-
diff --git a/mail/qmail-dk/files/patch-cdb__seek.c b/mail/qmail-dk/files/patch-cdb__seek.c
new file mode 100644
index 000000000000..167a43dfcb3f
--- /dev/null
+++ b/mail/qmail-dk/files/patch-cdb__seek.c
@@ -0,0 +1,9 @@
+--- cdb_seek.c.orig
++++ cdb_seek.c
+@@ -1,6 +1,5 @@
+ #include <sys/types.h>
+ #include <errno.h>
+-extern int errno;
+ #include "cdb.h"
+
+ #ifndef SEEK_SET
diff --git a/mail/qmail-dk/files/patch-dns.c b/mail/qmail-dk/files/patch-dns.c
new file mode 100644
index 000000000000..568abd815d27
--- /dev/null
+++ b/mail/qmail-dk/files/patch-dns.c
@@ -0,0 +1,10 @@
+--- dns.c.orig
++++ dns.c
+@@ -7,7 +7,6 @@
+ #include <errno.h>
+ extern int res_query();
+ extern int res_search();
+-extern int errno;
+ extern int h_errno;
+ #include "ip.h"
+ #include "ipalloc.h"
diff --git a/mail/qmail-dk/files/patch-error.h b/mail/qmail-dk/files/patch-error.h
new file mode 100644
index 000000000000..e35ddb04802a
--- /dev/null
+++ b/mail/qmail-dk/files/patch-error.h
@@ -0,0 +1,11 @@
+--- error.h.orig
++++ error.h
+@@ -1,7 +1,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;