aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-08 03:48:23 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-08 15:15:38 +0000
commitf96dea1cf1e86a79745163c65d788329db7bd2cd (patch)
tree97448e814014465fcdcc1616441b5f474e5a288c
parente25ebaf6c33516c30cfc50b738cec486f74544c6 (diff)
downloadports-f96dea1cf1e86a79745163c65d788329db7bd2cd.tar.gz
ports-f96dea1cf1e86a79745163c65d788329db7bd2cd.zip
devel/py-pytest-qt: New port: PyTest support for PyQt and PySide applications
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-qt/Makefile24
-rw-r--r--devel/py-pytest-qt/distinfo3
-rw-r--r--devel/py-pytest-qt/pkg-descr6
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 49155afeefd3..0018b2514f28 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5151,6 +5151,7 @@
SUBDIR += py-pytest-plus
SUBDIR += py-pytest-profiling
SUBDIR += py-pytest-pycodestyle
+ SUBDIR += py-pytest-qt
SUBDIR += py-pytest-randomly
SUBDIR += py-pytest-regressions
SUBDIR += py-pytest-regtest
diff --git a/devel/py-pytest-qt/Makefile b/devel/py-pytest-qt/Makefile
new file mode 100644
index 000000000000..4266f5ddb3e5
--- /dev/null
+++ b/devel/py-pytest-qt/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= pytest-qt
+DISTVERSION= 4.1.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= PyTest support for PyQt and PySide applications
+WWW= https://github.com/pytest-dev/pytest-qt
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils pytest # 3 tests fail, see https://github.com/pytest-dev/pytest-qt/issues/457
+
+NO_ARCH= yes
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest-qt/distinfo b/devel/py-pytest-qt/distinfo
new file mode 100644
index 000000000000..55520684b58c
--- /dev/null
+++ b/devel/py-pytest-qt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1665198683
+SHA256 (pytest-qt-4.1.0.tar.gz) = 027f3d3f5dd04af0530d846cf50fb858f719f7e87c2e4a1c686abd4e0f72172a
+SIZE (pytest-qt-4.1.0.tar.gz) = 119702
diff --git a/devel/py-pytest-qt/pkg-descr b/devel/py-pytest-qt/pkg-descr
new file mode 100644
index 000000000000..dc23b60cc12f
--- /dev/null
+++ b/devel/py-pytest-qt/pkg-descr
@@ -0,0 +1,6 @@
+pytest-qt is a pytest plugin that allows programmers to write tests for PyQt5,
+PyQt6, PySide2 and PySide6 applications.
+
+The main usage is to use the qtbot fixture, responsible for handling qApp
+creation as needed and provides methods to simulate user interaction, like key
+presses and mouse clicks.