aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-03-06 10:26:33 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-03-06 11:50:45 +0000
commitf98c438a01911643667fecb0780638d60d3843dd (patch)
tree567b1e2b5e36a2c8774d18659079acbdc4db7160
parent5699106002b551d66a29a37f501d553e7245c18d (diff)
downloadports-f98c438a01911643667fecb0780638d60d3843dd.tar.gz
ports-f98c438a01911643667fecb0780638d60d3843dd.zip
emulators/yuzu: unbreak build on aarch64
In file included from src/core/debugger/debugger.cpp:8: In file included from /usr/local/include/boost/asio.hpp:20: In file included from /usr/local/include/boost/asio/append.hpp:74: In file included from /usr/local/include/boost/asio/impl/append.hpp:22: In file included from /usr/local/include/boost/asio/detail/handler_alloc_helpers.hpp:21: In file included from /usr/local/include/boost/asio/detail/recycling_allocator.hpp:20: In file included from /usr/local/include/boost/asio/detail/thread_context.hpp:20: In file included from /usr/local/include/boost/asio/detail/call_stack.hpp:20: In file included from /usr/local/include/boost/asio/detail/tss_ptr.hpp:27: In file included from /usr/local/include/boost/asio/detail/posix_tss_ptr.hpp:76: In file included from /usr/local/include/boost/asio/detail/impl/posix_tss_ptr.ipp:23: In file included from /usr/local/include/boost/asio/detail/throw_error.hpp:20: In file included from /usr/local/include/boost/system/error_code.hpp:13: In file included from /usr/local/include/boost/system/detail/error_code.hpp:15: In file included from /usr/local/include/boost/system/detail/error_condition.hpp:18: In file included from /usr/local/include/boost/system/detail/append_int.hpp:8: /usr/local/include/boost/system/detail/snprintf.hpp:62:13: error: non-const lvalue reference to type '__builtin_va_list' cannot bind to a value of unrelated type 'va_list' (aka 'std::__va_list') va_end( args ); ^~~~ /usr/include/sys/_stdarg.h:51:40: note: expanded from macro 'va_end' #define va_end(ap) __builtin_va_end(ap) ^~ Reported by: pkg-fallout
-rw-r--r--emulators/yuzu/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index 2120adb7a9f8..2893a43c7aea 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -69,6 +69,7 @@ USE_SDL= sdl2
CMAKE_ON= Boost_USE_STATIC_LIBS
CMAKE_ON+= BUNDLE_SPEEX # only used by cubeb tests
CMAKE_OFF= YUZU_CHECK_SUBMODULES YUZU_USE_EXTERNAL_SDL2 YUZU_USE_EXTERNAL_VULKAN_HEADERS
+CMAKE_OFF+= ${ARCH:Maarch64:C/.+/YUZU_USE_PRECOMPILED_HEADERS DYNARMIC_USE_PRECOMPILED_HEADERS/}
CMAKE_OFF+= ${CMAKE_TESTING_ON}
CMAKE_TESTING_ON= YUZU_TESTS
LDFLAGS+= -Wl,--as-needed # Qt5Network