aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@freebsd.org>2023-02-03 14:58:16 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2023-02-03 14:58:16 +0000
commitf9ba0a00fccc399026105c4eb125ced955d40b47 (patch)
tree1f3f5a5d258c3934c40c3a5cd1243cf27c8c340d
parentc4527d109e86fd079874816d9b4f23e3bdfa9363 (diff)
downloadports-f9ba0a00fccc399026105c4eb125ced955d40b47.tar.gz
ports-f9ba0a00fccc399026105c4eb125ced955d40b47.zip
www/gitlab-pages: simplify Makefile
Remove custom targets, just pulling go.mk directly from gitlab.com is enough and targets provided by go.mk work fine here. PR: 269303
-rw-r--r--www/gitlab-pages/Makefile26
1 files changed, 3 insertions, 23 deletions
diff --git a/www/gitlab-pages/Makefile b/www/gitlab-pages/Makefile
index da241eeec460..c767ea0dd08b 100644
--- a/www/gitlab-pages/Makefile
+++ b/www/gitlab-pages/Makefile
@@ -1,8 +1,10 @@
PORTNAME= gitlab-pages
PORTVERSION= 15.8.1
-PORTREVISION= 1
DISTVERSIONPREFIX= v
+PORTREVISION= 2
CATEGORIES= www
+MASTER_SITES+= https://gitlab.com/gitlab-org/gitlab-pages/-/raw/v${DISTVERSION}/
+DISTFILES+= go.mod
MAINTAINER= swills@FreeBSD.org
COMMENT= Official GitLab Pages daemon
@@ -19,25 +21,6 @@ GL_ACCOUNT= gitlab-org
# Find this here: https://gitlab.com/gitlab-org/gitlab-pages/-/tags/
GL_COMMIT= 345ed7982842b70a17aed0b08dcee21af78b30df
-# for go dependencies
-# Gitlab hosts there dependencies on their own platform and not on go-proxy
-# so we download the required go.mod file from gitlab
-# lines are taken from go.mk
-# ---------------------------
-FETCH_DEPENDS= ${GO_CMD}:${GO_PORT} \
- ca_root_nss>0:security/ca_root_nss
-MASTER_SITES+= https://gitlab.com/gitlab-org/gitlab-pages/-/raw/v${DISTVERSION}/
-DISTFILES+= go.mod
-DIST_SUBDIR= go/${PKGORIGIN:S,/,_,g}/${DISTNAME}
-EXTRACT_ONLY+= ${DISTFILES:N*.mod\:*:N*.mod:C/:.*//}
-_USES_fetch+= 900:go-post-fetch-gitlab
-go-post-fetch-gitlab:
- @${ECHO_MSG} "===> Fetching ${PORTNAME} dependencies";
- @(cd ${DISTDIR}/${DIST_SUBDIR}; \
- [ -e go.mod ] || ${RLN} ${GO_MODFILE} go.mod; \
- ${SETENV} ${GO_ENV} GOPROXY=${GO_GOPROXY} ${GO_CMD} mod download -x all)
-# ---------------------------
-
GO_BUILDFLAGS= -ldflags="-X 'main.VERSION=${PORTVERSION}' -X 'main.REVISION=${GL_COMMIT}'"
PLIST_FILES= bin/gitlab-pages
@@ -47,7 +30,4 @@ USE_RC_SUBR= gitlab_pages
USERS= gitlab-pages
GROUPS= gitlab-pages
-do-install:
- ${INSTALL_PROGRAM} ${WRKDIR}/bin/gitlab-pages ${STAGEDIR}${PREFIX}/bin/gitlab-pages
-
.include <bsd.port.mk>