aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-04-25 20:56:30 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-04-27 00:24:51 +0000
commitf9c701cefcb495b3b0788092dbd18b24f4185548 (patch)
treec7ad08f7cc22bae78e843fff83dd7f8c3628e880
parent693bcfe3c2e4feb0d0544c5e4de6ea90472f75f1 (diff)
downloadports-f9c701cefcb495b3b0788092dbd18b24f4185548.tar.gz
ports-f9c701cefcb495b3b0788092dbd18b24f4185548.zip
accessibility/wlsunset: update to 0.2.0
-rw-r--r--accessibility/wlsunset/Makefile7
-rw-r--r--accessibility/wlsunset/distinfo14
-rw-r--r--accessibility/wlsunset/files/patch-main.c17
3 files changed, 21 insertions, 17 deletions
diff --git a/accessibility/wlsunset/Makefile b/accessibility/wlsunset/Makefile
index 4e962920042d..b1031bc80a9c 100644
--- a/accessibility/wlsunset/Makefile
+++ b/accessibility/wlsunset/Makefile
@@ -1,13 +1,8 @@
PORTNAME= wlsunset
-DISTVERSION= 0.1.0
+DISTVERSION= 0.2.0
CATEGORIES= accessibility
MASTER_SITES= https://git.sr.ht/~kennylevinsen/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
-PATCH_SITES= https://git.sr.ht/~kennylevinsen/${PORTNAME}/commit/
-PATCHFILES+= fa2bd4425314.patch:-p1 33c64bc929b2.patch:-p1 # manpage
-PATCHFILES+= ec0c1614af21.patch:-p1 # avoid USES=localbase
-PATCHFILES+= 49ad3ce7a8e8.patch:-p1 # unbreak Clang >= 10
-
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Day/night gamma adjustments for Wayland
diff --git a/accessibility/wlsunset/distinfo b/accessibility/wlsunset/distinfo
index 7dea638c9c25..7915d307505e 100644
--- a/accessibility/wlsunset/distinfo
+++ b/accessibility/wlsunset/distinfo
@@ -1,11 +1,3 @@
-TIMESTAMP = 1603237309
-SHA256 (wlsunset-0.1.0.tar.gz) = d9a20744be6a5ef7fceb4e97e831a5c8cec77a95fb8248744ec1e674da3bbe71
-SIZE (wlsunset-0.1.0.tar.gz) = 10927
-SHA256 (fa2bd4425314.patch) = 96ce10ee08adba006797683bb96468796a44a2b4ab07d668c9ca5778f9740e39
-SIZE (fa2bd4425314.patch) = 2634
-SHA256 (33c64bc929b2.patch) = fdb112f99f43fc4f2984a53d6474d616bf99c3fbbf802c7c3378fd98f9a78ee1
-SIZE (33c64bc929b2.patch) = 971
-SHA256 (ec0c1614af21.patch) = 9912020085fe3c5ebaf90684542e379b82a80c07f4bc060a9325cd2eb97ae7af
-SIZE (ec0c1614af21.patch) = 1450
-SHA256 (49ad3ce7a8e8.patch) = f3cbefd2cb3ba70b198eddafdc792f1bac46192f9f0f01eb956e55cc4dda12c9
-SIZE (49ad3ce7a8e8.patch) = 970
+TIMESTAMP = 1619384190
+SHA256 (wlsunset-0.2.0.tar.gz) = 88bce695722a09d79545f14d404cc0659f7176bb08d5db5f4f23228b6ba8bb03
+SIZE (wlsunset-0.2.0.tar.gz) = 12605
diff --git a/accessibility/wlsunset/files/patch-main.c b/accessibility/wlsunset/files/patch-main.c
new file mode 100644
index 000000000000..f8c592112448
--- /dev/null
+++ b/accessibility/wlsunset/files/patch-main.c
@@ -0,0 +1,17 @@
+Unbreak on FreeBSD after https://git.sr.ht/~kennylevinsen/wlsunset/commit/111181106e41
+See also https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=24590
+
+main.c:710:47: error: use of undeclared identifier 'timezone'
+ *time = tm.tm_hour * 3600 + tm.tm_min * 60 + timezone;
+
+--- main.c.orig 2021-04-25 20:56:30 UTC
++++ main.c
+@@ -707,7 +707,7 @@ static int parse_time_of_day(const char *s, time_t *ti
+ if (strptime(s, "%H:%M", &tm) == NULL) {
+ return -1;
+ }
+- *time = tm.tm_hour * 3600 + tm.tm_min * 60 + timezone;
++ *time = tm.tm_hour * 3600 + tm.tm_min * 60 + tm.tm_gmtoff;
+ return 0;
+ }
+