aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2022-09-30 20:01:40 +0000
committerRene Ladan <rene@FreeBSD.org>2022-09-30 20:06:28 +0000
commitf9f811816c9a50a19570ef4ee66dc6e3f43baec5 (patch)
tree6c5d3bd3f87bd69922bbd6802bfc83fefcb205d9
parent642838c92c58af3a4bdd30740b289fa2e06f5ec3 (diff)
downloadports-f9f811816c9a50a19570ef4ee66dc6e3f43baec5.tar.gz
ports-f9f811816c9a50a19570ef4ee66dc6e3f43baec5.zip
all: deprecate ports depending on expired security/py-keyrings.alt
-rw-r--r--biology/py-orange3-bioinformatics/Makefile3
-rw-r--r--biology/py-orange3-single-cell/Makefile3
-rw-r--r--misc/orange3/Makefile3
-rw-r--r--misc/py-orange3-associate/Makefile3
-rw-r--r--misc/py-orange3-datafusion/Makefile3
-rw-r--r--misc/py-orange3-educational/Makefile3
-rw-r--r--misc/py-orange3-network/Makefile3
-rw-r--r--misc/py-orange3-timeseries/Makefile3
-rw-r--r--textproc/py-orange3-text/Makefile3
9 files changed, 27 insertions, 0 deletions
diff --git a/biology/py-orange3-bioinformatics/Makefile b/biology/py-orange3-bioinformatics/Makefile
index 7b97466250ce..714eb7e79afb 100644
--- a/biology/py-orange3-bioinformatics/Makefile
+++ b/biology/py-orange3-bioinformatics/Makefile
@@ -12,6 +12,9 @@ WWW= https://github.com/biolab/orange3-bioinformatics
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Depends on expired security/py-keyrings.alt (via msic/orange3)
+EXPIRATION_DATE=2022-12-31
+
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR}
RUN_DEPENDS= orange3>0:misc/orange3 \
${PYTHON_PKGNAMEPREFIX}Genesis-PyAPI>0:biology/py-Genesis-PyAPI@${PY_FLAVOR} \
diff --git a/biology/py-orange3-single-cell/Makefile b/biology/py-orange3-single-cell/Makefile
index fa04f5481e29..a2fd06f80fc4 100644
--- a/biology/py-orange3-single-cell/Makefile
+++ b/biology/py-orange3-single-cell/Makefile
@@ -10,6 +10,9 @@ WWW= https://singlecell.biolab.si/
LICENSE= AGPLv3+
+DEPRECATED= Depends on expired security/py-keyrings.alt (via msic/orange3)
+EXPIRATION_DATE=2022-12-31
+
RUN_DEPENDS= orange3>0:misc/orange3 \
${PYTHON_PKGNAMEPREFIX}orange3-bioinformatics>0:biology/py-orange3-bioinformatics@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}astropy>0:astro/py-astropy@${PY_FLAVOR} \
diff --git a/misc/orange3/Makefile b/misc/orange3/Makefile
index bcf432b6e8ee..98bd9bc21df2 100644
--- a/misc/orange3/Makefile
+++ b/misc/orange3/Makefile
@@ -9,6 +9,9 @@ WWW= https://orange.biolab.si/
LICENSE= GPLv3
+DEPRECATED= Depends on expired security/py-keyrings.alt
+EXPIRATION_DATE=2022-12-31
+
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}AnyQt>=0.0.11:x11-toolkits/py-AnyQt@${PY_FLAVOR} \
diff --git a/misc/py-orange3-associate/Makefile b/misc/py-orange3-associate/Makefile
index 9239fbf85c5a..bc725546e585 100644
--- a/misc/py-orange3-associate/Makefile
+++ b/misc/py-orange3-associate/Makefile
@@ -9,6 +9,9 @@ WWW= https://github.com/biolab/orange3-associate
LICENSE= GPLv3+
+DEPRECATED= Depends on expired security/py-keyrings.alt (via msic/orange3)
+EXPIRATION_DATE=2022-12-31
+
RUN_DEPENDS= orange3>0:misc/orange3 \
${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
diff --git a/misc/py-orange3-datafusion/Makefile b/misc/py-orange3-datafusion/Makefile
index 31b34f88f861..7836734602e9 100644
--- a/misc/py-orange3-datafusion/Makefile
+++ b/misc/py-orange3-datafusion/Makefile
@@ -12,6 +12,9 @@ WWW= https://github.com/biolab/orange3-datafusion
LICENSE= GPLv3
+DEPRECATED= Depends on expired security/py-keyrings.alt (via msic/orange3)
+EXPIRATION_DATE=2022-12-31
+
RUN_DEPENDS= orange3>0:misc/orange3 \
${PYTHON_PKGNAMEPREFIX}scikit-fusion>0:misc/py-scikit-fusion@${PY_FLAVOR}
diff --git a/misc/py-orange3-educational/Makefile b/misc/py-orange3-educational/Makefile
index fc8fefdf633f..c930bbf451b7 100644
--- a/misc/py-orange3-educational/Makefile
+++ b/misc/py-orange3-educational/Makefile
@@ -10,6 +10,9 @@ WWW= https://github.com/biolab/orange3-educational
LICENSE= CC-BY-3.0
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Depends on expired security/py-keyrings.alt (via msic/orange3)
+EXPIRATION_DATE=2022-12-31
+
RUN_DEPENDS= orange3>0:misc/orange3 \
${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}beautifulsoup>0:www/py-beautifulsoup@${PY_FLAVOR}
diff --git a/misc/py-orange3-network/Makefile b/misc/py-orange3-network/Makefile
index 45f24ee498c7..2fee1ad313b1 100644
--- a/misc/py-orange3-network/Makefile
+++ b/misc/py-orange3-network/Makefile
@@ -10,6 +10,9 @@ WWW= https://github.com/biolab/orange3-network
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= Depends on expired security/py-keyrings.alt (via msic/orange3)
+EXPIRATION_DATE=2022-12-31
+
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= orange3>0:misc/orange3 \
${PYNUMPY} \
diff --git a/misc/py-orange3-timeseries/Makefile b/misc/py-orange3-timeseries/Makefile
index 578a215cc116..3f62fc529872 100644
--- a/misc/py-orange3-timeseries/Makefile
+++ b/misc/py-orange3-timeseries/Makefile
@@ -10,6 +10,9 @@ WWW= https://github.com/biolab/orange3-timeseries
LICENSE= CC-BY-3.0
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Depends on expired security/py-keyrings.alt (via msic/orange3)
+EXPIRATION_DATE=2022-12-31
+
RUN_DEPENDS= orange3>0:misc/orange3 \
${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}more-itertools>0:devel/py-more-itertools@${PY_FLAVOR} \
diff --git a/textproc/py-orange3-text/Makefile b/textproc/py-orange3-text/Makefile
index e2b4093bcd37..fc2ea5c31da3 100644
--- a/textproc/py-orange3-text/Makefile
+++ b/textproc/py-orange3-text/Makefile
@@ -9,6 +9,9 @@ WWW= https://github.com/biolab/orange3-text
LICENSE= AGPLv3
+DEPRECATED= Depends on expired security/py-keyrings.alt (via msic/orange3)
+EXPIRATION_DATE=2022-12-31
+
RUN_DEPENDS= orange3>0:misc/orange3 \
${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}beautifulsoup>0:www/py-beautifulsoup@${PY_FLAVOR} \