aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-06-12 06:09:12 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-06-12 06:09:36 +0000
commitfa639e45c6bc997148e2f727ca6c263091896217 (patch)
treeaac13c539473253a0bb5c38308d384f9a87a3884
parent3b0aaa83361a9dcae60b94c711370d1496b5e956 (diff)
downloadports-fa639e45c6bc997148e2f727ca6c263091896217.tar.gz
ports-fa639e45c6bc997148e2f727ca6c263091896217.zip
devel/smooth: new port had been added (+)
smooth is an object-oriented C++ class library for Windows, macOS, and most Unix-like operating systems. It provides basic functionality and platform support for applications and libraries. WWW: http://www.smooth-project.org/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/smooth/Makefile31
-rw-r--r--devel/smooth/distinfo3
-rw-r--r--devel/smooth/files/patch-Makefile29
-rw-r--r--devel/smooth/files/patch-classes_graphics_backends_cairo_fontcairo.cpp24
-rw-r--r--devel/smooth/files/patch-classes_gui_window_backends_xlib_windowxlib.cpp22
-rw-r--r--devel/smooth/pkg-descr13
-rw-r--r--devel/smooth/pkg-plist277
8 files changed, 400 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 99d9cdb74600..fed4749fcc13 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6827,6 +6827,7 @@
SUBDIR += slibtool
SUBDIR += smake
SUBDIR += smc
+ SUBDIR += smooth
SUBDIR += smv
SUBDIR += soapui
SUBDIR += sobjectizer
diff --git a/devel/smooth/Makefile b/devel/smooth/Makefile
new file mode 100644
index 000000000000..d6f9124e45e2
--- /dev/null
+++ b/devel/smooth/Makefile
@@ -0,0 +1,31 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+
+PORTNAME= smooth
+PORTVERSION= 0.9.7
+CATEGORIES= devel
+MASTER_SITES= SF
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Object-oriented class library
+
+LICENSE= ART20
+
+LIB_DEPENDS= libcpuid.so:sysutils/libcpuid \
+ libcurl.so:ftp/curl \
+ libfribidi.so:converters/fribidi \
+ libharfbuzz.so:print/harfbuzz \
+ libpng.so:graphics/png
+
+USES= gmake gnome iconv jpeg localbase pkgconfig xorg
+USE_LDCONFIG= yes
+USE_GNOME= cairo gdkpixbuf2 gtk30 libxml2
+USE_XORG= x11
+MAKE_ARGS= config=systemlibcpuid
+
+post-extract:
+# Prevent accidental build/use of bundled libraries' code/headers
+ @${RM} -r ${WRKSRC}/libraries/fribidi ${WRKSRC}/libraries/lib* \
+ ${WRKSRC}/libraries/v8 ${WRKSRC}/libraries/zlib
+ @${RM} -r ${WRKSRC}/include/support
+
+.include <bsd.port.mk>
diff --git a/devel/smooth/distinfo b/devel/smooth/distinfo
new file mode 100644
index 000000000000..ca270dab97a2
--- /dev/null
+++ b/devel/smooth/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1613312458
+SHA256 (smooth-0.9.7.tar.gz) = bc00a5e5650895eef629d9e4aa0c32e7438552798f1d40624498a9a116d2411d
+SIZE (smooth-0.9.7.tar.gz) = 8084875
diff --git a/devel/smooth/files/patch-Makefile b/devel/smooth/files/patch-Makefile
new file mode 100644
index 000000000000..a22e158abc56
--- /dev/null
+++ b/devel/smooth/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- Makefile.orig 2020-11-01 17:03:01 UTC
++++ Makefile
+@@ -129,7 +129,7 @@ endif
+
+ ### Output options ###
+
+-LIBS = -lstdc++
++LIBS += -lX11 -lm
+
+ ifeq ($(USE_BUNDLED_LIBBZ2),True)
+ LIBS += $(LIBDIR)/libbz2.a
+@@ -298,7 +298,7 @@ ifneq ($(BUILD_WIN32),True)
+ $(INSTALL) -d "$(DESTDIR)"$(libdir)
+
+ ifneq ($(BUILD_OSX),True)
+- $(INSTALL_DATA) $(DLLNAME) "$(DESTDIR)"$(libdir)/libsmooth-$(VERSION)$(SHARED).$(REVISION)
++ $(BSD_INSTALL_LIB) $(DLLNAME) "$(DESTDIR)"$(libdir)/libsmooth-$(VERSION)$(SHARED).$(REVISION)
+ $(LINK) -fs libsmooth-$(VERSION)$(SHARED).$(REVISION) "$(DESTDIR)"$(libdir)/libsmooth-$(VERSION)$(SHARED)
+
+ ifeq ($(BUILD_V8),True)
+@@ -324,7 +324,7 @@ endif
+ endif
+
+ $(INSTALL) -d "$(DESTDIR)"$(bindir)
+- $(INSTALL_PROGRAM) $(BINDIR)/translator "$(DESTDIR)"$(bindir)/smooth-translator
++ $(BSD_INSTALL_PROGRAM) $(BINDIR)/translator "$(DESTDIR)"$(bindir)/smooth-translator
+
+ $(INSTALL) -d "$(DESTDIR)"$(includedir)
+ $(COPY) -r "$(SRCDIR)"/include/smooth "$(DESTDIR)"$(includedir)
diff --git a/devel/smooth/files/patch-classes_graphics_backends_cairo_fontcairo.cpp b/devel/smooth/files/patch-classes_graphics_backends_cairo_fontcairo.cpp
new file mode 100644
index 000000000000..d9d36f69751f
--- /dev/null
+++ b/devel/smooth/files/patch-classes_graphics_backends_cairo_fontcairo.cpp
@@ -0,0 +1,24 @@
+--- classes/graphics/backends/cairo/fontcairo.cpp.orig 2020-06-13 21:01:13 UTC
++++ classes/graphics/backends/cairo/fontcairo.cpp
+@@ -8,6 +8,10 @@
+ * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+ * WARRANTIES OF MERCHANTIBILITY AND FITNESS FOR A PARTICULAR PURPOSE. */
+
++#include <stdio.h>
++#include <stdlib.h>
++#include <unistd.h>
++
+ #include <smooth/graphics/backends/cairo/fontcairo.h>
+ #include <smooth/graphics/surface.h>
+ #include <smooth/files/file.h>
+@@ -15,10 +19,6 @@
+ #include <smooth/init.h>
+
+ using namespace X11;
+-
+-#include <unistd.h>
+-#include <stdio.h>
+-#include <stdlib.h>
+
+ #include <cairo/cairo-xlib.h>
+ #include <pango/pangocairo.h>
diff --git a/devel/smooth/files/patch-classes_gui_window_backends_xlib_windowxlib.cpp b/devel/smooth/files/patch-classes_gui_window_backends_xlib_windowxlib.cpp
new file mode 100644
index 000000000000..86fe2cee1a5e
--- /dev/null
+++ b/devel/smooth/files/patch-classes_gui_window_backends_xlib_windowxlib.cpp
@@ -0,0 +1,22 @@
+--- classes/gui/window/backends/xlib/windowxlib.cpp.orig 2020-08-27 22:43:07 UTC
++++ classes/gui/window/backends/xlib/windowxlib.cpp
+@@ -8,6 +8,9 @@
+ * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+ * WARRANTIES OF MERCHANTIBILITY AND FITNESS FOR A PARTICULAR PURPOSE. */
+
++#include <stdio.h>
++#include <stdlib.h>
++
+ #include <smooth/gui/window/backends/xlib/windowxlib.h>
+ #include <smooth/gui/window/window.h>
+ #include <smooth/gui/widgets/special/cursor.h>
+@@ -20,9 +23,6 @@
+ #include <smooth/foreach.h>
+ #include <smooth/init.h>
+ #include <smooth/backends/xlib/backendxlib.h>
+-
+-#include <stdio.h>
+-#include <stdlib.h>
+
+ using namespace X11;
+
diff --git a/devel/smooth/pkg-descr b/devel/smooth/pkg-descr
new file mode 100644
index 000000000000..39945674f361
--- /dev/null
+++ b/devel/smooth/pkg-descr
@@ -0,0 +1,13 @@
+smooth is an object-oriented C++ class library for Windows, macOS, and
+most Unix-like operating systems. It provides basic functionality and
+platform support for applications and libraries.
+
+Features provided by smooth include:
+
+ - User interface API with various widgets
+ - Simple to use multithreading API
+ - File and network I/O interface
+ - Unicode and internationalization support
+ - Libxml2-based XML parser
+
+WWW: http://www.smooth-project.org/
diff --git a/devel/smooth/pkg-plist b/devel/smooth/pkg-plist
new file mode 100644
index 000000000000..2c3679df6ed2
--- /dev/null
+++ b/devel/smooth/pkg-plist
@@ -0,0 +1,277 @@
+bin/smooth-translator
+include/smooth.h
+include/smooth/args.h
+include/smooth/backends/backend.h
+include/smooth/backends/cocoa/backendcocoa.h
+include/smooth/backends/gdiplus/backendgdiplus.h
+include/smooth/backends/haiku/backendhaiku.h
+include/smooth/backends/win32/backendwin32.h
+include/smooth/backends/xlib/backendxlib.h
+include/smooth/basic/object.h
+include/smooth/basic/objecttype.h
+include/smooth/basic/setup.h
+include/smooth/definitions.h
+include/smooth/definitions.unix.h
+include/smooth/definitions.win32.h
+include/smooth/dll.h
+include/smooth/errors/error.h
+include/smooth/errors/fs/endoffile.h
+include/smooth/errors/fs/filenotfound.h
+include/smooth/errors/misc/permissiondenied.h
+include/smooth/errors/success.h
+include/smooth/files/directory.h
+include/smooth/files/file.h
+include/smooth/foreach.h
+include/smooth/graphics/backends/bitmapbackend.h
+include/smooth/graphics/backends/cairo/fontcairo.h
+include/smooth/graphics/backends/cairo/surfacecairo.h
+include/smooth/graphics/backends/cocoa/bitmapcocoa.h
+include/smooth/graphics/backends/cocoa/fontcocoa.h
+include/smooth/graphics/backends/cocoa/surfacecocoa.h
+include/smooth/graphics/backends/fontbackend.h
+include/smooth/graphics/backends/gdi/bitmapgdi.h
+include/smooth/graphics/backends/gdi/fontgdi.h
+include/smooth/graphics/backends/gdi/surfacegdi.h
+include/smooth/graphics/backends/gdiplus/bitmapgdiplus.h
+include/smooth/graphics/backends/gdiplus/fontgdiplus.h
+include/smooth/graphics/backends/gdiplus/surfacegdiplus.h
+include/smooth/graphics/backends/haiku/bitmaphaiku.h
+include/smooth/graphics/backends/haiku/fonthaiku.h
+include/smooth/graphics/backends/haiku/surfacehaiku.h
+include/smooth/graphics/backends/surfacebackend.h
+include/smooth/graphics/backends/xlib/bitmapxlib.h
+include/smooth/graphics/backends/xlib/fontxlib.h
+include/smooth/graphics/backends/xlib/surfacexlib.h
+include/smooth/graphics/bitmap.h
+include/smooth/graphics/color.h
+include/smooth/graphics/font.h
+include/smooth/graphics/forms/line.h
+include/smooth/graphics/forms/point.h
+include/smooth/graphics/forms/rect.h
+include/smooth/graphics/forms/size.h
+include/smooth/graphics/imageloader/icon.h
+include/smooth/graphics/imageloader/imageloader.h
+include/smooth/graphics/imageloader/jpeg.h
+include/smooth/graphics/imageloader/pci.h
+include/smooth/graphics/imageloader/png.h
+include/smooth/graphics/modifiers/fontsize.h
+include/smooth/graphics/modifiers/righttoleft.h
+include/smooth/graphics/surface.h
+include/smooth/gui/application/application.h
+include/smooth/gui/application/xulloader.h
+include/smooth/gui/clipboard/backends/clipboardbackend.h
+include/smooth/gui/clipboard/backends/cocoa/clipboardcocoa.h
+include/smooth/gui/clipboard/backends/haiku/clipboardhaiku.h
+include/smooth/gui/clipboard/backends/win32/clipboardwin32.h
+include/smooth/gui/clipboard/backends/xlib/clipboardxlib.h
+include/smooth/gui/clipboard/clipboard.h
+include/smooth/gui/dialogs/colordlg.h
+include/smooth/gui/dialogs/dialog.h
+include/smooth/gui/dialogs/dirdlg.h
+include/smooth/gui/dialogs/filedlg.h
+include/smooth/gui/dialogs/fontdlg.h
+include/smooth/gui/dialogs/icons/light.h
+include/smooth/gui/dialogs/messagebox.h
+include/smooth/gui/dialogs/splashscreen.h
+include/smooth/gui/dialogs/tipodaydlg.h
+include/smooth/gui/widgets/basic/activearea.h
+include/smooth/gui/widgets/basic/arrows.h
+include/smooth/gui/widgets/basic/button.h
+include/smooth/gui/widgets/basic/checkbox.h
+include/smooth/gui/widgets/basic/client.h
+include/smooth/gui/widgets/basic/divider.h
+include/smooth/gui/widgets/basic/editbox.h
+include/smooth/gui/widgets/basic/groupbox.h
+include/smooth/gui/widgets/basic/hyperlink.h
+include/smooth/gui/widgets/basic/image.h
+include/smooth/gui/widgets/basic/multiedit.h
+include/smooth/gui/widgets/basic/optionbox.h
+include/smooth/gui/widgets/basic/progressbar.h
+include/smooth/gui/widgets/basic/scrollbar.h
+include/smooth/gui/widgets/basic/slider.h
+include/smooth/gui/widgets/basic/statusbar.h
+include/smooth/gui/widgets/basic/tabwidget.h
+include/smooth/gui/widgets/basic/text.h
+include/smooth/gui/widgets/basic/titlebar.h
+include/smooth/gui/widgets/hotspot/hotspot.h
+include/smooth/gui/widgets/hotspot/simplebutton.h
+include/smooth/gui/widgets/layer.h
+include/smooth/gui/widgets/multi/generic/container.h
+include/smooth/gui/widgets/multi/generic/entry.h
+include/smooth/gui/widgets/multi/image/imagebox.h
+include/smooth/gui/widgets/multi/image/imageentry.h
+include/smooth/gui/widgets/multi/list/combobox.h
+include/smooth/gui/widgets/multi/list/list.h
+include/smooth/gui/widgets/multi/list/listbox.h
+include/smooth/gui/widgets/multi/list/listboxheader.h
+include/smooth/gui/widgets/multi/list/listentry.h
+include/smooth/gui/widgets/multi/list/listentryseparator.h
+include/smooth/gui/widgets/multi/menu/menu.h
+include/smooth/gui/widgets/multi/menu/menubar.h
+include/smooth/gui/widgets/multi/menu/menubar_cocoa.h
+include/smooth/gui/widgets/multi/menu/menubarentry.h
+include/smooth/gui/widgets/multi/menu/menuentry.h
+include/smooth/gui/widgets/multi/menu/micromenu.h
+include/smooth/gui/widgets/multi/menu/popupmenu.h
+include/smooth/gui/widgets/multi/menu/popupmenuentry.h
+include/smooth/gui/widgets/multi/menu/popupmenuentrycheck.h
+include/smooth/gui/widgets/multi/menu/popupmenuentryoption.h
+include/smooth/gui/widgets/multi/tree/tree.h
+include/smooth/gui/widgets/special/cursor.h
+include/smooth/gui/widgets/special/dragcontrol.h
+include/smooth/gui/widgets/special/droparea.h
+include/smooth/gui/widgets/special/shortcut.h
+include/smooth/gui/widgets/special/tooltip.h
+include/smooth/gui/widgets/widget.h
+include/smooth/gui/window/backends/cocoa/windowcocoa.h
+include/smooth/gui/window/backends/gdi/droptarget.h
+include/smooth/gui/window/backends/gdi/windowgdi.h
+include/smooth/gui/window/backends/haiku/windowhaiku.h
+include/smooth/gui/window/backends/windowbackend.h
+include/smooth/gui/window/backends/xlib/windowxlib.h
+include/smooth/gui/window/toolwindow.h
+include/smooth/gui/window/window.h
+include/smooth/i18n/language.h
+include/smooth/i18n/number.h
+include/smooth/i18n/section.h
+include/smooth/i18n/translator.h
+include/smooth/i18n/translator_internal.h
+include/smooth/init.h
+include/smooth/init.win32.h
+include/smooth/input/backends/cocoa/pointercocoa.h
+include/smooth/input/backends/haiku/pointerhaiku.h
+include/smooth/input/backends/pointerbackend.h
+include/smooth/input/backends/win32/pointerwin32.h
+include/smooth/input/backends/xlib/pointerxlib.h
+include/smooth/input/keyboard.h
+include/smooth/input/pointer.h
+include/smooth/io/driver.h
+include/smooth/io/drivers/driver_ansi.h
+include/smooth/io/drivers/driver_https.h
+include/smooth/io/drivers/driver_memory.h
+include/smooth/io/drivers/driver_posix.h
+include/smooth/io/drivers/driver_socket.h
+include/smooth/io/drivers/driver_socks4.h
+include/smooth/io/drivers/driver_socks5.h
+include/smooth/io/drivers/driver_win32.h
+include/smooth/io/drivers/driver_zero.h
+include/smooth/io/filter.h
+include/smooth/io/filters/filter_bzip2.h
+include/smooth/io/filters/filter_xor.h
+include/smooth/io/instream.h
+include/smooth/io/io.h
+include/smooth/io/outstream.h
+include/smooth/io/stream.h
+include/smooth/main.h
+include/smooth/misc/args.h
+include/smooth/misc/array.h
+include/smooth/misc/binary.h
+include/smooth/misc/config.h
+include/smooth/misc/datetime.h
+include/smooth/misc/encoding/base64.h
+include/smooth/misc/encoding/urlencode.h
+include/smooth/misc/hash/crc16.h
+include/smooth/misc/hash/crc32.h
+include/smooth/misc/hash/crc64.h
+include/smooth/misc/hash/md5.h
+include/smooth/misc/hash/sha1.h
+include/smooth/misc/math.h
+include/smooth/misc/memory.h
+include/smooth/misc/number.h
+include/smooth/misc/string.h
+include/smooth/net/protocols/file.h
+include/smooth/net/protocols/http.h
+include/smooth/net/protocols/protocol.h
+include/smooth/pciio.h
+include/smooth/resources.h
+include/smooth/system/backends/cocoa/eventcocoa.h
+include/smooth/system/backends/cocoa/screencocoa.h
+include/smooth/system/backends/cocoa/timercocoa.h
+include/smooth/system/backends/eventbackend.h
+include/smooth/system/backends/haiku/eventhaiku.h
+include/smooth/system/backends/haiku/screenhaiku.h
+include/smooth/system/backends/haiku/timerhaiku.h
+include/smooth/system/backends/posix/timerposix.h
+include/smooth/system/backends/screenbackend.h
+include/smooth/system/backends/threads/timerthreads.h
+include/smooth/system/backends/timerbackend.h
+include/smooth/system/backends/win32/eventwin32.h
+include/smooth/system/backends/win32/screenwin32.h
+include/smooth/system/backends/win32/timerwin32.h
+include/smooth/system/backends/xlib/eventxlib.h
+include/smooth/system/backends/xlib/screenxlib.h
+include/smooth/system/console.h
+include/smooth/system/cpu.h
+include/smooth/system/dynamicloader.h
+include/smooth/system/event.h
+include/smooth/system/screen.h
+include/smooth/system/system.h
+include/smooth/system/timer.h
+include/smooth/templates/array.h
+include/smooth/templates/array/array.h
+include/smooth/templates/array/arraybackend.h
+include/smooth/templates/buffer.h
+include/smooth/templates/buffer/buffer.h
+include/smooth/templates/callbacks.h
+include/smooth/templates/iterator.h
+include/smooth/templates/iterator/iterator.h
+include/smooth/templates/nonblocking.h
+include/smooth/templates/nonblocking/caller.h
+include/smooth/templates/nonblocking/caller_base.h
+include/smooth/templates/nonblocking/nonblocking.h
+include/smooth/templates/nonblocking/nonblocking_base.h
+include/smooth/templates/signals.h
+include/smooth/templates/signals/callback.h
+include/smooth/templates/signals/signal.h
+include/smooth/templates/signals/signal_base.h
+include/smooth/templates/signals/signalr.h
+include/smooth/templates/signalsr.h
+include/smooth/templates/slots.h
+include/smooth/templates/slots/slot_base.h
+include/smooth/templates/slots/slot_class.h
+include/smooth/templates/slots/slot_global.h
+include/smooth/templates/slots/slot_signal.h
+include/smooth/templates/slots/slotr_base.h
+include/smooth/templates/slots/slotr_class.h
+include/smooth/templates/slots/slotr_global.h
+include/smooth/templates/slots/slotr_signal.h
+include/smooth/templates/slots/slotr_value.h
+include/smooth/templates/slotsr.h
+include/smooth/templates/threadlocal.h
+include/smooth/templates/threadlocal/threadlocal.h
+include/smooth/threads/access.h
+include/smooth/threads/backends/cocoa/threadcocoa.h
+include/smooth/threads/backends/mutexbackend.h
+include/smooth/threads/backends/posix/mutexposix.h
+include/smooth/threads/backends/posix/semaphoreposix.h
+include/smooth/threads/backends/posix/threadposix.h
+include/smooth/threads/backends/semaphorebackend.h
+include/smooth/threads/backends/threadbackend.h
+include/smooth/threads/backends/win32/mutexwin32.h
+include/smooth/threads/backends/win32/semaphorewin32.h
+include/smooth/threads/backends/win32/threadwin32.h
+include/smooth/threads/mutex.h
+include/smooth/threads/rwlock.h
+include/smooth/threads/semaphore.h
+include/smooth/threads/thread.h
+include/smooth/types/bool.h
+include/smooth/types/float.h
+include/smooth/types/generic.h
+include/smooth/types/int.h
+include/smooth/types/void.h
+include/smooth/version.h
+include/smooth/xml/attribute.h
+include/smooth/xml/document.h
+include/smooth/xml/node.h
+include/smooth/xml/xul/box.h
+include/smooth/xml/xul/button.h
+include/smooth/xml/xul/description.h
+include/smooth/xml/xul/label.h
+include/smooth/xml/xul/menubar.h
+include/smooth/xml/xul/popupmenu.h
+include/smooth/xml/xul/renderer.h
+include/smooth/xml/xul/textbox.h
+include/smooth/xml/xul/widget.h
+include/smooth/xml/xul/window.h
+lib/libsmooth-0.9.so
+lib/libsmooth-0.9.so.0