aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2022-04-30 08:29:45 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2022-05-03 08:00:26 +0000
commitfa6c86d28188b4310cacf3d8667d719284e7e34d (patch)
treebe4c9c647d0be0314ea437dd82a8fbff530ced65
parent9530e44de7503a0c6df93e64ae1b03016a7728ae (diff)
downloadports-fa6c86d28188b4310cacf3d8667d719284e7e34d.tar.gz
ports-fa6c86d28188b4310cacf3d8667d719284e7e34d.zip
*: Fix up PORTREVISION
Mostly just typos and assigning PORTREVISION multiple times. This commit doesn't fix up PORTREVISION between master-slave ports where the master port often overwrites PORTREVISION from the slaves which means the slaves don't actually get bumped. These probably just need PORTREVISION?= but care must be taken to not decrease the package versions of all the master-slave packages and to actually bump PORTREVISION as intended. For the record the currently visible broken master ports are: databases/libgda5 emulators/virtualbox-ose emulators/virtualbox-ose-legacy graphics/atril multimedia/mlt7 textproc/uim But all master ports should be looked at here and get an explicit PORTREVISION?= where it's currently missing to prevent this. Reported by: portscan
-rw-r--r--audio/libsidplayfp/Makefile2
-rw-r--r--cad/kicad-devel/Makefile2
-rw-r--r--databases/go-carbon/Makefile1
-rw-r--r--devel/py-pytest-relaxed/Makefile1
-rw-r--r--emulators/cingb/Makefile2
-rw-r--r--finance/fixc/Makefile1
-rw-r--r--security/ssllabs-scan/Makefile1
-rw-r--r--security/vaultwarden/Makefile1
-rw-r--r--sysutils/docker-machine/Makefile1
-rw-r--r--sysutils/docker/Makefile1
-rw-r--r--sysutils/sensu-go/Makefile1
-rw-r--r--x11-wm/fvwm3/Makefile1
12 files changed, 3 insertions, 12 deletions
diff --git a/audio/libsidplayfp/Makefile b/audio/libsidplayfp/Makefile
index d636cf232b84..58de8f7af7bb 100644
--- a/audio/libsidplayfp/Makefile
+++ b/audio/libsidplayfp/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libsidplayfp
DISTVERSION= 2.3.1
-PORTREVISON= 1
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index 5e7edd9afa88..a6894e91ebe7 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -2,7 +2,7 @@
PORTNAME= kicad
DISTVERSION= r${GIT_SRC_DATE}
-#PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= cad
PKGNAMESUFFIX= -devel
DIST_SUBDIR= ${PORTNAME}
diff --git a/databases/go-carbon/Makefile b/databases/go-carbon/Makefile
index c2a591fa76a6..c8a358707c7b 100644
--- a/databases/go-carbon/Makefile
+++ b/databases/go-carbon/Makefile
@@ -1,7 +1,6 @@
PORTNAME= go-carbon
DISTVERSIONPREFIX= v
DISTVERSION= 0.12.0
-PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= databases
diff --git a/devel/py-pytest-relaxed/Makefile b/devel/py-pytest-relaxed/Makefile
index 323f8f6a0618..759da178aadf 100644
--- a/devel/py-pytest-relaxed/Makefile
+++ b/devel/py-pytest-relaxed/Makefile
@@ -1,7 +1,6 @@
PORTNAME= pytest-relaxed
PORTVERSION= 1.1.5
PORTREVISION= 1
-PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/emulators/cingb/Makefile b/emulators/cingb/Makefile
index 9fb5b1d1e057..7d94593243dd 100644
--- a/emulators/cingb/Makefile
+++ b/emulators/cingb/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cingb
DISTVERSIONPREFIX= v
DISTVERSION= 0.32
-PORTREVISIO= 1
+PORTREVISION= 1
CATEGORIES= emulators
MAINTAINER= 0mp@FreeBSD.org
diff --git a/finance/fixc/Makefile b/finance/fixc/Makefile
index 5120ae41ebb6..81903398b6bb 100644
--- a/finance/fixc/Makefile
+++ b/finance/fixc/Makefile
@@ -1,7 +1,6 @@
PORTNAME= fixc
PORTVERSION= 1.2
DISTVERSIONPREFIX= v
-PORTREVISION= 1
PORTREVISION= 1
CATEGORIES= finance
diff --git a/security/ssllabs-scan/Makefile b/security/ssllabs-scan/Makefile
index 2fba6276bed7..e839044855b1 100644
--- a/security/ssllabs-scan/Makefile
+++ b/security/ssllabs-scan/Makefile
@@ -1,7 +1,6 @@
PORTNAME= ssllabs-scan
DISTVERSIONPREFIX= v
DISTVERSION= 1.5.0
-PORTREVISION= 1
PORTREVISION= 1
CATEGORIES= security net
diff --git a/security/vaultwarden/Makefile b/security/vaultwarden/Makefile
index ad46de739da4..c10edcd7f8e7 100644
--- a/security/vaultwarden/Makefile
+++ b/security/vaultwarden/Makefile
@@ -3,7 +3,6 @@
PORTNAME= vaultwarden
DISTVERSION= 1.24.0
PORTREVISION= 1
-#PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= https://github.com/dani-garcia/bw_web_builds/releases/download/v${DISTVERSION_WV}/:web
DISTFILES= ${WV_DISTFILE}:web
diff --git a/sysutils/docker-machine/Makefile b/sysutils/docker-machine/Makefile
index 08c0818aeb36..412ecae44b05 100644
--- a/sysutils/docker-machine/Makefile
+++ b/sysutils/docker-machine/Makefile
@@ -1,7 +1,6 @@
PORTNAME= docker-machine
PORTVERSION= 0.16.2
DISTVERSIONPREFIX= v
-PORTREVISION= 1
PORTREVISION= 1
CATEGORIES= sysutils
diff --git a/sysutils/docker/Makefile b/sysutils/docker/Makefile
index 6fef5dde9671..a0d3510df5bc 100644
--- a/sysutils/docker/Makefile
+++ b/sysutils/docker/Makefile
@@ -3,7 +3,6 @@
PORTNAME= docker
PORTVERSION= 18.09.5
DISTVERSIONPREFIX= v
-PORTREVISION= 1
PORTREVISION= 1
CATEGORIES= sysutils
diff --git a/sysutils/sensu-go/Makefile b/sysutils/sensu-go/Makefile
index 7f48f01111fc..1d680c070ef9 100644
--- a/sysutils/sensu-go/Makefile
+++ b/sysutils/sensu-go/Makefile
@@ -1,6 +1,5 @@
PORTNAME= sensu-go
DISTVERSION= 5.11.1
-PORTREVISION= 1
PORTREVISION= 1
CATEGORIES= sysutils
diff --git a/x11-wm/fvwm3/Makefile b/x11-wm/fvwm3/Makefile
index 49f013489533..1bc8b33f4e5b 100644
--- a/x11-wm/fvwm3/Makefile
+++ b/x11-wm/fvwm3/Makefile
@@ -26,7 +26,6 @@ CPE_VENDOR= fvwm
CPE_PRODUCT= fvwm
PLIST_SUB= PORTVERSION=${PORTVERSION}
-PORTREVISION= 1
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ac_cv_path_PYTHON=${PYTHON_CMD}