aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2023-11-24 08:52:53 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2023-11-24 08:52:53 +0000
commitfa7309cb976e3e73d59f271be3da01fee3006152 (patch)
treeb10e994472cb5c98e87c564bedfdbbc1bcd877f9
parent2dad037fe703e129875b11a85c59059fb8a4d8a3 (diff)
lang/clover: Restrict llvm to max version 16
Clover cannot (yet?) be compiled with LLVM17, it misses llvm/Transforms/IPO/PassManagerBuilder.h For now set a max version of llvm to 16 for clover only, people should still be able to use llvm17 for other mesa componant if they are not interested in clover. While here clean up a bit the USES=llvm for mesa port, we already set noexport in mesa-dri/Makefile.common so no need to set it in all the ports. Sponsored by: Beckhoff Automation GmbH & Co. KG PR: 275290
-rw-r--r--graphics/libosmesa/Makefile2
-rw-r--r--graphics/mesa-dri/Makefile2
-rw-r--r--graphics/mesa-gallium-va/Makefile2
-rw-r--r--graphics/mesa-gallium-vdpau/Makefile2
-rw-r--r--graphics/mesa-gallium-xa/Makefile2
-rw-r--r--lang/clover/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index 17a3660608b2..747e22dd8b46 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -10,7 +10,7 @@ LICENSE_FILE= ${WRKSRC}/docs/license.rst
LIB_DEPENDS+= libglapi.so:graphics/mesa-libs
-USES= llvm:lib,noexport xorg
+USES= llvm:lib xorg
USE_XORG= xorgproto
USE_LDCONFIG= yes
diff --git a/graphics/mesa-dri/Makefile b/graphics/mesa-dri/Makefile
index e309b1adf75f..4e79e3ef500c 100644
--- a/graphics/mesa-dri/Makefile
+++ b/graphics/mesa-dri/Makefile
@@ -8,7 +8,7 @@ WWW= https://www.mesa3d.org/
LIB_DEPENDS+= libglapi.so:graphics/mesa-libs
-USES+= llvm:lib,noexport
+USES+= llvm:lib
OPTIONS_GROUP= PLATFORM
OPTIONS_GROUP_PLATFORM= PLATFORM_X11 PLATFORM_WAYLAND
diff --git a/graphics/mesa-gallium-va/Makefile b/graphics/mesa-gallium-va/Makefile
index 91a565557ce9..78ef35b95012 100644
--- a/graphics/mesa-gallium-va/Makefile
+++ b/graphics/mesa-gallium-va/Makefile
@@ -15,7 +15,7 @@ ONLY_FOR_ARCHS_REASON= used only by AMD/Radeon hardware
LIB_DEPENDS= libva.so:multimedia/libva \
libzstd.so:archivers/zstd
-USES= llvm:lib,noexport
+USES= llvm:lib
OPTIONS_DEFINE= X11
OPTIONS_DEFAULT= X11
diff --git a/graphics/mesa-gallium-vdpau/Makefile b/graphics/mesa-gallium-vdpau/Makefile
index 43cf846da711..07fc35d0c0ff 100644
--- a/graphics/mesa-gallium-vdpau/Makefile
+++ b/graphics/mesa-gallium-vdpau/Makefile
@@ -15,7 +15,7 @@ ONLY_FOR_ARCHS_REASON= used only by AMD/Radeon hardware
LIB_DEPENDS= libvdpau.so:multimedia/libvdpau \
libzstd.so:archivers/zstd
-USES= llvm:lib,noexport
+USES= llvm:lib
OPTIONS_DEFINE= X11
OPTIONS_DEFAULT= X11
diff --git a/graphics/mesa-gallium-xa/Makefile b/graphics/mesa-gallium-xa/Makefile
index 72d13b41fa26..5ec8474145e9 100644
--- a/graphics/mesa-gallium-xa/Makefile
+++ b/graphics/mesa-gallium-xa/Makefile
@@ -11,7 +11,7 @@ LICENSE_FILE= ${WRKSRC}/docs/license.rst
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= used only by VMware supported architectures
-USES= llvm:lib,noexport xorg
+USES= llvm:lib xorg
USE_XORG= xorgproto
.include <bsd.port.options.mk>
diff --git a/lang/clover/Makefile b/lang/clover/Makefile
index 6c3c00ef1ad5..e083b4b8a006 100644
--- a/lang/clover/Makefile
+++ b/lang/clover/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libOpenCL.so:devel/ocl-icd \
RUN_DEPENDS= libclc>=0.3.0:devel/libclc \
opencl>=0:devel/opencl
-USES= llvm:lib,noexport
+USES= llvm:lib,max=16
.include <bsd.port.options.mk>
.include "${.CURDIR:H:H}/graphics/mesa-dri/Makefile.common"