aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2021-09-22 15:35:03 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2021-09-23 19:42:07 +0000
commitfa814a6e9e3d770ffec356a07b3ed381a2e385b0 (patch)
tree9c6d93ce7ee001da3ad923724bb578661c340c42
parent79df51b0bec6cb08deb0a453b68dd8381178c9ca (diff)
downloadports-fa814a6e9e3d770ffec356a07b3ed381a2e385b0.tar.gz
ports-fa814a6e9e3d770ffec356a07b3ed381a2e385b0.zip
www/gitlab-ce: Update to 14.3.0
-rw-r--r--www/gitlab-ce/Makefile35
-rw-r--r--www/gitlab-ce/distinfo6
-rw-r--r--www/gitlab-ce/files/patch-Gemfile23
-rw-r--r--www/gitlab-ce/files/patch-bin_background__jobs__sk20
-rw-r--r--www/gitlab-ce/files/patch-config_gitlab.yml.example12
-rw-r--r--www/gitlab-ce/files/patch-config_initializers_1__settings.rb4
-rw-r--r--www/gitlab-ce/pkg-message4
7 files changed, 47 insertions, 57 deletions
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index cec7d2d28622..3fec018b727c 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -1,8 +1,8 @@
# Created by: Torsten Zuehlsdorff <tz@FreeBSD.org>
PORTNAME= gitlab-ce
-PORTVERSION= 14.2.2
-PORTREVISION= 1
+PORTVERSION= 14.3.0
+PORTREVISION= 0
CATEGORIES= www devel
MAINTAINER= mfechner@FreeBSD.org
@@ -16,9 +16,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
MY_DEPENDS= git>=2.32.0:devel/git \
gitaly>=${PORTVERSION}:devel/gitaly \
gitlab-elasticsearch-indexer>=2.13.0:textproc/gitlab-elasticsearch-indexer \
- gitlab-agent>=14.2.2:net/gitlab-agent \
- gitlab-pages>=1.42.0:www/gitlab-pages \
- gitlab-shell>=13.19.1:devel/gitlab-shell \
+ gitlab-agent>=14.3.2:net/gitlab-agent \
+ gitlab-pages>=1.44.0:www/gitlab-pages \
+ gitlab-shell>=13.21.0:devel/gitlab-shell \
gitlab-workhorse>=${PORTVERSION}:www/gitlab-workhorse \
redis>=6.0.14:databases/redis \
yarn>=1.10.0:www/yarn \
@@ -31,7 +31,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-default_value_for>=3.4.0<3.5.0:devel/rubygem-default_value_for \
rubygem-pg>=1.2.3<2:databases/rubygem-pg \
rubygem-rugged>=1.1<2:devel/rubygem-rugged \
- rubygem-grape-path-helpers>=1.6.3<1.7:devel/rubygem-grape-path-helpers \
+ rubygem-grape-path-helpers>=1.7.0<1.8:devel/rubygem-grape-path-helpers \
rubygem-faraday>=1.0<2:www/rubygem-faraday \
rubygem-marginalia>=1.10.0<1.11:databases/rubygem-marginalia \
rubygem-declarative_policy>=1.0.0<1.1:security/rubygem-declarative_policy \
@@ -40,7 +40,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-doorkeeper>=5.5.0.rc2<5.6:security/rubygem-doorkeeper \
rubygem-doorkeeper-openid_connect>=1.7.5<1.8:security/rubygem-doorkeeper-openid_connect \
rubygem-rexml>=3.2.5<3.3:textproc/rubygem-rexml \
- rubygem-ruby-saml>=1.12.1<1.13:security/rubygem-ruby-saml \
+ rubygem-ruby-saml>=1.13.0<1.14:security/rubygem-ruby-saml \
rubygem-omniauth1>=1.9.1<2.0:security/rubygem-omniauth1 \
rubygem-omniauth-auth0>=2.0.0<2.1.0:net/rubygem-omniauth-auth0 \
rubygem-omniauth-azure-activedirectory-v2>=1.0<2:net/rubygem-omniauth-azure-activedirectory-v2 \
@@ -93,7 +93,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-hamlit>=2.15.0<2.16:www/rubygem-hamlit \
rubygem-carrierwave>=1.3.2<2.0:www/rubygem-carrierwave \
rubygem-mini_magick>=4.10.1<4.11:graphics/rubygem-mini_magick \
- rubygem-fog-aws>=3.9<4.0:net/rubygem-fog-aws \
+ rubygem-fog-aws>=3.12<4:net/rubygem-fog-aws \
rubygem-fog-core210=2.1.0:devel/rubygem-fog-core210 \
rubygem-fog-google>=1.15<2:net/rubygem-fog-google \
rubygem-fog-local>=0.6<1.0:net/rubygem-fog-local \
@@ -155,7 +155,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-device_detector>=0:devel/rubygem-device_detector \
rubygem-redis>=4.1.4<5:databases/rubygem-redis \
rubygem-connection_pool>=2.0<3.0:net/rubygem-connection_pool \
- rubygem-redis-rails-rails61>=5.0.2<5.1:www/rubygem-redis-rails-rails61 \
+ rubygem-redis-actionpack-rails61>=5.2.0<5.3:databases/rubygem-redis-actionpack-rails61 \
rubygem-discordrb-webhooks>=3.4<4.0:net-im/rubygem-discordrb-webhooks \
rubygem-jira-ruby>=2.1.4<2.2:devel/rubygem-jira-ruby \
rubygem-atlassian-jwt>=0.2.0<0.3.0:www/rubygem-atlassian-jwt \
@@ -188,7 +188,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-sentry-raven>=3.1<4.0:devel/rubygem-sentry-raven \
rubygem-pg_query>=2.1<3:databases/rubygem-pg_query \
rubygem-premailer-rails-rails61>=1.10.3<1.11.0:mail/rubygem-premailer-rails-rails61 \
- rubygem-gitlab-labkit>=0.21.0<0.22:devel/rubygem-gitlab-labkit \
+ rubygem-gitlab-labkit>=0.21.1<0.22:devel/rubygem-gitlab-labkit \
rubygem-thrift>=0.14.0:devel/rubygem-thrift \
rubygem-ruby_parser>=3.15<4.0:devel/rubygem-ruby_parser \
rubygem-rails-i18n-rails61>=6.0<7.0:devel/rubygem-rails-i18n-rails61 \
@@ -200,7 +200,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-snowplow-tracker>=0.6.1<0.7.0:devel/rubygem-snowplow-tracker \
rubygem-method_source>=1.0<2:devel/rubygem-method_source \
rubygem-webrick>=1.6.1:www/rubygem-webrick \
- rubygem-prometheus-client-mmap>=0.12.0<0.13.0:devel/rubygem-prometheus-client-mmap \
+ rubygem-prometheus-client-mmap>=0.15.0<0.16.0:devel/rubygem-prometheus-client-mmap \
rubygem-warning>=1.2.0<1.3:devel/rubygem-warning \
rubygem-octokit>=4.20<5.0:net/rubygem-octokit \
rubygem-gitlab-mail_room>=0.0.9<0.1.0:mail/rubygem-gitlab-mail_room \
@@ -222,9 +222,9 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-ed25519>=1.2<2.0:security/rubygem-ed25519 \
rubygem-bcrypt_pbkdf>=1.0<2.0:security/rubygem-bcrypt_pbkdf \
rubygem-spamcheck>=0.1.0<0.2:net/rubygem-spamcheck \
- rubygem-gitaly>=14.2.0.pre.rc2<14.3.0:net/rubygem-gitaly \
- rubygem-kas-grpc>=0.0.2<0.1:net/rubygem-kas-grpc \
- rubygem-grpc>=1.38.0<2:net/rubygem-grpc \
+ rubygem-gitaly>=14.3.0.pre.rc1<14.4.0:net/rubygem-gitaly \
+ rubygem-kas-grpc>=0.0.2,1<0.0.3,1:net/rubygem-kas-grpc \
+ rubygem-grpc>=1.30.2<2:net/rubygem-grpc \
rubygem-google-protobuf317>=3.17.1<3.18:devel/rubygem-google-protobuf317 \
rubygem-toml-rb>=2.0.1<3:www/rubygem-toml-rb \
rubygem-flipper021>=0.21.0<0.22:devel/rubygem-flipper021 \
@@ -242,7 +242,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-mail>=2.7.1<2.7.2,2:mail/rubygem-mail \
rubygem-lockbox>=0.6.2<0.7:security/rubygem-lockbox \
rubygem-valid_email>=0.1<1:mail/rubygem-valid_email \
- rubygem-json>=2.3.0<2.4:devel/rubygem-json \
+ rubygem-json>=2.5.1<2.6:devel/rubygem-json \
rubygem-json_schemer>=0.2.18<0.3:devel/rubygem-json_schemer \
rubygem-oj310>=3.10.6<3.11:devel/rubygem-oj310 \
rubygem-multi_json114>=1.14.1<1.15:devel/rubygem-multi_json114 \
@@ -270,7 +270,7 @@ USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
GL_PROJECT= gitlab-foss
# Find the here: https://gitlab.com/gitlab-org/gitlab-foss/-/tags
-GL_COMMIT= 8d08c6cbe51a88fbdc5065aba6e459768e98e63b
+GL_COMMIT= ceec8accb09a4c43d70896440d3662bf6dc765dc
USERS= git
GROUPS= git
@@ -316,6 +316,7 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/www/${PORTNAME}/tmp/cache
${MKDIR} ${STAGEDIR}${PREFIX}/www/${PORTNAME}/tmp/sessions
${MKDIR} ${STAGEDIR}${PREFIX}/www/${PORTNAME}/tmp/backups
+ ${MKDIR} ${STAGEDIR}${PREFIX}/www/${PORTNAME}/tmp/sockets/private/internal
${MKDIR} ${STAGEDIR}${PREFIX}/www/${PORTNAME}/shared/tmp
${MKDIR} ${STAGEDIR}${PREFIX}/www/${PORTNAME}/shared/artifacts/tmp/work
${MKDIR} ${STAGEDIR}${PREFIX}/www/${PORTNAME}/vendor/assets/stylesheets
@@ -381,7 +382,6 @@ post-install:
@${ECHO_CMD} "@dir(,,700) ${WWWDIR_REL}/shared/tmp" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,700) ${WWWDIR_REL}/shared/lfs-objects" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,700) ${WWWDIR_REL}/shared/registry" >> ${TMPPLIST}
- @${ECHO_CMD} "@dir(,,700) ${WWWDIR_REL}/spec/javascripts/fixtures" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/backups" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/cache" >> ${TMPPLIST}
@@ -394,6 +394,7 @@ post-install:
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/sessions" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/sockets" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/sockets/private" >> ${TMPPLIST}
+ @${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/sockets/private/internal" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/vendor" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/vendor/assets" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/vendor/assets/stylesheets" >> ${TMPPLIST}
diff --git a/www/gitlab-ce/distinfo b/www/gitlab-ce/distinfo
index 1d395ec50020..94431566dc20 100644
--- a/www/gitlab-ce/distinfo
+++ b/www/gitlab-ce/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1630441634
-SHA256 (gitlab-org-gitlab-foss-8d08c6cbe51a88fbdc5065aba6e459768e98e63b_GL0.tar.gz) = 43ae952fc8ba070ec18f24e6a6b00c07ade8f3e4a5b5016e1a511c1a1b5a5414
-SIZE (gitlab-org-gitlab-foss-8d08c6cbe51a88fbdc5065aba6e459768e98e63b_GL0.tar.gz) = 94812882
+TIMESTAMP = 1632242433
+SHA256 (gitlab-org-gitlab-foss-ceec8accb09a4c43d70896440d3662bf6dc765dc_GL0.tar.gz) = 2d35066e0067b3a722a40e61933f44131864021860775ea542c63e1651d53b51
+SIZE (gitlab-org-gitlab-foss-ceec8accb09a4c43d70896440d3662bf6dc765dc_GL0.tar.gz) = 94739477
diff --git a/www/gitlab-ce/files/patch-Gemfile b/www/gitlab-ce/files/patch-Gemfile
index a943c286e3d3..ea879687e2dc 100644
--- a/www/gitlab-ce/files/patch-Gemfile
+++ b/www/gitlab-ce/files/patch-Gemfile
@@ -1,4 +1,4 @@
---- Gemfile.orig 2021-08-31 13:57:34 UTC
+--- Gemfile.orig 2021-09-21 10:06:28 UTC
+++ Gemfile
@@ -88,7 +88,7 @@ gem 'gpgme', '~> 2.0.19'
# GitLab fork with several improvements to original library. For full list of changes
@@ -26,16 +26,15 @@
gem 'connection_pool', '~> 2.0'
# Redis session store
-@@ -332,105 +331,10 @@ gem 'snowplow-tracker', '~> 0.6.1'
+@@ -332,106 +331,10 @@ gem 'snowplow-tracker', '~> 0.6.1'
# Metrics
gem 'method_source', '~> 1.0', require: false
-gem 'webrick', '~> 1.6.1', require: false
-+gem 'webrick', '~> 1.6', require: false
- gem 'prometheus-client-mmap', '~> 0.12.0', require: 'prometheus/client'
+ gem 'prometheus-client-mmap', '~> 0.15.0', require: 'prometheus/client'
gem 'warning', '~> 1.2.0'
--
+
-group :development do
- gem 'lefthook', '~> 0.7.0', require: false
- gem 'solargraph', '~> 0.43', require: false
@@ -71,7 +70,7 @@
- gem 'spring', '~> 2.1.0'
- gem 'spring-commands-rspec', '~> 1.0.4'
-
-- gem 'gitlab-styles', '~> 6.2.0', require: false
+- gem 'gitlab-styles', '~> 6.3.0', require: false
-
- gem 'haml_lint', '~> 0.36.0', require: false
- gem 'bundler-audit', '~> 0.7.0.1', require: false
@@ -130,6 +129,16 @@
- # Moved in `test` because https://gitlab.com/gitlab-org/gitlab/-/issues/217527
- gem 'derailed_benchmarks', require: false
-end
-
+-
gem 'octokit', '~> 4.15'
+ # https://gitlab.com/gitlab-org/gitlab/issues/207207
+@@ -479,7 +382,7 @@ gem 'gitaly', '~> 14.3.0.pre.rc1'
+ # KAS GRPC protocol definitions
+ gem 'kas-grpc', '~> 0.0.2'
+
+-gem 'grpc', '~> 1.30.2'
++gem 'grpc', '~> 1.30'
+
+ gem 'google-protobuf', '~> 3.17.1'
+
diff --git a/www/gitlab-ce/files/patch-bin_background__jobs__sk b/www/gitlab-ce/files/patch-bin_background__jobs__sk
deleted file mode 100644
index cb91657ec11e..000000000000
--- a/www/gitlab-ce/files/patch-bin_background__jobs__sk
+++ /dev/null
@@ -1,20 +0,0 @@
---- bin/background_jobs_sk.orig 2020-03-27 13:35:17 UTC
-+++ bin/background_jobs_sk
-@@ -14,7 +14,7 @@ warn()
-
- stop()
- {
-- bundle exec sidekiqctl stop $sidekiq_pidfile >> $sidekiq_logfile 2>&1
-+ bundle exec sidekiqctl stop $sidekiq_pidfile >> $sidekiq_logfile 2>&1
- }
-
- restart()
-@@ -42,7 +42,7 @@ start_sidekiq()
- cmd="${cmd} ${chpst} -P"
- fi
-
-- ${cmd} bundle exec sidekiq -C "${sidekiq_config}" -e $RAILS_ENV "$@"
-+ ${cmd} bundle exec sidekiq -C "${sidekiq_config}" -e $RAILS_ENV "$@"
- }
-
- case "$1" in
diff --git a/www/gitlab-ce/files/patch-config_gitlab.yml.example b/www/gitlab-ce/files/patch-config_gitlab.yml.example
index 89723cc9c122..fab515d68357 100644
--- a/www/gitlab-ce/files/patch-config_gitlab.yml.example
+++ b/www/gitlab-ce/files/patch-config_gitlab.yml.example
@@ -1,6 +1,6 @@
---- config/gitlab.yml.example.orig 2021-08-23 16:27:44 UTC
+--- config/gitlab.yml.example.orig 2021-09-21 10:06:28 UTC
+++ config/gitlab.yml.example
-@@ -1123,8 +1123,8 @@ production: &base
+@@ -1128,8 +1128,8 @@ production: &base
# real path not the symlink.
storages: # You must have at least a `default` storage path.
default:
@@ -11,7 +11,7 @@
# gitaly_token: 'special token' # Optional: override global gitaly.token for this storage.
## Backup settings
-@@ -1171,12 +1171,12 @@ production: &base
+@@ -1184,12 +1184,12 @@ production: &base
## GitLab Shell settings
gitlab_shell:
@@ -27,7 +27,7 @@
# Git over HTTP
upload_pack: true
-@@ -1191,13 +1191,13 @@ production: &base
+@@ -1204,13 +1204,13 @@ production: &base
workhorse:
# File that contains the secret key for verifying access for gitlab-workhorse.
# Default is '.gitlab_workhorse_secret' relative to Rails.root (i.e. root of the GitLab app).
@@ -43,7 +43,7 @@
# The URL to the external KAS API (used by the Kubernetes agents)
# external_url: wss://kas.example.com
-@@ -1207,13 +1207,13 @@ production: &base
+@@ -1220,13 +1220,13 @@ production: &base
## GitLab Elasticsearch settings
elasticsearch:
@@ -59,7 +59,7 @@
## Webpack settings
# If enabled, this will tell rails to serve frontend assets from the webpack-dev-server running
-@@ -1440,7 +1440,7 @@ test:
+@@ -1453,7 +1453,7 @@ test:
gitaly_address: unix:tmp/tests/gitaly/praefect.socket
gitaly:
diff --git a/www/gitlab-ce/files/patch-config_initializers_1__settings.rb b/www/gitlab-ce/files/patch-config_initializers_1__settings.rb
index 700475acbec5..7bf3581974c1 100644
--- a/www/gitlab-ce/files/patch-config_initializers_1__settings.rb
+++ b/www/gitlab-ce/files/patch-config_initializers_1__settings.rb
@@ -1,6 +1,6 @@
---- config/initializers/1_settings.rb.orig 2021-08-23 16:27:44 UTC
+--- config/initializers/1_settings.rb.orig 2021-09-21 10:06:28 UTC
+++ config/initializers/1_settings.rb
-@@ -184,11 +184,7 @@ Settings.gitlab['url'] ||= Settings.__send__(:build_gi
+@@ -185,11 +185,7 @@ Settings.gitlab['url'] ||= Settings.__send__(:build_gi
Settings.gitlab['user'] ||= 'git'
# External configuration may cause the ssh user to differ from the GitLab user
Settings.gitlab['ssh_user'] ||= Settings.gitlab.user
diff --git a/www/gitlab-ce/pkg-message b/www/gitlab-ce/pkg-message
index 5b67ecb3b3ff..b245648b6653 100644
--- a/www/gitlab-ce/pkg-message
+++ b/www/gitlab-ce/pkg-message
@@ -6,7 +6,7 @@ Gitlab was installed successfully.
You now need to set up the various components of Gitlab, so please
follow the instructions in the guide at:
-https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/install/14.2-freebsd.md
+https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/install/14.3-freebsd.md
EOM
type: install
}
@@ -20,7 +20,7 @@ EOM
If you just installed an major upgrade of GitLab, for example you
switched from 12.6.x to 12.7.x, please follow the instructions in the guide at:
-https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/update/14.1-14.2-freebsd.md
+https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/update/14.2-14.3-freebsd.md
If you just installed an minor upgrade of GitLab please follow
the instructions in the guide at: