aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2022-11-23 02:51:31 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2022-11-23 02:54:05 +0000
commitfb48078990706bd1af7dd8ad5b601395876ba651 (patch)
treef5fa06d0546862f9521a3172c0e92de79c2494d0
parent0a8e8e130dd14e832e786f7d80f72282fac14c45 (diff)
downloadports-fb48078990706bd1af7dd8ad5b601395876ba651.tar.gz
ports-fb48078990706bd1af7dd8ad5b601395876ba651.zip
databases:firebird40-*: Update to 4.0.2
-rw-r--r--databases/firebird40-server/Makefile9
-rw-r--r--databases/firebird40-server/distinfo6
-rw-r--r--databases/firebird40-server/files/patch-extern_cloop_Makefile17
-rw-r--r--databases/firebird40-server/files/patch-src_remote_SockAddr.h25
4 files changed, 14 insertions, 43 deletions
diff --git a/databases/firebird40-server/Makefile b/databases/firebird40-server/Makefile
index bfc9c04af4c5..800515207c12 100644
--- a/databases/firebird40-server/Makefile
+++ b/databases/firebird40-server/Makefile
@@ -1,15 +1,12 @@
PORTNAME= firebird
-PORTVERSION= 4.0.0
-PORTREVISION= 4
+PORTVERSION= 4.0.2
+PORTREVISION= 0
CATEGORIES?= databases
MASTER_SITES= https://github.com/FirebirdSQL/${PORTNAME}/releases/download/v${PORTVERSION}/
PKGNAMESUFFIX?= ${PORTVERSION:R:S/.//}-server
-DISTNAME= ${PORTNAME:S/f/F/}-${PORTVERSION}.2496-0
+DISTNAME= ${PORTNAME:S/f/F/}-${PORTVERSION}.2816-0
DIST_SUBDIR= ${PORTNAME}
-PATCH_SITES= https://github.com/FirebirdSQL/firebird/commit/
-PATCHFILES= 96931200340c8e0abcd3529b8e443d5ab62adfa5.patch:-p1
-
MAINTAINER= acm@FreeBSD.org
COMMENT?= Firebird-4 relational database (server)
WWW= https://www.firebirdsql.org/
diff --git a/databases/firebird40-server/distinfo b/databases/firebird40-server/distinfo
index f6ab8f53d3ce..4cc2b3984a4a 100644
--- a/databases/firebird40-server/distinfo
+++ b/databases/firebird40-server/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1659115441
-SHA256 (firebird/Firebird-4.0.0.2496-0.tar.xz) = c155b8893e39d27c90f164d4865a7940749f47e971c7da6cf4828c980c708a57
-SIZE (firebird/Firebird-4.0.0.2496-0.tar.xz) = 30522192
+TIMESTAMP = 1669081398
+SHA256 (firebird/Firebird-4.0.2.2816-0.tar.xz) = fb28140cec1eb32ea683bdf552dd1d6b7d455db61282fcf96fae18b3103af6c6
+SIZE (firebird/Firebird-4.0.2.2816-0.tar.xz) = 30665764
SHA256 (firebird/96931200340c8e0abcd3529b8e443d5ab62adfa5.patch) = cf70a42c4d92b06ecf7a75131ed04dfbb471aba8c78eda66a3412f12b9084d58
SIZE (firebird/96931200340c8e0abcd3529b8e443d5ab62adfa5.patch) = 4011
diff --git a/databases/firebird40-server/files/patch-extern_cloop_Makefile b/databases/firebird40-server/files/patch-extern_cloop_Makefile
index ccc6f08bcc04..f5ca1c8dd566 100644
--- a/databases/firebird40-server/files/patch-extern_cloop_Makefile
+++ b/databases/firebird40-server/files/patch-extern_cloop_Makefile
@@ -1,6 +1,6 @@
---- extern/cloop/Makefile.orig 2020-10-12 00:02:22 UTC
-+++ extern/cloop/Makefile
-@@ -6,7 +6,7 @@ TARGET := release
+--- extern/cloop/Makefile.orig 2022-08-10 04:04:28.000000000 -0500
++++ extern/cloop/Makefile 2022-11-21 20:57:09.474150000 -0500
+@@ -6,7 +6,7 @@
CC := $(CC)
CXX := $(CXX)
@@ -9,16 +9,15 @@
SRC_DIR := src
BUILD_DIR := build
-@@ -27,8 +27,9 @@ SRCS_CPP := $(foreach sdir,$(SRC_DIRS),$
+@@ -27,8 +27,9 @@
OBJS_C := $(patsubst $(SRC_DIR)/%.c,$(OBJ_DIR)/%.o,$(SRCS_C))
OBJS_CPP := $(patsubst $(SRC_DIR)/%.cpp,$(OBJ_DIR)/%.o,$(SRCS_CPP))
-C_FLAGS := -ggdb -fPIC -MMD -MP -W -Wall -Wno-unused-parameter
--CXX_FLAGS := $(C_FLAGS)
+-CXX_FLAGS := $(C_FLAGS) -std=c++11
+COMMON_C_FLAGS := -ggdb -fPIC -MMD -MP -W -Wall -Wno-unused-parameter
+C_FLAGS := $(COMMON_C_FLAGS) $(CFLAGS) $(CPPFLAGS)
-+CXX_FLAGS := $(COMMON_C_FLAGS) $(CXXFLAGS) $(CPPFLAGS)
- FPC_FLAGS := -Mdelphi
++CXX_FLAGS := $(COMMON_C_FLAGS) $(CXXFLAGS) $(CPPFLAGS) -std=c++11
+ FPC_FLAGS := -Mdelphi -Cg
- ifeq ($(TARGET),release)
-
+ ifeq ($(shell uname),FreeBSD)
diff --git a/databases/firebird40-server/files/patch-src_remote_SockAddr.h b/databases/firebird40-server/files/patch-src_remote_SockAddr.h
deleted file mode 100644
index 30297137c2c5..000000000000
--- a/databases/firebird40-server/files/patch-src_remote_SockAddr.h
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/remote/SockAddr.h.orig 2020-10-12 00:02:22 UTC
-+++ src/remote/SockAddr.h
-@@ -112,11 +112,13 @@ public:
-
- #define AF_INET6_POSIX 10
- #define AF_INET6_WINDOWS 23
-+#define AF_INET6_BSD 28
- #define AF_INET6_DARWIN 30
-
- #if AF_INET6 == AF_INET6_POSIX
- #elif AF_INET6 == AF_INET6_WINDOWS
- #elif AF_INET6 == AF_INET6_DARWIN
-+#elif AF_INET6 == AF_INET6_BSD
- #else
- #error Unknown value of AF_INET6 !
- #endif
-@@ -132,6 +134,7 @@ inline void SockAddr::checkAndFixFamily(
- case AF_INET6_POSIX:
- case AF_INET6_WINDOWS:
- case AF_INET6_DARWIN:
-+ case AF_INET6_BSD:
- data.sock.sa_family = AF_INET6;
- fb_assert(len == sizeof(sockaddr_in6));
- break;
-