aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-10-11 20:23:42 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-10-12 10:15:38 +0000
commitfb91445edeab0e0d2e6273600ed604da50fb2ee8 (patch)
treeee955455f42f4684129fe63bae6f1846d497717f
parentf7a1442b3ad461e3250072bcdb38f9d898a783f8 (diff)
downloadports-fb91445edeab0e0d2e6273600ed604da50fb2ee8.tar.gz
ports-fb91445edeab0e0d2e6273600ed604da50fb2ee8.zip
graphics/dcmtk: use LLVM 15 on powerpc* when 14 is in the system
LLVM 14 crashes: Assertion failed: (all_of(I->users(), [&InsertedSet](Value *U) { return InsertedSet.contains(cast<Instruction>(U)); }) && "removed instruction should only be used by instructions inserted " "during expansion"), function cleanup, file /usr/local/poudriere/jails/powerpc64-140/usr/src/contrib/llvm-project/llvm/lib/Transforms/Utils/ScalarEvolutionExpander.cpp, line 2798.
-rw-r--r--graphics/dcmtk/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/graphics/dcmtk/Makefile b/graphics/dcmtk/Makefile
index f1e606b9bec1..eb97a85aed4e 100644
--- a/graphics/dcmtk/Makefile
+++ b/graphics/dcmtk/Makefile
@@ -32,4 +32,13 @@ PORTDOCS= *
TEST_TARGET= test test-exhaustive
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH:Mpowerpc*} && ${COMPILER_VERSION} == 140
+LLVM_VER= 15
+BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
+CC= ${LOCALBASE}/bin/clang${LLVM_VER}
+CXX= ${LOCALBASE}/bin/clang++${LLVM_VER}
+.endif
+
+.include <bsd.port.post.mk>