aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2022-08-27 14:37:17 +0000
committerThierry Thomas <thierry@FreeBSD.org>2022-08-27 14:40:55 +0000
commitfbab55b27f97ce1d6cf067a1583b28716f2e127c (patch)
tree7d78c3c9f3c468822c8c83ab2a67f1b4e55a4ef2
parent44cb38ae10c564a7168fc7d66e8e6e32e3d9e897 (diff)
downloadports-fbab55b27f97ce1d6cf067a1583b28716f2e127c.tar.gz
ports-fbab55b27f97ce1d6cf067a1583b28716f2e127c.zip
math/libdivide: fix build on armv6/armv7
The NEON code included in this library is for arm64 only. Disable use of NEON on armv6/armv7. See <https://github.com/ridiculousfish/libdivide/issues/102>. PR: 265870 Reported by: fuz (at) fuz.su
-rw-r--r--math/libdivide/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/math/libdivide/Makefile b/math/libdivide/Makefile
index ca5c50a09bb7..8e43501a4eb0 100644
--- a/math/libdivide/Makefile
+++ b/math/libdivide/Makefile
@@ -14,6 +14,11 @@ GH_ACCOUNT= ridiculousfish
USES= cmake compiler:c++11-lang
NO_ARCH= yes
+# NEON support requires arm64
+CMAKE_OFF_armv6= LIBDIVIDE_NEON
+CMAKE_OFF_armv7= LIBDIVIDE_NEON
+CMAKE_OFF= ${CMAKE_OFF_${ARCH}}
+
PLIST_FILES= include/libdivide.h \
lib/cmake/libdivide/libdivideConfig.cmake \
lib/cmake/libdivide/libdivideConfigVersion.cmake