aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2022-05-03 16:27:01 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2022-05-03 16:27:01 +0000
commitfc0a979a30ea24c8d28d8a3893bb5ac0549e56cb (patch)
tree3fbd01ec3a15157609cd359f107e0be45e320fbc
parent0139633fd311e7690f42ac9f4ac9c3e87e9d7e2e (diff)
downloadports-fc0a979a30ea24c8d28d8a3893bb5ac0549e56cb.tar.gz
ports-fc0a979a30ea24c8d28d8a3893bb5ac0549e56cb.zip
www/firefox{,-esr}, mail/thunderbird: remote LTO from default options
When rust's internal LLVM does not match the LLVM used for building gecko ports, LTO-built binaries will be unstable, exhibit crashes and other undesirable behaviour. Rust 1.60 created such a situation. Disabling LTO will allow these ports to be used, and keeping it off will safe on build and debug time.
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/Makefile.options2
4 files changed, 3 insertions, 5 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 679dfc9d0e24..3507408aac71 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -2,7 +2,7 @@
PORTNAME= thunderbird
DISTVERSION= 91.9.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail news net-im
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build3/source
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 8988ae4bc703..12f4ace9f7b4 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -2,7 +2,7 @@
PORTNAME= firefox
DISTVERSION= 91.9.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 6e3312fbe7a5..ae0b1ad6f1fb 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -2,7 +2,7 @@
PORTNAME= firefox
DISTVERSION= 100.0
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/firefox/Makefile.options b/www/firefox/Makefile.options
index a277e8f44d1e..d5a417480eb3 100644
--- a/www/firefox/Makefile.options
+++ b/www/firefox/Makefile.options
@@ -5,8 +5,6 @@ OPTIONS_DEFINE+= CANBERRA DBUS DEBUG FFMPEG \
OPTIONS_DEFAULT+= DBUS FFMPEG OPTIMIZED_CFLAGS PROFILE \
${OPTIONS_GROUP_AUDIO:NALSA}
-OPTIONS_DEFAULT_aarch64+= LTO
-OPTIONS_DEFAULT_amd64+= LTO
OPTIONS_GROUP+= AUDIO
OPTIONS_GROUP_AUDIO= ALSA JACK PULSEAUDIO SNDIO