aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-16 03:57:22 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-16 04:19:21 +0000
commitfc36df088218261dd8d96b72c2b6400efc079f07 (patch)
treebc523433650cbee4ede49d410dbca991e9836f7d
parenta5d7f6b9cf223f60d11f252e9d3e381c08891c96 (diff)
devel/py-jeepney: Update to 0.8.0
-rw-r--r--devel/py-jeepney/Makefile7
-rw-r--r--devel/py-jeepney/distinfo6
-rw-r--r--devel/py-jeepney/files/setup.py32
3 files changed, 40 insertions, 5 deletions
diff --git a/devel/py-jeepney/Makefile b/devel/py-jeepney/Makefile
index 3905da195b2e..852eb0480997 100644
--- a/devel/py-jeepney/Makefile
+++ b/devel/py-jeepney/Makefile
@@ -1,7 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= jeepney
-PORTVERSION= 0.7.1
+PORTVERSION= 0.8.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,9 +12,12 @@ COMMENT= Low-level, pure Python DBus protocol wrapper
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+post-patch:
+ @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
+
.include <bsd.port.mk>
diff --git a/devel/py-jeepney/distinfo b/devel/py-jeepney/distinfo
index e86d8c752929..327875e79d9d 100644
--- a/devel/py-jeepney/distinfo
+++ b/devel/py-jeepney/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1628103120
-SHA256 (jeepney-0.7.1.tar.gz) = fa9e232dfa0c498bd0b8a3a73b8d8a31978304dcef0515adc859d4e096f96f4f
-SIZE (jeepney-0.7.1.tar.gz) = 61833
+TIMESTAMP = 1649423788
+SHA256 (jeepney-0.8.0.tar.gz) = 5efe48d255973902f6badc3ce55e2aa6c5c3b3bc642059ef3a91247bcfcc5806
+SIZE (jeepney-0.8.0.tar.gz) = 106005
diff --git a/devel/py-jeepney/files/setup.py b/devel/py-jeepney/files/setup.py
new file mode 100644
index 000000000000..28b4a1ec913e
--- /dev/null
+++ b/devel/py-jeepney/files/setup.py
@@ -0,0 +1,32 @@
+#!/usr/bin/env python
+# setup.py generated by flit for tools that don't yet use PEP 517
+
+from distutils.core import setup
+
+packages = \
+['jeepney', 'jeepney.io', 'jeepney.io.tests', 'jeepney.tests']
+
+package_data = \
+{'': ['*']}
+
+extras_require = \
+{'test': ['pytest',
+ 'pytest-trio',
+ 'pytest-asyncio >=0.17',
+ 'testpath',
+ 'trio',
+ 'async-timeout'],
+ 'trio': ['trio'],
+ "trio:python_version == '3.6'": ['async_generator']}
+
+setup(name='jeepney',
+ version='%%PORTVERSION%%',
+ description='Low-level, pure Python DBus protocol wrapper.',
+ author='Thomas Kluyver',
+ author_email='thomas@kluyver.me.uk',
+ url='https://gitlab.com/takluyver/jeepney',
+ packages=packages,
+ package_data=package_data,
+ extras_require=extras_require,
+ python_requires='>=3.7',
+ )