aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-12-11 02:10:48 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-12-11 02:10:48 +0000
commitfc438e9c3ee6144c7fb8d869aaad3ec69abe85fb (patch)
treeed633e47cf6cb90e6656d62eb0e0cad8c6aab55f
parent76c184acf692c17cb6011b7098808ed67f47548f (diff)
downloadports-fc438e9c3ee6144c7fb8d869aaad3ec69abe85fb.tar.gz
ports-fc438e9c3ee6144c7fb8d869aaad3ec69abe85fb.zip
o Replace previous mldonkey GUI with new mlgui version 2.
o Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=150844
-rw-r--r--net-p2p/mldonkey-devel/Makefile8
-rw-r--r--net/mldonkey-devel/Makefile8
2 files changed, 10 insertions, 6 deletions
diff --git a/net-p2p/mldonkey-devel/Makefile b/net-p2p/mldonkey-devel/Makefile
index 107b81957d14..68be3e90ee49 100644
--- a/net-p2p/mldonkey-devel/Makefile
+++ b/net-p2p/mldonkey-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mldonkey
PORTVERSION= 2.7.1
+PORTREVISION= 1
CATEGORIES+= net
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -59,11 +60,12 @@ CONFLICTS+= mldonkey-gui-[0.9]*
.if !defined(WITHOUT_CORE)
CONFLICTS+= mldonkey-devel-[0-9]*
.endif
-BUILD_DEPENDS+= lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk \
+BUILD_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2 \
${LOCALBASE}/lib/ocaml/jabbr.cma:${PORTSDIR}/net-im/ocaml-jabbr
-LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
+LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd \
+ rsvg-2.2:${PORTSDIR}/graphics/librsvg
-CONFIGURE_ARGS+=--enable-gui=newgui1
+CONFIGURE_ARGS+=--enable-gui=newgui2
# we don't need lablgtk as RUN dependency, but we need gtk+glib
USE_GNOME= gtk12
diff --git a/net/mldonkey-devel/Makefile b/net/mldonkey-devel/Makefile
index 107b81957d14..68be3e90ee49 100644
--- a/net/mldonkey-devel/Makefile
+++ b/net/mldonkey-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mldonkey
PORTVERSION= 2.7.1
+PORTREVISION= 1
CATEGORIES+= net
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -59,11 +60,12 @@ CONFLICTS+= mldonkey-gui-[0.9]*
.if !defined(WITHOUT_CORE)
CONFLICTS+= mldonkey-devel-[0-9]*
.endif
-BUILD_DEPENDS+= lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk \
+BUILD_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2 \
${LOCALBASE}/lib/ocaml/jabbr.cma:${PORTSDIR}/net-im/ocaml-jabbr
-LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
+LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd \
+ rsvg-2.2:${PORTSDIR}/graphics/librsvg
-CONFIGURE_ARGS+=--enable-gui=newgui1
+CONFIGURE_ARGS+=--enable-gui=newgui2
# we don't need lablgtk as RUN dependency, but we need gtk+glib
USE_GNOME= gtk12