aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-04-26 10:14:38 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-04-26 10:17:38 +0000
commitfc6c79393bc7d87ea5ee6181e504a9c0b37964f8 (patch)
treeb22631d28eea6ca743334363ded43552b69c76c5
parentc7e7e9abc20a75be7219a04beceefd5f2903b851 (diff)
downloadports-fc6c79393bc7d87ea5ee6181e504a9c0b37964f8.tar.gz
ports-fc6c79393bc7d87ea5ee6181e504a9c0b37964f8.zip
science/frontistr adding FrontISTR
This is an Open-Source Large-Scale Parallel FEM Program for Nonlinear Structural Analysis.
-rw-r--r--science/Makefile1
-rw-r--r--science/frontistr/Makefile56
-rw-r--r--science/frontistr/distinfo3
-rw-r--r--science/frontistr/pkg-descr5
-rw-r--r--science/frontistr/pkg-plist6
5 files changed, 71 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 03a8a852d714..e0c5545b0e69 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -76,6 +76,7 @@
SUBDIR += fasthenry
SUBDIR += fastjet
SUBDIR += fisicalab
+ SUBDIR += frontistr
SUBDIR += fsom
SUBDIR += fvcom
SUBDIR += fvcom-mpi
diff --git a/science/frontistr/Makefile b/science/frontistr/Makefile
new file mode 100644
index 000000000000..b232e4f0e747
--- /dev/null
+++ b/science/frontistr/Makefile
@@ -0,0 +1,56 @@
+# Created by: Thierry Thomas <thierry@pompo.net>
+
+PORTNAME= FrontISTR
+PORTVERSION= 5.2
+DISTVERSIONPREFIX= v
+CATEGORIES= science cad
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Large-Scale Parallel FEM Program for Nonlinear Structural Analysis
+
+LICENSE= MIT
+
+LIB_DEPENDS= libmetis.so:math/metis \
+ libscotch.so:cad/scotch \
+ libcmumps.so.5:math/mumps \
+ libscalapack.so:math/scalapack
+TEST_DEPENDS= bash:shells/bash \
+ gawk:lang/gawk
+
+USE_GITLAB= yes
+GL_ACCOUNT= ${PORTNAME}-Commons
+GL_COMMIT= c66bdc397de319ca59a0565b3f3b1a3b33f0c50c
+
+USES= blaslapack:openblas cmake:testing fortran mpi shebangfix
+SHEBANG_GLOB= *.sh
+FFLAGS+= -fallow-argument-mismatch
+ALL_TARGET= all
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+DOCS_USES= python:build
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
+ dot:graphics/graphviz \
+ ${PYTHON_PKGNAMEPREFIX}mkdocs>0:textproc/py-mkdocs@${PY_FLAVOR}
+DOCS_CMAKE_BOOL= WITH_DOC
+DOCS_ALL_TARGET= doc
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's/awk/gawk/' ${WRKSRC}/tests/test.sh
+
+do-install-DOCS-on:
+ ${FIND} ${BUILD_WRKSRC}/doc/html -type d -empty -delete
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${BUILD_WRKSRC}/doc/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
+
+do-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+
+do-test:
+ (cd ${TEST_WRKSRC} && ctest)
+
+.include <bsd.port.mk>
diff --git a/science/frontistr/distinfo b/science/frontistr/distinfo
new file mode 100644
index 000000000000..8354d652acfe
--- /dev/null
+++ b/science/frontistr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1619284091
+SHA256 (FrontISTR-Commons-FrontISTR-c66bdc397de319ca59a0565b3f3b1a3b33f0c50c_GL0.tar.gz) = f977bf0942ee782d006a510cf03f7a6846d15cdb1eda3ab8706bb404aa016ede
+SIZE (FrontISTR-Commons-FrontISTR-c66bdc397de319ca59a0565b3f3b1a3b33f0c50c_GL0.tar.gz) = 28063234
diff --git a/science/frontistr/pkg-descr b/science/frontistr/pkg-descr
new file mode 100644
index 000000000000..0fb6f0fd893d
--- /dev/null
+++ b/science/frontistr/pkg-descr
@@ -0,0 +1,5 @@
+FrontISTR is an Open-Source Large-Scale Parallel FEM Program for Nonlinear
+Structural Analysis.
+
+WWW: https://www.frontistr.com/
+WWW: https://gitlab.com/FrontISTR-Commons/FrontISTR
diff --git a/science/frontistr/pkg-plist b/science/frontistr/pkg-plist
new file mode 100644
index 000000000000..e340413dbc30
--- /dev/null
+++ b/science/frontistr/pkg-plist
@@ -0,0 +1,6 @@
+bin/fistr1
+bin/hec2rcap
+bin/hecmw_part1
+bin/hecmw_vis1
+bin/rconv
+bin/rmerge