aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Richardson <arichardson@llvm.org>2021-06-19 12:39:17 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2021-06-19 12:43:54 +0000
commitfd14cb96eb4d160d6d173447546ea025f55b2882 (patch)
tree4ac0b70251eef9d14583b81ffe41539fdc926537
parentd571f1f33222ae3c639baa517f53783fdf759e69 (diff)
downloadports-fd14cb96eb4d160d6d173447546ea025f55b2882.tar.gz
ports-fd14cb96eb4d160d6d173447546ea025f55b2882.zip
audio/lame: fix build on riscv
The previous commit only removed the BROKEN for riscv, but didn't add a patch. PR: 256583 Reported by: Robert Clausecker <fuz@fuz.su> Obtained from: LLVM project https://reviews.llvm.org/D89557
-rw-r--r--audio/lame/Makefile2
-rw-r--r--audio/lame/files/patch-libmp3lame_util.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/audio/lame/Makefile b/audio/lame/Makefile
index 5287c5cd8eca..6bae97c986f9 100644
--- a/audio/lame/Makefile
+++ b/audio/lame/Makefile
@@ -2,7 +2,7 @@
PORTNAME= lame
PORTVERSION= 3.100
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME:tl}/3.100
diff --git a/audio/lame/files/patch-libmp3lame_util.c b/audio/lame/files/patch-libmp3lame_util.c
new file mode 100644
index 000000000000..984bf2af9976
--- /dev/null
+++ b/audio/lame/files/patch-libmp3lame_util.c
@@ -0,0 +1,14 @@
+--- libmp3lame/util.c.orig 2021-06-11 15:08:59 UTC
++++ libmp3lame/util.c
+@@ -843,9 +843,8 @@ disable_FPE(void)
+ */
+
+
+-
+-
+-#if defined(__FreeBSD__) && !defined(__alpha__)
++/* https://reviews.llvm.org/D89557 */
++#if defined(__FreeBSD__) && defined(FP_X_INV) && defined(FP_X_DZ)
+ {
+ /* seet floating point mask to the Linux default */
+ fp_except_t mask;