aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-06-30 07:03:19 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-06-30 07:03:19 +0000
commitfe68c9ef68be72ac508602052aaf57a85d0b0f59 (patch)
treee0cba683c3b0f0646898684a6aab2515daa473e4
parent97da3a680169e06555a6804053dd6017b0168e2c (diff)
downloadports-fe68c9ef68be72ac508602052aaf57a85d0b0f59.tar.gz
ports-fe68c9ef68be72ac508602052aaf57a85d0b0f59.zip
devel/py-configupdater: Convert to USE_PYTHON=pep517
- Remove outdated PYTHON_REL check after lang/python37 removal - Bump PORTREVISION for package change
-rw-r--r--devel/py-configupdater/Makefile15
-rw-r--r--devel/py-configupdater/files/patch-setup.cfg9
2 files changed, 15 insertions, 9 deletions
diff --git a/devel/py-configupdater/Makefile b/devel/py-configupdater/Makefile
index 839f451c6f7d..226a374ecca0 100644
--- a/devel/py-configupdater/Makefile
+++ b/devel/py-configupdater/Makefile
@@ -1,5 +1,6 @@
PORTNAME= configupdater
PORTVERSION= 3.1.1
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,17 +13,13 @@ WWW= https://github.com/pyscaffold/configupdater
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=5:devel/py-setuptools_scm@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=46.1.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=5:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 30800
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=0:devel/py-importlib-metadata@${PY_FLAVOR}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/py-configupdater/files/patch-setup.cfg b/devel/py-configupdater/files/patch-setup.cfg
new file mode 100644
index 000000000000..31f67cd8c3fe
--- /dev/null
+++ b/devel/py-configupdater/files/patch-setup.cfg
@@ -0,0 +1,9 @@
+--- setup.cfg.orig 2022-06-26 18:37:07 UTC
++++ setup.cfg
+@@ -1,5 +1,5 @@
+ [metadata]
+-name = ConfigUpdater
++name = configupdater
+ description = Parser like ConfigParser but for updating configuration files
+ author = Florian Wilhelm
+ author_email = florian.wilhelm@gmail.com